[PATCH] gnu: mangohud: Update to 0.7.0.

  • Done
  • quality assurance status badge
Details
2 participants
  • John Kehayias
  • Ludovic Courtès
Owner
unassigned
Submitted by
John Kehayias
Severity
normal
J
J
John Kehayias wrote on 9 Oct 2023 06:23
(address . guix-patches@gnu.org)(name . John Kehayias)(address . john.kehayias@protonmail.com)
94feda96cdbfe16512a664d66dd25290320f762e.1696825155.git.john.kehayias@protonmail.com
* gnu/packages/graphics.scm (mangohud): Update to 0.7.0.
[arguments]<#:configure-flags>: Remove "-Duse_system_vulkan=enabled" and
"-Dvulkan_datadir" from as they are no longer supported.
<#:phases>: Add 'unbundle-vulkan-headers'.
[inputs]: Add nlohmann-json. Replace vulkan-headers with origin for
vulkan-headers@1.2.158.
[native-inputs]: Add git-minimal.
---

Here is a patch to update mangohud to the latest version. I've used
guix lint, built it locally, and also tested it works with vulkan. The
major change here is to manually unbundle vulkan-headers as that is no
longer a configurable option. To do this a bare origin is used to get
the source for the expected vulkan version (a specific older one is
required) and the build patched to use this.

Thanks!
John


gnu/packages/graphics.scm | 46 +++++++++++++++++++++++++++++----------
1 file changed, 35 insertions(+), 11 deletions(-)

Toggle diff (105 lines)
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 9362666274..c5be44b1e4 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -28,7 +28,7 @@
;;; Copyright © 2021 Ekaitz Zarraga <ekaitz@elenq.tech>
;;; Copyright © 2021, 2022 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2022 Michael Rohleder <mike@rohleder.de>
-;;; Copyright © 2022 John Kehayias <john.kehayias@protonmail.com>
+;;; Copyright © 2022, 2023 John Kehayias <john.kehayias@protonmail.com>
;;; Copyright © 2022 Zheng Junjie <873216071@qq.com>
;;; Copyright © 2022 Tobias Kortkamp <tobias.kortkamp@gmail.com>
;;; Copyright © 2022 Paul A. Patience <paul@apatience.com>
@@ -121,6 +121,7 @@ (define-module (gnu packages graphics)
#:use-module (gnu packages tbb)
#:use-module (gnu packages toolkits)
#:use-module (gnu packages upnp)
+ #:use-module (gnu packages version-control)
#:use-module (gnu packages video)
#:use-module (gnu packages vulkan)
#:use-module (gnu packages xiph)
@@ -1038,7 +1039,7 @@ (define-public alembic
(define-public mangohud
(package
(name "mangohud")
- (version "0.6.8")
+ (version "0.7.0")
(source
(origin
(method git-fetch)
@@ -1047,21 +1048,18 @@ (define-public mangohud
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "19dp8l5njzl9xah0bhwlkl39vc8w2rnpvpdrhgaz3hnhz8b0r5df"))))
+ (base32 "1m4a2dqzqdhk9w1gvzppid7k0fxvplh5hmivvj9sda529s1g24rc"))))
(build-system meson-build-system)
(arguments
(list
#:build-type "release"
#:configure-flags
- #~(list "-Duse_system_vulkan=enabled"
- "-Duse_system_spdlog=enabled"
+ #~(list "-Duse_system_spdlog=enabled"
"-Dwith_xnvctrl=disabled"
- "-Dappend_libdir_mangohud=false"
- (string-append "-Dvulkan_datadir="
- #$(this-package-input "vulkan-headers") "/share"))
+ "-Dappend_libdir_mangohud=false")
#:phases
#~(modify-phases %standard-phases
- ;; Mangohud tries to build the imgui library as a meson submodule,
+ ;; MangoHud tries to build the imgui library as a meson submodule,
;; so we change the dependency to the imgui input instead.
(add-after 'unpack 'unbundle-imgui
(lambda _
@@ -1073,6 +1071,23 @@ (define-public mangohud
"declare_dependency(dependencies: "
"cpp.find_library('imgui'), include_directories: '"
#$(this-package-input "imgui") "/include/imgui')")))))
+ ;; Likewise, MangoHud bundles a Vulkan headers submodule to use a
+ ;; specific version, which we provide as an input and adjust the
+ ;; build accordingly.
+ (add-after 'unbundle-imgui 'unbundle-vulkan-headers
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "meson.build"
+ (("vkh_sp = .*")
+ "")
+ (("vkh_sp.get_variable\\('vulkan_api_xml'\\)")
+ (string-append "files('"
+ (search-input-file inputs "registry/vk.xml")
+ "')"))
+ (("dep_vulkan = .*")
+ ""))
+ (substitute* "src/meson.build"
+ (("dep_vulkan,")
+ ""))))
(add-after 'unpack 'patch-paths
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "src/meson.build"
@@ -1098,11 +1113,20 @@ (define-public mangohud
libx11
mesa
mesa-utils
+ nlohmann-json
python-mako
spdlog
- vulkan-headers
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/KhronosGroup/Vulkan-Headers")
+ (commit "v1.2.158")))
+ (file-name (git-file-name "vulkan" "v1.2.158"))
+ (sha256
+ (base32
+ "0jvaqj87792yccpr290djb18pqaisspq9dw6bqim6mrhfgda9v76")))
vulkan-loader))
- (native-inputs (list pkg-config python))
+ (native-inputs (list git-minimal pkg-config python))
(home-page "https://github.com/flightlessmango/MangoHud/")
(synopsis "Vulkan and OpenGL overlay for monitoring performance and hardware")
(description "MangoHud is a Vulkan and OpenGL overlay for monitoring

base-commit: 321979a15317eaf93b15e9cca30d328d39cca4b1
--
2.41.0
L
L
Ludovic Courtès wrote on 14 Oct 2023 22:25
(name . John Kehayias)(address . john.kehayias@protonmail.com)(address . 66413@debbugs.gnu.org)
87zg0l9ck0.fsf@gnu.org
John Kehayias <john.kehayias@protonmail.com> skribis:

Toggle quote (8 lines)
> * gnu/packages/graphics.scm (mangohud): Update to 0.7.0.
> [arguments]<#:configure-flags>: Remove "-Duse_system_vulkan=enabled" and
> "-Dvulkan_datadir" from as they are no longer supported.
> <#:phases>: Add 'unbundle-vulkan-headers'.
> [inputs]: Add nlohmann-json. Replace vulkan-headers with origin for
> vulkan-headers@1.2.158.
> [native-inputs]: Add git-minimal.

[...]

Toggle quote (1 lines)
> + (native-inputs (list git-minimal pkg-config python))
^
Should be ‘git-minimal/pinned’ to avoid unnecessary rebuilds.

Otherwise LGTM and to qa.guix!

Thanks,
Ludo’.
J
J
John Kehayias wrote on 14 Oct 2023 22:55
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 66413-done@debbugs.gnu.org)
87h6msc4bd.fsf@protonmail.com
On Sat, Oct 14, 2023 at 10:25 PM, Ludovic Courtès wrote:

Toggle quote (17 lines)
> John Kehayias <john.kehayias@protonmail.com> skribis:
>
>> * gnu/packages/graphics.scm (mangohud): Update to 0.7.0.
>> [arguments]<#:configure-flags>: Remove "-Duse_system_vulkan=enabled" and
>> "-Dvulkan_datadir" from as they are no longer supported.
>> <#:phases>: Add 'unbundle-vulkan-headers'.
>> [inputs]: Add nlohmann-json. Replace vulkan-headers with origin for
>> vulkan-headers@1.2.158.
>> [native-inputs]: Add git-minimal.
>
> [...]
>
>> + (native-inputs (list git-minimal pkg-config python))
> ^
> Should be ‘git-minimal/pinned’ to avoid unnecessary rebuilds.
>

Ah, thanks!

Toggle quote (5 lines)
> Otherwise LGTM and to qa.guix!
>
> Thanks,
> Ludo’.

Made that change, updated commit message accordingly, and pushed as 5a6b1a55869c488c0da15b4a7a8176d616ec92f8.
Closed
?