[PATCH] gnu: emacs-mastodon: Update to 1.0.5.

  • Done
  • quality assurance status badge
Details
3 participants
  • Liliana Marie Prikler
  • Christopher Baines
  • Fabio Natali
Owner
unassigned
Submitted by
Fabio Natali
Severity
normal

Debbugs page

Fabio Natali wrote 1 years ago
(address . guix-patches@gnu.org)(name . Fabio Natali)(address . me@fabionatali.com)
ae7dc5ab3ec7ce032a4aa5c4afbf6a39ac045ce5.1696607091.git.me@fabionatali.com
* gnu/packages/emacs-xyz.scm (emacs-mastodon): Update to 1.0.5.
---
Hi! 👋

This is to update Emacs Mastodon (mastodon.el) to 1.0.5.

Hope it looks ok. 🙏

Cheers, Fabio.


gnu/packages/emacs-xyz.scm | 63 ++++++++++++++++++--------------------
1 file changed, 30 insertions(+), 33 deletions(-)

Toggle diff (79 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index cf1542955c..6b9f945c20 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -32827,40 +32827,37 @@ (define-public emacs-wc-mode
(license license:gpl3+)))
(define-public emacs-mastodon
- ;; No release in ~1 year, hence this snapshot.
- (let ((commit "20dec8871c9bb5f5e418bfc197e7533b5e3065e3")
- (revision "1"))
- (package
- (name "emacs-mastodon")
- (version (git-version "1.0.0" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://codeberg.org/martianh/mastodon.el")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "15cfjny99yw5frdp8nlyazlwgscvfvbinsj0fbdfprxf50k2zjs6"))))
- (build-system emacs-build-system)
- (arguments
- (list #:phases
- #~(modify-phases %standard-phases
- ;; Move the source files to the top level, which is included in
- ;; the EMACSLOADPATH.
- (add-after 'unpack 'move-source-files
- (lambda _
- (let ((el-files (find-files "./lisp" ".*\\.el$")))
- (for-each (lambda (f)
- (rename-file f (basename f)))
- el-files)))))))
- (propagated-inputs
- (list emacs-request emacs-ts emacs-persist))
- (home-page "https://codeberg.org/martianh/mastodon.el")
- (synopsis "Emacs client for Mastodon")
- (description "@code{mastodon.el} is an Emacs client for Mastodon, the
+ (package
+ (name "emacs-mastodon")
+ (version "1.0.5")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://codeberg.org/martianh/mastodon.el")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1bswv34r0x0a7va0qm6014zy1ddm4sv0l0k37d7z9r295kyz2v0s"))))
+ (build-system emacs-build-system)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ ;; Move the source files to the top level, which is included in
+ ;; the EMACSLOADPATH.
+ (add-after 'unpack 'move-source-files
+ (lambda _
+ (let ((el-files (find-files "./lisp" ".*\\.el$")))
+ (for-each (lambda (f)
+ (rename-file f (basename f)))
+ el-files)))))))
+ (propagated-inputs
+ (list emacs-request emacs-ts emacs-persist))
+ (home-page "https://codeberg.org/martianh/mastodon.el")
+ (synopsis "Emacs client for Mastodon")
+ (description "@code{mastodon.el} is an Emacs client for Mastodon, the
federated microblogging social network.")
- (license license:gpl3+))))
+ (license license:gpl3+)))
(define-public emacs-ebdb
(package

base-commit: a7e6b4c98b97921ab695218f9b89be4f1ded48c9
--
2.41.0
Liliana Marie Prikler wrote 1 years ago
5897f3c2be1d8c852b9740d97ad8ff4b5f762adc.camel@gmail.com
Am Freitag, dem 06.10.2023 um 16:45 +0100 schrieb Fabio Natali:
Toggle quote (74 lines)
> * gnu/packages/emacs-xyz.scm (emacs-mastodon): Update to 1.0.5.
> ---
> Hi! 👋
>
> This is to update Emacs Mastodon (mastodon.el) to 1.0.5.
>
> Hope it looks ok. 🙏
>
> Cheers, Fabio.
>
>
>  gnu/packages/emacs-xyz.scm | 63 ++++++++++++++++++------------------
> --
>  1 file changed, 30 insertions(+), 33 deletions(-)
>
> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
> index cf1542955c..6b9f945c20 100644
> --- a/gnu/packages/emacs-xyz.scm
> +++ b/gnu/packages/emacs-xyz.scm
> @@ -32827,40 +32827,37 @@ (define-public emacs-wc-mode
>      (license license:gpl3+)))
>  
>  (define-public emacs-mastodon
> -  ;; No release in ~1 year, hence this snapshot.
> -  (let ((commit "20dec8871c9bb5f5e418bfc197e7533b5e3065e3")
> -        (revision "1"))
> -    (package
> -      (name "emacs-mastodon")
> -      (version (git-version "1.0.0" revision commit))
> -      (source (origin
> -                (method git-fetch)
> -                (uri (git-reference
> -                      (url
> "https://codeberg.org/martianh/mastodon.el")
> -                      (commit commit)))
> -                (file-name (git-file-name name version))
> -                (sha256
> -                 (base32
> -                 
> "15cfjny99yw5frdp8nlyazlwgscvfvbinsj0fbdfprxf50k2zjs6"))))
> -      (build-system emacs-build-system)
> -      (arguments
> -       (list #:phases
> -             #~(modify-phases %standard-phases
> -                 ;; Move the source files to the top level, which is
> included in
> -                 ;; the EMACSLOADPATH.
> -                 (add-after 'unpack 'move-source-files
> -                   (lambda _
> -                     (let ((el-files (find-files "./lisp"
> ".*\\.el$")))
> -                       (for-each (lambda (f)
> -                                   (rename-file f (basename f)))
> -                                 el-files)))))))
> -      (propagated-inputs
> -       (list emacs-request emacs-ts emacs-persist))
> -      (home-page "https://codeberg.org/martianh/mastodon.el")
> -      (synopsis "Emacs client for Mastodon")
> -      (description "@code{mastodon.el} is an Emacs client for
> Mastodon, the
> +  (package
> +    (name "emacs-mastodon")
> +    (version "1.0.5")
> +    (source (origin
> +              (method git-fetch)
> +              (uri (git-reference
> +                    (url
> "https://codeberg.org/martianh/mastodon.el")
> +                    (commit version)))
> +              (file-name (git-file-name name version))
> +              (sha256
> +               (base32
> +               
> "1bswv34r0x0a7va0qm6014zy1ddm4sv0l0k37d7z9r295kyz2v0s"))))
I'm getting a hash collision:

r:sha256 hash mismatch for /gnu/store/7nj10z58x8csn8q05krn23pghfcgcxjb-
emacs-mastodon-1.0.5-checkout:
expected hash: 1bswv34r0x0a7va0qm6014zy1ddm4sv0l0k37d7z9r295kyz2v0s
actual hash: 0zjn3v3qfr034vz0ns7s9j7n4xzzqy5xiihc307mr3f6fcjgq0xd

Looks like upstream moved the tag?
Fabio Natali wrote 1 years ago
[PATCH v2] gnu: emacs-mastodon: Update to 1.0.5.
(address . 66372@debbugs.gnu.org)(name . Fabio Natali)(address . me@fabionatali.com)
9b0938f378b114fcddc4254c7df1def4ef6d3bbe.1696637656.git.me@fabionatali.com
* gnu/packages/emacs-xyz.scm (emacs-mastodon): Update to 1.0.5.
---
Hi,

Here's an updated version of the patch for Emacs Mastodon 1.0.5.

The commit hash has been updated to reflect a change in the upstream repository.

I've used `guix lint' and `guix style', which didn't seem to spot anything major.

Hopefully this looks good.

Thanks, cheers, Fabio.


gnu/packages/emacs-xyz.scm | 62 ++++++++++++++++++--------------------
1 file changed, 29 insertions(+), 33 deletions(-)

Toggle diff (78 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index cf1542955c..47bdc10685 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -32827,40 +32827,36 @@ (define-public emacs-wc-mode
(license license:gpl3+)))
(define-public emacs-mastodon
- ;; No release in ~1 year, hence this snapshot.
- (let ((commit "20dec8871c9bb5f5e418bfc197e7533b5e3065e3")
- (revision "1"))
- (package
- (name "emacs-mastodon")
- (version (git-version "1.0.0" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://codeberg.org/martianh/mastodon.el")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "15cfjny99yw5frdp8nlyazlwgscvfvbinsj0fbdfprxf50k2zjs6"))))
- (build-system emacs-build-system)
- (arguments
- (list #:phases
- #~(modify-phases %standard-phases
- ;; Move the source files to the top level, which is included in
- ;; the EMACSLOADPATH.
- (add-after 'unpack 'move-source-files
- (lambda _
- (let ((el-files (find-files "./lisp" ".*\\.el$")))
- (for-each (lambda (f)
- (rename-file f (basename f)))
- el-files)))))))
- (propagated-inputs
- (list emacs-request emacs-ts emacs-persist))
- (home-page "https://codeberg.org/martianh/mastodon.el")
- (synopsis "Emacs client for Mastodon")
- (description "@code{mastodon.el} is an Emacs client for Mastodon, the
+ (package
+ (name "emacs-mastodon")
+ (version "1.0.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://codeberg.org/martianh/mastodon.el")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0zjn3v3qfr034vz0ns7s9j7n4xzzqy5xiihc307mr3f6fcjgq0xd"))))
+ (build-system emacs-build-system)
+ (arguments
+ (list
+ #:phases #~(modify-phases %standard-phases
+ ;; Move the source files to the top level, which is included in
+ ;; the EMACSLOADPATH.
+ (add-after 'unpack 'move-source-files
+ (lambda _
+ (let ((el-files (find-files "./lisp" ".*\\.el$")))
+ (for-each (lambda (f)
+ (rename-file f
+ (basename f))) el-files)))))))
+ (propagated-inputs (list emacs-request emacs-ts emacs-persist))
+ (home-page "https://codeberg.org/martianh/mastodon.el")
+ (synopsis "Emacs client for Mastodon")
+ (description "@code{mastodon.el} is an Emacs client for Mastodon, the
federated microblogging social network.")
- (license license:gpl3+))))
+ (license license:gpl3+)))
(define-public emacs-ebdb
(package

base-commit: add2a22ad7bcca2521432e3f486460138401d5a5
--
2.41.0
Fabio Natali wrote 1 years ago
Re: [bug#66372] [PATCH] gnu: emacs-mastodon: Update to 1.0.5.
877cnzqo85.fsf@fabionatali.com
On 2023-10-06, 23:45 +0200, Liliana Marie Prikler <liliana.prikler@gmail.com> wrote:
Toggle quote (1 lines)
> I'm getting a hash collision:
[...]
Toggle quote (2 lines)
> Looks like upstream moved the tag?

Hi Liliana,

Thanks for checking! True, it looks like 1.0.5 has been moved to
7d49ecba22. Updated patch just sent separately.

Cheers, Fabio.
Fabio Natali wrote 1 years ago
[PATCH v3] gnu: emacs-mastodon: Update to 1.0.6.
(address . 66372@debbugs.gnu.org)(name . Fabio Natali)(address . me@fabionatali.com)
94fca17c1c9cb5be644b2236462cc3a9b5acf1aa.1696672441.git.me@fabionatali.com
* gnu/packages/emacs-xyz.scm (emacs-mastodon): Update to 1.0.6.
---
Sorry, there's been a hotfix release in the upstream repo, just this morning. Please discard the previous patch. This one is for 1.0.6, which includes the hotfix. Have a lovely day, Fabio. 🙏🌈

gnu/packages/emacs-xyz.scm | 63 ++++++++++++++++++--------------------
1 file changed, 30 insertions(+), 33 deletions(-)

Toggle diff (79 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index cf1542955c..5fd42a3a28 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -32827,40 +32827,37 @@ (define-public emacs-wc-mode
(license license:gpl3+)))
(define-public emacs-mastodon
- ;; No release in ~1 year, hence this snapshot.
- (let ((commit "20dec8871c9bb5f5e418bfc197e7533b5e3065e3")
- (revision "1"))
- (package
- (name "emacs-mastodon")
- (version (git-version "1.0.0" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://codeberg.org/martianh/mastodon.el")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "15cfjny99yw5frdp8nlyazlwgscvfvbinsj0fbdfprxf50k2zjs6"))))
- (build-system emacs-build-system)
- (arguments
- (list #:phases
- #~(modify-phases %standard-phases
- ;; Move the source files to the top level, which is included in
- ;; the EMACSLOADPATH.
- (add-after 'unpack 'move-source-files
- (lambda _
- (let ((el-files (find-files "./lisp" ".*\\.el$")))
- (for-each (lambda (f)
- (rename-file f (basename f)))
- el-files)))))))
- (propagated-inputs
- (list emacs-request emacs-ts emacs-persist))
- (home-page "https://codeberg.org/martianh/mastodon.el")
- (synopsis "Emacs client for Mastodon")
- (description "@code{mastodon.el} is an Emacs client for Mastodon, the
+ (package
+ (name "emacs-mastodon")
+ (version "1.0.6")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://codeberg.org/martianh/mastodon.el")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1z5lmzxhindxa0f6qi6z361k9smqcz68alr6w6jbmwg279qmk8jj"))))
+ (build-system emacs-build-system)
+ (arguments
+ (list
+ #:phases #~(modify-phases %standard-phases
+ ;; Move the source files to the top level, which is
+ ;; included in the EMACSLOADPATH.
+ (add-after 'unpack 'move-source-files
+ (lambda _
+ (let ((el-files (find-files "./lisp" ".*\\.el$")))
+ (for-each (lambda (f)
+ (rename-file f
+ (basename f)))
+ el-files)))))))
+ (propagated-inputs (list emacs-request emacs-ts emacs-persist))
+ (home-page "https://codeberg.org/martianh/mastodon.el")
+ (synopsis "Emacs client for Mastodon")
+ (description "@code{mastodon.el} is an Emacs client for Mastodon, the
federated microblogging social network.")
- (license license:gpl3+))))
+ (license license:gpl3+)))
(define-public emacs-ebdb
(package

base-commit: 84431a30ea0eab9d80cdf22b97375d1d6339596c
--
2.41.0
Christopher Baines wrote 1 years ago
(name . Fabio Natali)(address . me@fabionatali.com)
87wmvte3hp.fsf@cbaines.net
Fabio Natali via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (9 lines)
> * gnu/packages/emacs-xyz.scm (emacs-mastodon): Update to 1.0.6.
> ---
> Sorry, there's been a hotfix release in the upstream repo, just this
> morning. Please discard the previous patch. This one is for 1.0.6,
> which includes the hotfix. Have a lovely day, Fabio. 🙏🌈
>
> gnu/packages/emacs-xyz.scm | 63 ++++++++++++++++++--------------------
> 1 file changed, 30 insertions(+), 33 deletions(-)

This looks good to me, I've pushed it to master as
d6afcffb217ade8573fb86ef18d6740d1a9cba4d.

Thanks,

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmUml9JfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9Xe9Tw/7B5xdDq/xX515JLtUXiYP/lhoB+PQUBl0
0wblpaIOLBrWMnZEr+5qCbwJ4h2Sj5mMcSpuDbwlELHXIjxQHJt4H3r9O0rrFb+g
xV6FiYpFuwO0FNVWkvPiPdqD0Y3/aYj08oOBSRdRd853Gy5bn/8M/uSsTk1xhKIy
VYpM2ZQpNwxfns0iR62FherbWc5rsaXsceUr6E+tRgFILLH/wV8hsh9vxN4XsDn3
7n80NZLcEvVrn4DBymx4XvBDfVCPxAqHeTRAqdTLnxFXlTuC5ciT1bFmjzGi5bjG
qT6ve2pWYx0mkti9m0es7nite+tsCsDpQWFBDm4QZCZWQh0clqD4lQYfIIhA6ShI
nbVuH7Fe6qSRwnyryFbbAXcLm2kdKgSTGgeZ2cSNLE0KvIpP50uvCa1GNMEcUI0e
GTHNgcGYgh8qcdcY+eD2iNBDk3mhECuL0ghDiybhR/JTrYjulWo7lykjdh4r4d9V
QJioG9WRpH+qLERaT6hchNHeZu0NA4+Q9zs7OXH6v07UlN2EhyM94nzT77ulb/Xg
AVsLu0t14ee4pIgkQldJMHqLNG6Y6uwmDRiKoF2jOnzOq882SNWn6Eu8/vQmdqLA
Damv9sh5lXznkVArFWcOydE+e6kYBV9ZBy2iaGUG4Ud0PUDbxpd+znbXDcNy6iOJ
ieVbzMzG/d8=
=AhtM
-----END PGP SIGNATURE-----

?
Your comment

This issue is archived.

To comment on this conversation send an email to 66372@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 66372
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help