Add more setups to Guix docs

  • Done
  • quality assurance status badge
Details
2 participants
  • Efraim Flashner
  • Ekaitz Zarraga
Owner
unassigned
Submitted by
Ekaitz Zarraga
Severity
normal

Debbugs page

Ekaitz Zarraga wrote 1 years ago
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
dxVNBOgQDsVRT1GeXdK8sz-E84mcvW0BN05eSLjnzc9kErZPVgz_EHShz_UDpv6bUZicnijsnDlS1bXpZwdO8KvPEEIxqFkSF42q9kdgEYs=@elenq.tech
------- Original Message -------
On Wednesday, October 4th, 2023 at 15:27, Ludovic Courtès <ludo@gnu.org> wrote:


Toggle quote (35 lines)
> Hi,
>
> Ekaitz Zarraga ekaitz@elenq.tech skribis:
>
> > From 0c2be98f05bb288699a8e39dcef6428eb5a9dc3f Mon Sep 17 00:00:00 2001
> > Message-ID: 0c2be98f05bb288699a8e39dcef6428eb5a9dc3f.1695679042.git.ekaitz@elenq.tech
> > From: Ekaitz Zarraga ekaitz@elenq.tech
> > Date: Mon, 25 Sep 2023 16:16:28 +0200
> > Subject: [PATCH] WIP: doc: contributing: Add alternative setups section
> >
> > Start with Guile Studio and Vim/NeoVim.
> >
> > * doc/contributing.texi (Alternative Setups): Add section explaining
> > other setups that are similar to the one in The Perfect Setup
>
>
> Not a maintainer either but I like it!
>
> > +@node Alternative Setups
> > +
>
>
> I think you’re missing an @section here.
>
> > +@node Vim and NeoVim
> > +@subsection Vim and Neovim
>
>
> Which spelling is the right one? :-)
>
> Maybe send it to guix-patches@gnu.org so it passes on everyone’s radar,
> but otherwise LGTM!
>
> Ludo’.

Great!
Thanks Ludo.

Fixed!

I add guix-patches in the loop.

Thanks all,
Ekaitz
From 8ea037b7d8f3472323682594266f5810fd87f291 Mon Sep 17 00:00:00 2001
Message-ID: <8ea037b7d8f3472323682594266f5810fd87f291.1696433643.git.ekaitz@elenq.tech>
From: Ekaitz Zarraga <ekaitz@elenq.tech>
Date: Mon, 25 Sep 2023 16:16:28 +0200
Subject: [PATCH] doc: contributing: Add alternative setups section

Start with Guile Studio and Vim/NeoVim.

* doc/contributing.texi (Alternative Setups): Add section explaining
other setups that are similar to the one in The Perfect Setup
---
doc/contributing.texi | 77 +++++++++++++++++++++++++++++++++++++++----
1 file changed, 70 insertions(+), 7 deletions(-)

Toggle diff (106 lines)
diff --git a/doc/contributing.texi b/doc/contributing.texi
index 0de47a403b..c476097bf5 100644
--- a/doc/contributing.texi
+++ b/doc/contributing.texi
@@ -23,6 +23,7 @@ Contributing
* Building from Git:: The latest and greatest.
* Running Guix Before It Is Installed:: Hacker tricks.
* The Perfect Setup:: The right tools.
+* Alternative Setups:: Other posible tools that do the job.
* Packaging Guidelines:: Growing the distribution.
* Coding Style:: Hygiene of the contributor.
* Submitting Patches:: Share your work.
@@ -453,6 +454,75 @@ The Perfect Setup
Emacs Manual} and @ref{Minor Mode,,, debbugs-ug, The Debbugs User
Guide}.
+@node Alternative Setups
+@section Alternative Setups
+
+Alternative setups than Emacs may let you work on Guix with a
+similar development experience and they might work better with the
+tools you currently use or help you make the transition to Emacs.
+
+The options listed below only provide the alternatives to the Emacs
+based setup, which is the most widely used in the Guix community. If
+you want to really understand how is the perfect setup for Guix
+development supposed to work, we encourage you to read the section
+before this regardless the editor you choose to use.
+
+@menu
+* Guile Studio:: First step in your transition to Emacs.
+* Vim and NeoVim:: When you are evil to the root.
+@end menu
+
+@node Guile Studio
+@subsection Guile Studio
+
+Guile Studio is a pre-configured Emacs with mostly everything you need
+to start hacking in Guile. If you are not familiar with Emacs it makes
+the transition easier for you.
+
+@example
+guix install guile-studio
+@end example
+
+Guile Studio comes with Geiser preinstalled and prepared for action.
+
+@node Vim and NeoVim
+@subsection Vim and NeoVim
+
+
+Vim (and NeoVim) are also packaged in Guix, just in case you decided
+to go for the evil path.
+
+@example
+guix install vim
+@end example
+
+If you want to enjoy a similar development experience to that in the perfect
+setup, you should install several plugins to configure the editor. Vim (and
+NeoVim) have the equivalent to Paredit,
+@uref{https://www.vim.org/scripts/script.php?script_id=3998,
+@code{paredit.vim}}, that will help you with the structural editing of Scheme
+files (the support for very large files is not great, though).
+
+@example
+guix install vim-paredit
+@end example
+
+We also recommend that you run @code{:set autoindent} so that your code is
+automatically indented as you type.
+
+For the interaction with Git,
+@uref{https://www.vim.org/scripts/script.php?script_id=2975
+@code{fugitive.vim}} is the most commonly used plugin:
+
+@example
+guix install vim-fugitive
+@end example
+
+In NeoVim you can even make a similar setup to Geiser using
+@url{https://conjure.fun/, Conjure} that lets you connect to a running Guile
+process and inject your code there live (sadly it's not packaged in Guix yet).
+
+
@node Packaging Guidelines
@section Packaging Guidelines
@@ -1257,13 +1327,6 @@ Formatting Code
@noindent
@xref{Invoking guix style}, for more information.
-@cindex Vim, Scheme code editing
-If you are editing code with Vim, we recommend that you run @code{:set
-autoindent} so that your code is automatically indented as you type.
-Additionally,
-@uref{https://www.vim.org/scripts/script.php?script_id=3998,
-@code{paredit.vim}} may help you deal with all these parentheses.
-
We require all top-level procedures to carry a docstring. This
requirement can be relaxed for simple private procedures in the
@code{(guix build @dots{})} name space, though.

base-commit: 284f8508bebcae510261c7c223dc28f9badf87ce
--
2.41.0
Efraim Flashner wrote 1 years ago
(name . Ekaitz Zarraga)(address . ekaitz@elenq.tech)
ZR2QWPHpjGErYGmn@3900XT
Attachment: file
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmUdkFUACgkQQarn3Mo9
g1FewQ/9Eo1+2qUv29Cd90lqjA8MjYoYHlf5JAitb5BOmmKCvSNsdi9CWNwVzXP3
tGVxO5Tn9xuDkz0PJsJhduqiMAJBrNW2ejOGSBXuPd0eosW1CSy3Eg3N5b27NGcH
EXs5qaJjSke3giMPJRAqW+o5SRdjGoOaPeLIcSlrMOIxRkAxLKEeV3yTrsgBDKJJ
rhnHBdDgyYQhkS31umGXsForZxS59dfOzK/uCZ9jWMG+ak2cWQ6DqmybYbqlgOdB
Ouw0oCB812RlYkvSL8pCjirAJF2UA99KIk9JiaWbjRJl2tzix515SLWJ3bcEaGLE
CIsvAuAx84Eukm0w6hk5wAJabTMaLMQYInCC2yg1uyVgEmjCIYxhNgjbeCS2vG8C
qBVhqoxZjl39oeQUk1KAXOUEJ46sZpn7olEUnfZZzd7zqdQKLAQeXlMMDfy71xhn
kGb2DW91w1QIQo+ZMbuQZ7LGprWg+SfnG4eyfDAbJKPPDIMHYqrXRvHGkXwmhiTH
QexKgy+iY8TMKS0OpgmrER5t7cxQqoLmZdN/PyN+fD02OOV83IDI4nDGX2lPnAut
p8gWvn/RuMi4saraSbx6jT0SRT4Ly7v4nWPIV5zAL7dWTCMfu1gbm7iNR0REgD0U
Zxrt/WbZmhXVdkT+q9nkAf+Q8Tc2gkm5X1GJRk15CqRkV2x5BK4=
=o4JO
-----END PGP SIGNATURE-----


Ekaitz Zarraga wrote 1 years ago
(name . Efraim Flashner)(address . efraim@flashner.co.il)
JEQlRoqiZp6xIBWAvKL2rv0ksiE-4OJnz1eO0-32IjBXyLTW0jXzVs9i1KeWx7XAOUWotoNRsvqEaR8JTF3L7PhPT-LnZEdmUQcLinLmvdA=@elenq.tech
------- Original Message -------
On Wednesday, October 4th, 2023 at 16:18, Efraim Flashner <efraim@flashner.co.il> wrote:


Toggle quote (3 lines)
> I think we can mention guix.vim also


Certainly, do you want to add it yourself?

Nobody is going to explain it better than you.

:)
Efraim Flashner wrote 1 years ago
(name . Ekaitz Zarraga)(address . ekaitz@elenq.tech)
ZR2wgVgEvme3on6I@3900XT
On Wed, Oct 04, 2023 at 06:15:53PM +0000, Ekaitz Zarraga wrote:
Toggle quote (13 lines)
>
>
> ------- Original Message -------
> On Wednesday, October 4th, 2023 at 16:18, Efraim Flashner <efraim@flashner.co.il> wrote:
>
>
> > I think we can mention guix.vim also
>
>
> Certainly, do you want to add it yourself?
>
> Nobody is going to explain it better than you.

I tossed in a line or two in the middle of the patch

--
Efraim Flashner <efraim@flashner.co.il> רנשלפ םירפא
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmUdsIEACgkQQarn3Mo9
g1GiHQ//YiF2y2W0Taaa9fZN77x13rDoki3TQdu2NyZL0iM4udmVMe30RTSKv0/y
tG85SrEUthP7tPrzNtMhlhvcpXhsD05KVYX9oeCvIzWRSzXacg/Y7u0dSz2Q/QRV
MEZiJF77c/wgKl39o/525YK6+WvkyQcuZ7yjK3++HrEDHNOAWzQ+bA6R/QpEZGKN
q0JYeM6CY5URh4cSmG4iWumMQ+iOFXdo8Tjy71qudR5uRZTmWwUCqixgrctTPqmd
J30Z37Hs73CNxD5TWqzAfSS5qxKL5qz3tPc+VtMBZELvtuD/YkowGQvLrazQYVBJ
SZHI6jPhkp8eJQzAkZcmFa1yH/A1TvxiZ1PE9TBG2BsQHPKtm+wOO4qqJcRhAEtU
PfjbBaVUU2wmihI/UJMfRzqHbmk1+0b/d0o92ekGpo6hxCPO0mg5jkYxDXyaPyv+
lEd6DTH3tPdf6LDFec04D/y6bVCpBIGCNVhUkritmJ45e90deeeckvR3bzvXCALx
qsxHfHiN2peB8uoXo6v2dVVueGlD3jSJK9vZtSeGCRZSwGWP65ENiTiLi7BFAF+z
OBZdehZj+yCd201QMkzmXxzJD1tsKurmCvnxsvAsEauHQesYrqFS3TIgkEHPvc0A
0n0oj/VBKE8uAtDw4LT6X8/dkbkYKFZ5e+RblDC3qTKexRb8SJ8=
=4f8q
-----END PGP SIGNATURE-----


Ekaitz Zarraga wrote 1 years ago
(name . Efraim Flashner)(address . efraim@flashner.co.il)
pu1-01dMwTGvV2OwbZzu-3p3Ojf9JpsJ2lx74KhQY-8LaqC4_aHHhomnAEpjNvn5CAOZIZ0zoYwxhPnSeCMuFIsyHUtg3Kai1JIpAiJvPWQ=@elenq.tech
------- Original Message -------
On Wednesday, October 4th, 2023 at 18:35, Efraim Flashner <efraim@flashner.co.il> wrote:


Toggle quote (14 lines)
> On Wed, Oct 04, 2023 at 06:15:53PM +0000, Ekaitz Zarraga wrote:
>
> > ------- Original Message -------
> > On Wednesday, October 4th, 2023 at 16:18, Efraim Flashner efraim@flashner.co.il wrote:
> >
> > > I think we can mention guix.vim also
> >
> > Certainly, do you want to add it yourself?
> >
> > Nobody is going to explain it better than you.
>
>
> I tossed in a line or two in the middle of the patch

But you didn't attach, did you?

Or you directly commited?
Efraim Flashner wrote 1 years ago
(name . Ekaitz Zarraga)(address . ekaitz@elenq.tech)
ZR3QVVyYZ6cyYc4a@3900XT
On Wed, Oct 04, 2023 at 06:47:51PM +0000, Ekaitz Zarraga wrote:
Toggle quote (23 lines)
>
> ------- Original Message -------
> On Wednesday, October 4th, 2023 at 18:35, Efraim Flashner <efraim@flashner.co.il> wrote:
>
>
> > On Wed, Oct 04, 2023 at 06:15:53PM +0000, Ekaitz Zarraga wrote:
> >
> > > ------- Original Message -------
> > > On Wednesday, October 4th, 2023 at 16:18, Efraim Flashner efraim@flashner.co.il wrote:
> > >
> > > > I think we can mention guix.vim also
> > >
> > > Certainly, do you want to add it yourself?
> > >
> > > Nobody is going to explain it better than you.
> >
> >
> > I tossed in a line or two in the middle of the patch
>
> But you didn't attach, did you?
>
> Or you directly commited?

I commented directly in the middle of the patch.

Toggle quote (5 lines)
> +@example
> +guix install vim-fugitive
> +@end example
> +

And of course if you want to interact with Guix directly from inside of
vim, using the built-in terminal emulator, we have our very own
@code{guix.vim} package!

@example
guix install vim-guix-vim
@end example

Toggle quote (3 lines)
> +In NeoVim you can even make a similar setup to Geiser using
> +@url{https://conjure.fun/, Conjure} that lets you connect to a running Guile

--
Efraim Flashner <efraim@flashner.co.il> רנשלפ םירפא
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
From 410eff90c552977a209db2c56538166ec5455be1 Mon Sep 17 00:00:00 2001
Message-ID: <410eff90c552977a209db2c56538166ec5455be1.1696452671.git.efraim@flashner.co.il>
From: Ekaitz Zarraga <ekaitz@elenq.tech>
Date: Mon, 25 Sep 2023 16:16:28 +0200
Subject: [PATCH v2] doc: contributing: Add alternative setups section

Start with Guile Studio and Vim/NeoVim.

* doc/contributing.texi (Alternative Setups): Add section explaining
other setups that are similar to the one in The Perfect Setup
---
doc/contributing.texi | 85 +++++++++++++++++++++++++++++++++++++++----
1 file changed, 78 insertions(+), 7 deletions(-)

Toggle diff (117 lines)
diff --git a/doc/contributing.texi b/doc/contributing.texi
index 0de47a403b..f7c72634e7 100644
--- a/doc/contributing.texi
+++ b/doc/contributing.texi
@@ -23,6 +23,7 @@ Contributing
* Building from Git:: The latest and greatest.
* Running Guix Before It Is Installed:: Hacker tricks.
* The Perfect Setup:: The right tools.
+* Alternative Setups:: Other posible tools that do the job.
* Packaging Guidelines:: Growing the distribution.
* Coding Style:: Hygiene of the contributor.
* Submitting Patches:: Share your work.
@@ -453,6 +454,83 @@ The Perfect Setup
Emacs Manual} and @ref{Minor Mode,,, debbugs-ug, The Debbugs User
Guide}.
+@node Alternative Setups
+@section Alternative Setups
+
+Alternative setups than Emacs may let you work on Guix with a
+similar development experience and they might work better with the
+tools you currently use or help you make the transition to Emacs.
+
+The options listed below only provide the alternatives to the Emacs
+based setup, which is the most widely used in the Guix community. If
+you want to really understand how is the perfect setup for Guix
+development supposed to work, we encourage you to read the section
+before this regardless the editor you choose to use.
+
+@menu
+* Guile Studio:: First step in your transition to Emacs.
+* Vim and NeoVim:: When you are evil to the root.
+@end menu
+
+@node Guile Studio
+@subsection Guile Studio
+
+Guile Studio is a pre-configured Emacs with mostly everything you need
+to start hacking in Guile. If you are not familiar with Emacs it makes
+the transition easier for you.
+
+@example
+guix install guile-studio
+@end example
+
+Guile Studio comes with Geiser preinstalled and prepared for action.
+
+@node Vim and NeoVim
+@subsection Vim and NeoVim
+
+
+Vim (and NeoVim) are also packaged in Guix, just in case you decided
+to go for the evil path.
+
+@example
+guix install vim
+@end example
+
+If you want to enjoy a similar development experience to that in the perfect
+setup, you should install several plugins to configure the editor. Vim (and
+NeoVim) have the equivalent to Paredit,
+@uref{https://www.vim.org/scripts/script.php?script_id=3998,
+@code{paredit.vim}}, that will help you with the structural editing of Scheme
+files (the support for very large files is not great, though).
+
+@example
+guix install vim-paredit
+@end example
+
+We also recommend that you run @code{:set autoindent} so that your code is
+automatically indented as you type.
+
+For the interaction with Git,
+@uref{https://www.vim.org/scripts/script.php?script_id=2975
+@code{fugitive.vim}} is the most commonly used plugin:
+
+@example
+guix install vim-fugitive
+@end example
+
+And of course if you want to interact with Guix directly from inside of
+vim, using the built-in terminal emulator, we have our very own
+@code{guix.vim} package!
+
+@example
+guix install vim-guix-vim
+@end example
+
+In NeoVim you can even make a similar setup to Geiser using
+@url{https://conjure.fun/, Conjure} that lets you connect to a running Guile
+process and inject your code there live (sadly it's not packaged in Guix yet).
+
+
@node Packaging Guidelines
@section Packaging Guidelines
@@ -1257,13 +1335,6 @@ Formatting Code
@noindent
@xref{Invoking guix style}, for more information.
-@cindex Vim, Scheme code editing
-If you are editing code with Vim, we recommend that you run @code{:set
-autoindent} so that your code is automatically indented as you type.
-Additionally,
-@uref{https://www.vim.org/scripts/script.php?script_id=3998,
-@code{paredit.vim}} may help you deal with all these parentheses.
-
We require all top-level procedures to carry a docstring. This
requirement can be relaxed for simple private procedures in the
@code{(guix build @dots{})} name space, though.

base-commit: e71864793021051cff35597abd59bb2d5649977d
prerequisite-patch-id: f3ace8d09a8dea9552cefac6971f2dc48480e326
--
Efraim Flashner <efraim@flashner.co.il> רנשלפ םירפא
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmUd0FUACgkQQarn3Mo9
g1G7sA/+Ne+/WJIILs8Kq750JZivrM52dgW9BDm2NVnIFSxA4o5X4J0gYuWwtiLy
vlZxa5E6JSSWz1/cSIz5wxG6U2JDLDyEQ2P+OcOVdj9o12S0RBVAyvD6peooST6k
vCix+oaWt4Eq5J3Din7bccQfo9SH02b7xuae8huTSaBbSuNkzfNXnOMnmwzoPgpk
MSyu0tJPh6rtICMvfNGG7l4gh806RaWa5MYhTABw5Ix3aaoKAwbP9mwSwfr84T4k
IJwv2gxsTzfjcodrEldpgG18vUnZjZdZJWQAYtAoFu67FzntGE6ad/jvoOR17AFT
tnX7q3vruohxT75xtyWzL4nxvYGYjBp91CkI1zl09aHq70g8Jj8FsEJbEo1ENdDL
BHV8ADlE0DpCIiPDRQqvsFUZxfv2LlejiVqKoVtwNJp6Z8CKoXIo+ahUDjXKjnvq
QCgqIE/VX/AKktPMxe+8/7WOlBWraVBBSXUiQ3qOuR2a4WfZZp7djz1eZYIsF+GM
qrA7Ry5zshB/oq6hf8828lVDCOiZcmNQW06vsRjRZIgCLP+xEL7SiuSukEc/Bm46
HqILRFMSrqVK0IWeLsFljLVp5ppOknQDzbAdC82ccx9661uskc53U0HxRq4fDuwZ
LpVtRkinBMGRvJuC2TDi4ZWziwY6fbkq2qvqLs258hx94tLfPq4=
=nxen
-----END PGP SIGNATURE-----


Ekaitz Zarraga wrote 1 years ago
(name . Efraim Flashner)(address . efraim@flashner.co.il)
KrL-Ko_CYH6MmCnbXsNZZcPE97cG3aGM24rK2xtcCqfj2UH3aXGhFkpiY5FcmZar6oRNWB8DvDWxVHgf0zCNmPXy2sRgsND65NEmDVNq_x8=@elenq.tech
ElenQ Technology


------- Original Message -------
On Wednesday, October 4th, 2023 at 20:51, Efraim Flashner <efraim@flashner.co.il> wrote:


Toggle quote (49 lines)
> On Wed, Oct 04, 2023 at 06:47:51PM +0000, Ekaitz Zarraga wrote:
>
> > ------- Original Message -------
> > On Wednesday, October 4th, 2023 at 18:35, Efraim Flashner efraim@flashner.co.il wrote:
> >
> > > On Wed, Oct 04, 2023 at 06:15:53PM +0000, Ekaitz Zarraga wrote:
> > >
> > > > ------- Original Message -------
> > > > On Wednesday, October 4th, 2023 at 16:18, Efraim Flashner efraim@flashner.co.il wrote:
> > > >
> > > > > I think we can mention guix.vim also
> > > >
> > > > Certainly, do you want to add it yourself?
> > > >
> > > > Nobody is going to explain it better than you.
> > >
> > > I tossed in a line or two in the middle of the patch
> >
> > But you didn't attach, did you?
> >
> > Or you directly commited?
>
>
> I commented directly in the middle of the patch.
>
> > +@example
> > +guix install vim-fugitive
> > +@end example
> > +
>
>
> And of course if you want to interact with Guix directly from inside of
> vim, using the built-in terminal emulator, we have our very own
> @code{guix.vim} package!
>
> @example
> guix install vim-guix-vim
> @end example
>
> > +In NeoVim you can even make a similar setup to Geiser using
> > +@url{https://conjure.fun/, Conjure} that lets you connect to a running Guile
>
>
> --
> Efraim Flashner efraim@flashner.co.il רנשלפ םירפא
>
> GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
> Confidentiality cannot be guaranteed on emails sent or received unencrypted

It looks good to me.

Commit?
Efraim Flashner wrote 1 years ago
(name . Ekaitz Zarraga)(address . ekaitz@elenq.tech)
ZR6m9gi7yryPqwd_@3900XT
On Wed, Oct 04, 2023 at 08:55:32PM +0000, Ekaitz Zarraga wrote:
Toggle quote (5 lines)
>
> It looks good to me.
>
> Commit?

Looks good to me too. Patch pushed!

--
Efraim Flashner <efraim@flashner.co.il> רנשלפ םירפא
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmUepvYACgkQQarn3Mo9
g1GyrQ/9FplJuT/7vtoUw4VmsGCG/RFEYqAjfdxRosue1ffsMcmnmhZFF+vz4EeH
MBKSFeNLp/BL5kDboBlTdP2p7ho1FpltVx5x4YtR6CSL13uRAcXrg4YC4RhA9vR/
wTaIlvhazF2uaP9O+onWNVgxaiYKfXxvFyYZ5cBP9ZNyDh1pJczg6bSZw2Gfp6hj
Me0aCq5Q/4yv730DvCjWnREadXH1W31/FD0/4xRIYnZgzgsfqgr8B6WtPxLog7Jk
0/l6qp2IFq8QqYJB5fMJhoVBjnKCyL6/21yWm/H9HOL7fNKQDhK8EwuARGAbXRzQ
fqC4BMkuiTVmsxMUB577JGdgdksODOvN8AumnWf80vCn6NHebGFy0H2soDv1JzyU
sPU+6jfJQ8zTdVe7CmAOhqUGRWXE0qnJhaUVrpsKT+ph3u+SmmmDrYZSLV6BU7gD
9IhTpPLPwYvSm64azY2OHO+JpwgcaqHqXUinmBFPQOPV6n+4mNwm9HuXfQj9Ndn1
gIOJoUmEWLOHBtai7dus4mCxvnFfRGLeS8lJ4WaL08t2DyMww3hC495/JF2m7YTD
nLGLHDNwTDBuzNIcFcysXOb9e0T5trSxCs4uVDQLnv0a5Y4W+0CT4CCB7sV9iGJE
NP3xLcwDGfibpDk+RdUxDDZjlCULPWhmtgWVvs7ksuSr5PyHiaA=
=fROB
-----END PGP SIGNATURE-----


Closed
Ekaitz Zarraga wrote 1 years ago
(name . Efraim Flashner)(address . efraim@flashner.co.il)
LFj0u4PUSytFCwbYUTXzyBiNG7exUoh7OZGUNWa3ml7iA_6uNUbb0aVofUKh31bUtoCi_1e2coKQYDiMrg9frrrJ2oabWtaxEWhHQT49IgQ=@elenq.tech
Thank you all for the collaboration!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 66343@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 66343
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help