[PATCH 0/3] Add HELambdaP

  • Done
  • quality assurance status badge
Details
2 participants
  • Gabriel Hondet
  • Guillaume Le Vaillant
Owner
unassigned
Submitted by
Gabriel Hondet
Severity
normal

Debbugs page

Gabriel Hondet wrote 1 years ago
(address . guix-patches@gnu.org)(name . Gabriel Hondet)(address . gabriel.hondet@laposte.net)
cover.1696261435.git.gabriel.hondet@laposte.net
From: Gabriel Hondet <gabriel.hondet@laposte.net>

HELambdaP is a common lisp library to document code. These patches add
the library helambdap and two of its dependencies. For each library L,
we define first the sbcl version sbcl-L and then we build the cl version
cl-L from the sbcl version.

Gabriel Hondet (3):
gnu: add sbcl-xhtmlambda
gnu: add sbcl-clad
gnu: add sbcl-helambdap

gnu/packages/lisp-xyz.scm | 87 +++++++++++++++++++++++++++++++++++++++
1 file changed, 87 insertions(+)


base-commit: 3f7b091ea4897e3a170a54433a2476d3b6810dc4
--
2.42.0
Gabriel Hondet wrote 1 years ago
[PATCH 1/3] [PATCH] gnu: add sbcl-xhtmlambda
(address . 66318@debbugs.gnu.org)(name . Gabriel Hondet)(address . koizel+dev@simplelogin.com)
40aca978fb1fba5500aaeb82249a6b363a07e25a.1696447957.git.gabriel.hondet@cominety.net
From: Gabriel Hondet <koizel+dev@simplelogin.com>

---
gnu/packages/lisp-xyz.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (55 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 2751af4a85..003abe6f9c 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -39,6 +39,7 @@
;;; Copyright © 2022, 2023 Artyom Bologov <mail@aartaka.me>
;;; Copyright © 2023 Roman Scherer <roman@burningswell.com>
;;; Copyright © 2023 ykonai <mail@ykonai.net>
+;;; Copyright © 2023 Gabriel Hondet <gabriel.hondet@cominety.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -10563,6 +10564,38 @@ (define-public cl-lass
(define-public ecl-lass
(sbcl-package->ecl-package sbcl-lass))
+(define-public sbcl-xhtmlambda
+ (let ((commit "c86376bccebf77ca428e8033df2ba7d8450ea1e8"))
+ (package
+ (name "sbcl-xhtmlambda")
+ (version
+ ;; The source repository doesn't provide any version nor revision, but
+ ;; a timestamp
+ (git-version "2022-01-21" "0" commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.common-lisp.net/xhtmlambda/XHTMLambda")
+ (commit commit)))
+ (sha256
+ (base32 "0narbzz06ry1wn048avm1fwihvnjvvc4wfcv5hmdazkilpvnqz2y"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs (list sbcl-cl-unicode))
+ (synopsis "(X)HTMΛ is an (X)HTML library which emphasizes
+programmability")
+ (description
+ "(X)HTMLambda is yet another (X)HTML library which
+emphasizes programmability and user-friendliness. Each (X)HTML element is a
+strucuterd object and pretty-printing of (X)HTML trees is well defined to
+provide properly indented human-readable output even for complex recursive
+arrangements.")
+ (license license:expat)
+ (home-page "https://xhtmlambda.common-lisp.dev/"))))
+
+(define-public cl-xhtmlambda
+ (sbcl-package->cl-source-package sbcl-xhtmlambda))
+
(define-public sbcl-plump
(let ((commit "0c3e0b57b43b6e0c5794b6a902f1cf5bee2a2927")
(revision "3"))

base-commit: 3f7b091ea4897e3a170a54433a2476d3b6810dc4
--
2.41.0
Gabriel Hondet wrote 1 years ago
[PATCH 2/3] [PATCH] gnu: add sbcl-clad
(address . 66318@debbugs.gnu.org)(name . Gabriel Hondet)(address . koizel+dev@simplelogin.com)
d25ce511b80cb4ba97acde6201eccaac2234bee5.1696447957.git.gabriel.hondet@cominety.net
From: Gabriel Hondet <koizel+dev@simplelogin.com>

---
gnu/packages/lisp-xyz.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 003abe6f9c..79a96988f5 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -10596,6 +10596,34 @@ (define-public sbcl-xhtmlambda
(define-public cl-xhtmlambda
(sbcl-package->cl-source-package sbcl-xhtmlambda))
+(define-public sbcl-clad
+ (let ((commit "1ff6f417d4ee3836d1edd96923d4b03f3cafa849"))
+ (package
+ (name "sbcl-clad")
+ (version
+ ;; There's no version, but there's a timestamp
+ (git-version "2023-01-21" "0" commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.common-lisp.net/mantoniotti/CLAD")
+ (commit commit)))
+ (sha256
+ (base32 "184mhdq7pxd6hd4rzv8z4lfbwnkyhgm5bdn3xsqaav2j0d1dqm6i"))))
+ (build-system asdf-build-system/sbcl)
+ (synopsis "CLAD is a library providing \"standard\" locations on the
+file system")
+ (description
+ "The Common Lisp Application Directories (CLAD) library is
+a simple API collection that provides access to a set of \"standard\" Common
+Lisp folders on a \"per-application\" or \"per-library\" basis.")
+ (license license:expat) ;the mit-modern-variant is used
+ (home-page "https://gitlab.common-lisp.net/mantoniotti/CLAD"))))
+
+(define-public cl-clad
+ (sbcl-package->cl-source-package sbcl-clad))
+
(define-public sbcl-plump
(let ((commit "0c3e0b57b43b6e0c5794b6a902f1cf5bee2a2927")
(revision "3"))
--
2.41.0
Gabriel Hondet wrote 1 years ago
[PATCH 3/3] [PATCH] gnu: add sbcl-helambdap
(address . 66318@debbugs.gnu.org)(name . Gabriel Hondet)(address . koizel+dev@simplelogin.com)
31316725d498dffa117a4c066a57d777f216a431.1696447957.git.gabriel.hondet@cominety.net
From: Gabriel Hondet <koizel+dev@simplelogin.com>

---
gnu/packages/lisp-xyz.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 79a96988f5..4959447fff 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -10463,6 +10463,32 @@ (define-public cl-staple
(define-public ecl-staple
(sbcl-package->ecl-package sbcl-staple))
+(define-public sbcl-helambdap
+ (let ((commit "5bf65f57a36ee094cadb096caca6e90eb3ba46c4")
+ (timestamp "20220103"))
+ (package
+ (name "sbcl-helambdap")
+ (version (git-version timestamp "0" commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.code.sf.net/p/helambdap/code")
+ (commit commit)))
+ (sha256
+ (base32 "1kzapbf9l2bw8i9m9sxv0dfnkksrxq81d5hbn34pm25abk0i937j"))))
+ (build-system asdf-build-system/sbcl)
+ (native-inputs (list sbcl-cl-fad sbcl-split-sequence sbcl-clad
+ sbcl-xhtmlambda sbcl-cl-unicode))
+ (synopsis "HELambdap is a Common Lisp documentation system")
+ (description "HELambdap is a Common Lisp documentation system which
+strives to be simple to use, yet easily customizable.")
+ (license license:expat)
+ (home-page "https://helambdap.sourceforge.net"))))
+
+(define-public cl-helambdap
+ (sbcl-package->cl-source-package sbcl-helambdap))
+
(define-public sbcl-form-fiddle
(let ((commit "e0c23599dbb8cff3e83e012f3d86d0764188ad18")
(revision "0"))
--
2.41.0
Guillaume Le Vaillant wrote 1 years ago
Re: [bug#66318] [PATCH 0/3] Add HELambdaP
(name . Gabriel Hondet)(address . gabriel.hondet@cominety.net)(address . 66318-done@debbugs.gnu.org)
877cnuopw4.fsf@kitej
Patches applied as 1dbc630a3390d7232e26b4cfa3499b579b82e553 and
following (with some modifications and complete commit messages).
Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCZSUH6w8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j8QOwD9E0IJ8FQ/g7UbeDp4hnS2RPaiKpvfePjFoYiS
S5pwq04BAIPUJgJmvQ3UAylFyxyrIyqYKs2eHRzOxzksh36ljy1H
=8fh4
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 66318@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 66318
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help