GuixSD on powerpc64le

  • Open
  • quality assurance status badge
Details
2 participants
  • Sus Amogus
  • jbranso
Owner
unassigned
Submitted by
Sus Amogus
Severity
normal
S
S
Sus Amogus wrote on 26 Sep 2023 00:12
(address . bug-guix@gnu.org)
CAHooFsupF16_HNSqdA8xqc=awSegSCDh1ev=9YwEYKHy-60AWg@mail.gmail.com
I'm currently working on building Guix System for powerpc64le, and I've
encountered a few issues that I could use some assistance with.

Firstly, linux-initrd failing because gcc-7.5 package used for
bootstrap-glibc do not support --with-long-double-128. Removing this works
just fine -- with last gcc package:
Toggle quote (5 lines)
> /gnu/packages/make-bootstrap.scm
> (native-inputs
> `(("gcc" ,gcc-7.5)
> ,@(package-native-inputs base)))

I'm curious why gcc-7.5 was built without --with-long-double-128,
especially considering it's defined for powerpc64le-linux in
/gnu/packages/gcc.scm under (gcc-configure-flags-for-triplet).

Furthermore, I've encountered issues with Grub, which are detailed in this
issue: https://issues.guix.gnu.org/54407.I believe that porting
gcc-12-multilib from Debian could potentially resolve this problem.

Lastly, any image generated from (system-disk-image) depends on
grub-efi{,32}, but (a) grub-efi build fails on ppc*, and (b) ppc* systems
do not use EFI.

The remaining problems mostly involve software patching or minor code
adjustments.

Best regards,

Mykhailo Chernysh
iskrim666@gmail.com
Attachment: file
J
J
jbranso wrote on 28 Sep 2023 20:38
5a5c7f090c9fec0f2795846cce95101a@dismail.de
September 26, 2023 5:50 PM, "Sus Amogus" <iskrim666@gmail.com> wrote:

Toggle quote (3 lines)
> I'm currently working on building Guix System for powerpc64le, and I've encountered a few issues
> that I could use some assistance with.

Sweet! My friend ownes a blackbird and a Talso II! Let me know if you need help building grub
or various testing!

Toggle quote (19 lines)
>
> Firstly, linux-initrd failing because gcc-7.5 package used for bootstrap-glibc do not support
> --with-long-double-128. Removing this works just fine -- with last gcc package:
>
>> /gnu/packages/make-bootstrap.scm
>
>> (native-inputs
>
>> `(("gcc" ,gcc-7.5)
>
>> ,@(package-native-inputs base)))
>
> I'm curious why gcc-7.5 was built without --with-long-double-128, especially considering it's
> defined for powerpc64le-linux in /gnu/packages/gcc.scm under (gcc-configure-flags-for-triplet).
>
> Furthermore, I've encountered issues with Grub, which are detailed in this issue:
> https://issues.guix.gnu.org/54407. I believe that porting gcc-12-multilib from Debian could
> potentially resolve this problem.

Sounds like a good place to start!

Toggle quote (3 lines)
> Lastly, any image generated from (system-disk-image) depends on grub-efi{,32}, but (a) grub-efi
> build fails on ppc*, and (b) ppc* systems do not use EFI.

Yeah...the Talos II has peptiboot installed in the bios or something?

Toggle quote (2 lines)
> The remaining problems mostly involve software patching or minor code adjustments.

Definitely ask for for help in testing this stuff!
Toggle quote (4 lines)
> Best regards,
>
> Mykhailo Chernysh
> iskrim666@gmail.com
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 66205@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 66205
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch