[PATCH] gnu: lhasa: Update to 0.4.0.

  • Done
  • quality assurance status badge
Details
2 participants
  • Hendursaga
  • Christopher Baines
Owner
unassigned
Submitted by
Hendursaga
Severity
normal

Debbugs page

Hendursaga wrote 1 years ago
(address . guix-patches@gnu.org)
c01b1116a5abb21e7b0928cfcb58279f230a8c0e.1695664069.git.hendursaga@aol.com
* gnu/packages/compression.scm (lhasa): Update to 0.4.0.
[arguments]: Use G-expressions.
[home-page]: Switch to github.io.
[description]: Add Texinfo markup.
---
gnu/packages/compression.scm | 35 +++++++++++++++++------------------
1 file changed, 17 insertions(+), 18 deletions(-)

Toggle diff (60 lines)
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index beaac3fccb..43e02b895d 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -542,7 +542,7 @@ (define-public xz
(define-public lhasa
(package
(name "lhasa")
- (version "0.3.1")
+ (version "0.4.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -550,26 +550,25 @@ (define-public lhasa
version "/lhasa-" version ".tar.gz"))
(sha256
(base32
- "092zi9av18ma20c6h9448k0bapvx2plnp292741dvfd9hmgqxc1z"))))
+ "1cy5429c7h1dp4l5y9ncdy40qarl9ix31ylkzdi8al2c60y8iz57"))))
(build-system gnu-build-system)
(arguments
- '(#:phases
- (modify-phases %standard-phases
- (add-before 'check 'set-up-test-environment
- (lambda* (#:key inputs #:allow-other-keys)
- (setenv "TZDIR"
- (search-input-directory inputs
- "share/zoneinfo")))))))
- (native-inputs
- (list tzdata-for-tests))
- (home-page "https://fragglet.github.com/lhasa/")
+ (list #:phases #~(modify-phases %standard-phases
+ (add-before 'check 'set-up-test-environment
+ (lambda* (#:key inputs #:allow-other-keys)
+ (setenv "TZDIR"
+ (search-input-directory inputs
+ "share/zoneinfo")))))))
+ (native-inputs (list tzdata-for-tests))
+ (home-page "https://fragglet.github.io/lhasa/")
(synopsis "LHA archive decompressor")
- (description "Lhasa is a replacement for the Unix LHA tool, for
-decompressing .lzh (LHA / LHarc) and .lzs (LArc) archives. The backend for the
-tool is a library, so that it can be reused for other purposes. Lhasa aims to
-be compatible with as many types of lzh/lzs archives as possible. It also aims
-to generate the same output as the (non-free) Unix LHA tool, so that it will
-act as a free drop-in replacement.")
+ (description
+ "Lhasa is a replacement for the Unix LHa tool, for decompressing
+@file{.lzh} (LHA / LHarc) and .lzs (LArc) archives. The backend for the tool is
+a library, so that it can be reused for other purposes. Lhasa aims to be
+compatible with as many types of @file{.lzh}/@file{lzs} archives as possible.
+It also aims to generate the same output as the (non-free) Unix @command{lha}
+tool, so that it will act as a free drop-in replacement.")
(license license:isc)))
(define-public lzo

base-commit: 1d872a67054291bf05ef00185b60f73d6608bf18
--
2.41.0
Christopher Baines wrote 1 years ago
(name . Hendursaga)(address . hendursaga@aol.com)
87ttrfbzs8.fsf@cbaines.net
Hendursaga via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (8 lines)
> * gnu/packages/compression.scm (lhasa): Update to 0.4.0.
> [arguments]: Use G-expressions.
> [home-page]: Switch to github.io.
> [description]: Add Texinfo markup.
> ---
> gnu/packages/compression.scm | 35 +++++++++++++++++------------------
> 1 file changed, 17 insertions(+), 18 deletions(-)

Thanks for the patch, I've pushed this to master as
5c3e4c826f35a7eaace878b1782dd3cb66bd74fa.

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmUUFxdfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9Xc6zBAAkYPRUYlh4afOG3rVKOCoOWQw2HZGeSNo
5oS05SSY0rUQZyJ5eds/atFrEHcj29uH3jkn0BXfeel/wclfdr6c8Lr9uoJw5N7L
cWrAYvcN0igGqQ6Tj/p6Ca3Mnzct3jF0JHNBMKy11aNWAKSSeQ7nL2lOCAg31mKk
3U9zXI58J2urQI0FvEfuLx6ZzbBwKe4YPdxbPkTGoEOJfhpOwDA1mkNZir93jd4s
h9ItNxaRxsraXfpGQ1U0LhsTI34u6HZgG+dqPksHRI0Dp68b/wd3YOhNdQVfl819
XNR8XPM2igilcEdtizJLudHZzruRJczY9srQPm2ds+9N8GMXwo0a/zPSyKQcKyEK
4S3dXgnpkySAWAyhhS7Va0cLTZnqg85l5/JkgN/NlDRwEZ9pf1aFafOE9M9+HyBJ
gyLVNn/3EV6Q2A6KMHMKmTWU8Pm0uqir8kt7IMOqKbSD1PaeBOHx+T1OEttf7Fxw
0pQg41lPupmmbXsRnTvFOFIC2Tv0g+GkbR6jAUhwhpJEQWhJGGIIbOL+D2VgHe8x
mWq2evxGbAZ/FWibD7XXMEoCCWnp2l8RjEnbankjmMrT+LukaSQ10vck989WHxML
057IHQSZBTDPzETyCW3X4QKKRZTGq3v3oTStf6TRX0x8qnxu05phYgPMAgl71QCS
dAFi1CvZfMI=
=dJQQ
-----END PGP SIGNATURE-----

?
Your comment

This issue is archived.

To comment on this conversation send an email to 66194@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 66194
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help