git error: object not found when running system reconfigure
(address . bug-guix@gnu.org)(address . chris@bumblehead.com)
Hello,
For the past day or so `sudo guix system reconfigure guix.system.scm` results in the error attached to this mail. The id value has changed from yesterday. I visited the irc channel and someone there recommended the same advice found here https://issues.guix.gnu.org/40769to delete "~/.cache/guix" and actually I deleted all "~/.cache" but the error is still there.
This morning, again, I tried "rm -r ~/.cache/guix" and "sudo guix system reconfigure guix.system.scm" and the same error occurred and I don't know how to resolve.
Thanks for any advice,
Chris
Backtrace:
In guix/ui.scm:
2286:10 19 (run-guix-command _ . _)
In ice-9/boot-9.scm:
1752:10 18 (with-exception-handler _ _ #:unwind? _ # _)
In guix/status.scm:
859:3 17 (_)
839:4 16 (call-with-status-report _ _)
In guix/scripts/system.scm:
1278:4 15 (_)
In ice-9/boot-9.scm:
1752:10 14 (with-exception-handler _ _ #:unwind? _ # _)
In guix/store.scm:
659:37 13 (thunk)
1298:8 12 (call-with-build-handler #<procedure 7f1a4bce1360 at g…> …)
2168:25 11 (run-with-store #<store-connection 256.99 7f1a50081730> …)
In guix/scripts/system.scm:
1302:15 10 (_ _)
831:5 9 (perform-action reconfigure #<<image> name: #f format:…> …)
In guix/scripts/system/reconfigure.scm:
346:3 8 (check-forward-update _ #:current-channels _)
In srfi/srfi-1.scm:
691:23 7 (filter-map #<procedure 7f1a64222da0 at guix/scripts…> . #)
In guix/scripts/system/reconfigure.scm:
353:39 6 (_ #<<channel> name: guix url: "https://git.savannah.gn…>)
In guix/git.scm:
481:21 5 (update-cached-checkout _ #:ref _ #:recursive? _ # _ # _ …)
367:15 4 (reference-available? _ _)
In git/commit.scm:
172:8 3 (_ #<git-repository 2079780> #<oid e134686cead6db62ea8b…>)
In git/bindings.scm:
77:2 2 (raise-git-error _)
In ice-9/boot-9.scm:
1685:16 1 (raise-exception _ #:continuable? _)
1685:16 0 (raise-exception _ #:continuable? _)
ice-9/boot-9.scm:1685:16: In procedure raise-exception:
Git error: object not found - no match for id (e134686cead6db62ea8b941b2ed7c0bd660804da)