merge commits may harm your cache maybe?

  • Done
  • quality assurance status badge
Details
3 participants
  • chris
  • Liliana Marie Prikler
  • Simon Tournier
Owner
unassigned
Submitted by
chris
Severity
important
Merged with

Debbugs page

chris wrote 1 years ago
git error: object not found when running system reconfigure
(address . bug-guix@gnu.org)(address . chris@bumblehead.com)
ZRBfnJSjOpm3P6CW@guix-xps
Hello,


For the past day or so `sudo guix system reconfigure guix.system.scm` results in the error attached to this mail. The id value has changed from yesterday. I visited the irc channel and someone there recommended the same advice found here https://issues.guix.gnu.org/40769to delete "~/.cache/guix" and actually I deleted all "~/.cache" but the error is still there.

This morning, again, I tried "rm -r ~/.cache/guix" and "sudo guix system reconfigure guix.system.scm" and the same error occurred and I don't know how to resolve.

Thanks for any advice,

Chris
Backtrace:
In guix/ui.scm:
2286:10 19 (run-guix-command _ . _)
In ice-9/boot-9.scm:
1752:10 18 (with-exception-handler _ _ #:unwind? _ # _)
In guix/status.scm:
859:3 17 (_)
839:4 16 (call-with-status-report _ _)
In guix/scripts/system.scm:
1278:4 15 (_)
In ice-9/boot-9.scm:
1752:10 14 (with-exception-handler _ _ #:unwind? _ # _)
In guix/store.scm:
659:37 13 (thunk)
1298:8 12 (call-with-build-handler #<procedure 7f1a4bce1360 at g…> …)
2168:25 11 (run-with-store #<store-connection 256.99 7f1a50081730> …)
In guix/scripts/system.scm:
1302:15 10 (_ _)
831:5 9 (perform-action reconfigure #<<image> name: #f format:…> …)
In guix/scripts/system/reconfigure.scm:
346:3 8 (check-forward-update _ #:current-channels _)
In srfi/srfi-1.scm:
691:23 7 (filter-map #<procedure 7f1a64222da0 at guix/scripts…> . #)
In guix/scripts/system/reconfigure.scm:
353:39 6 (_ #<<channel> name: guix url: "https://git.savannah.gn…>)
In guix/git.scm:
481:21 5 (update-cached-checkout _ #:ref _ #:recursive? _ # _ # _ …)
367:15 4 (reference-available? _ _)
In git/commit.scm:
172:8 3 (_ #<git-repository 2079780> #<oid e134686cead6db62ea8b…>)
In git/bindings.scm:
77:2 2 (raise-git-error _)
In ice-9/boot-9.scm:
1685:16 1 (raise-exception _ #:continuable? _)
1685:16 0 (raise-exception _ #:continuable? _)

ice-9/boot-9.scm:1685:16: In procedure raise-exception:
Git error: object not found - no match for id (e134686cead6db62ea8b941b2ed7c0bd660804da)
chris wrote 1 years ago
rm -r /root/.cache/guix # works
(address . 66182@debbugs.gnu.org)(address . chris@bumblehead.com)
ZRBqbkhcrLseMXJg@guix-xps
The issue is resolved here. Per irc discussion, root's guix cache was removed
```
sudo rm -r /root/.cache/guix
sudo rm -r /root/.cache/guile
```

After that, `guix pull` and `sudo guix system reconfigure guix.system.scm` succeeded
Liliana Marie Prikler wrote 1 years ago
(address . control@debbugs.gnu.org)
ee7fd83cc9364ea60fc3d4c98a0e5922b7dceeec.camel@gmail.com
merge 66169 66182
retitle 66169 merge commits may harm your cache maybe?
severity 66169 important
thanks
Simon Tournier wrote 1 years ago
(address . chris@bumblehead.com)
87v8by5xgk.fsf@gmail.com
Hi,

Thanks for the report. And sorry for the annoyance. The culprit is
6d33c1f8061e86d63ab5c9ec75df9c58130c7264 reducing the number of network
access.

The error should be fixed with 94f3831e5bb1e04eeb3a0e7d31a0675208ce6f4c.

Let me know.

Cheers,
simon
?
Your comment

This issue is archived.

To comment on this conversation send an email to 66182@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 66182
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help