[PATCH] gnu: git: Install shell completions.

  • Done
  • quality assurance status badge
Details
4 participants
  • Efraim Flashner
  • Liliana Marie Prikler
  • Maxim Cournoyer
  • Simon Tournier
Owner
unassigned
Submitted by
Liliana Marie Prikler
Severity
normal
L
L
Liliana Marie Prikler wrote on 23 Sep 2023 21:43
(address . guix-patches@gnu.org)
e5452a70381443c07400cabf7f8c098cdb9849bf.1695498272.git.liliana.prikler@gmail.com
* gnu/packages/version-control.scm (git)[outputs]: Add “completion”.
[#:phases]: Add ‘install-completion’.
---
gnu/packages/version-control.scm | 15 +++++++++++++++
1 file changed, 15 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 9716a6f27a..54b2ed74fb 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -303,6 +303,7 @@ (define-public git
"credential-netrc" ; git-credential-netrc
"credential-libsecret" ; git-credential-libsecret
"subtree" ; git-subtree
+ "completion" ; git-completion and git-prompt
"gui")) ; gitk, git gui
(arguments
`(#:make-flags `("V=1" ;more verbose compilation
@@ -482,6 +483,20 @@ (define-public git
(string-append subtree "/bin"))
(install-file "contrib/subtree/git-subtree.1"
(string-append subtree "/share/man/man1")))))
+ (add-after 'install 'install-completion
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((completion (assoc-ref outputs "completion")))
+ (define (install-as file storename)
+ (let ((storename (string-append completion storename)))
+ (mkdir-p (dirname storename))
+ (copy-file file storename)))
+ (with-directory-excursion "contrib/completion"
+ (for-each (cut apply install-as <>)
+ `(("git-prompt.sh" "/bin/git-prompt")
+ ("git-completion.bash"
+ "/share/bash-completion/completions/_git")
+ ("git-completion.zsh"
+ "/share/zsh/site-functions/_git")))))))
(add-after 'install 'restore-sample-hooks-shebang
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))

base-commit: 4f35ff1275e05be31f5d41464ccf147e9dbfd016
prerequisite-patch-id: ee5d7299c5790d77e0d409f34165063fcff10a8b
--
2.41.0
S
S
Simon Tournier wrote on 25 Sep 2023 13:12
87r0mm5wwb.fsf@gmail.com
Hi,

On Sat, 23 Sep 2023 at 21:43, Liliana Marie Prikler <liliana.prikler@gmail.com> wrote:
Toggle quote (3 lines)
> * gnu/packages/version-control.scm (git)[outputs]: Add “completion”.
> [#:phases]: Add ‘install-completion’.

Naive question: this also adds “completion” to git-minimal, no? I mean,
does the phase need to be deleted in git-minimal?

Cheers,
simon
L
L
Liliana Marie Prikler wrote on 23 Sep 2023 21:43
[PATCH v2] gnu: git: Install shell completions.
(address . 66171@debbugs.gnu.org)(name . Simon Tournier)(address . zimon.toutoune@gmail.com)
7be0975a4d30362dec08c3115e68c992e58ab549.1695660890.git.liliana.prikler@gmail.com
* gnu/packages/version-control.scm (git)[outputs]: Add “completion”.
[#:phases]: Add ‘install-completion’.
(git-minimal)[#:phases]: Adjust accordingly.
---
Am Montag, dem 25.09.2023 um 13:12 +0200 schrieb Simon Tournier:
Toggle quote (2 lines)
> Naive question: this also adds “completion” to git-minimal, no? I mean,
> does the phase need to be deleted in git-minimal?
Indeed it does; updated the patch accordingly.

Cheers

gnu/packages/version-control.scm | 16 ++++++++++++++++
1 file changed, 16 insertions(+)

Toggle diff (45 lines)
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 9716a6f27a..35d17d434e 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -303,6 +303,7 @@ (define-public git
"credential-netrc" ; git-credential-netrc
"credential-libsecret" ; git-credential-libsecret
"subtree" ; git-subtree
+ "completion" ; git-completion and git-prompt
"gui")) ; gitk, git gui
(arguments
`(#:make-flags `("V=1" ;more verbose compilation
@@ -482,6 +483,20 @@ (define-public git
(string-append subtree "/bin"))
(install-file "contrib/subtree/git-subtree.1"
(string-append subtree "/share/man/man1")))))
+ (add-after 'install 'install-completion
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((completion (assoc-ref outputs "completion")))
+ (define (install-as file storename)
+ (let ((storename (string-append completion storename)))
+ (mkdir-p (dirname storename))
+ (copy-file file storename)))
+ (with-directory-excursion "contrib/completion"
+ (for-each (cut apply install-as <>)
+ `(("git-prompt.sh" "/bin/git-prompt")
+ ("git-completion.bash"
+ "/share/bash-completion/completions/_git")
+ ("git-completion.zsh"
+ "/share/zsh/site-functions/_git")))))))
(add-after 'install 'restore-sample-hooks-shebang
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
@@ -639,6 +654,7 @@ (define-public git-minimal
(delete 'install-subtree)
(delete 'install-credential-netrc)
(delete 'install-credential-libsecret)
+ (delete 'install-completion)
(add-after 'install 'remove-unusable-perl-commands
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))

base-commit: e134686cead6db62ea8b941b2ed7c0bd660804da
--
2.41.0
M
M
Maxim Cournoyer wrote on 25 Sep 2023 19:51
Re: bug#66171: [PATCH] gnu: git: Install shell completions.
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)
877coe2lap.fsf_-_@gmail.com
Hello,

Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

Toggle quote (4 lines)
> * gnu/packages/version-control.scm (git)[outputs]: Add “completion”.
> [#:phases]: Add ‘install-completion’.
> (git-minimal)[#:phases]: Adjust accordingly.

Did something change in git? I've always had completion in git, so I'm
not sure what this extra phase does, or when it's useful? Does it add
*extra* completion or... ?

Also, a completion output seems a bit over the top. I doubt its weigh
justifies the annoyance of special casing it.

--
Thanks,
Maxim
L
L
Liliana Marie Prikler wrote on 25 Sep 2023 20:41
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)
7659d2d5a891bb3ee81e87ab484924f3337cae81.camel@gmail.com
Am Montag, dem 25.09.2023 um 13:51 -0400 schrieb Maxim Cournoyer:
Toggle quote (12 lines)
> Hello,
>
> Liliana Marie Prikler <liliana.prikler@gmail.com> writes:
>
> > * gnu/packages/version-control.scm (git)[outputs]: Add
> > “completion”.
> > [#:phases]: Add ‘install-completion’.
> > (git-minimal)[#:phases]: Adjust accordingly.
>
> Did something change in git?  I've always had completion in git, so
> I'm not sure what this extra phase does, or when it's useful?  Does
> it add *extra* completion or... ?
Which shell are you using? If it's zsh, then the completion is baked
in. If it's bash, idk, I haven't tried. I personally use this for the
included git-prompt, which allows me to have my prompt look like the
following:

\u@\h /path/to/guix [$branch env] ($SHLVL) \$

Toggle quote (2 lines)
> Also, a completion output seems a bit over the top.  I doubt its
> weigh justifies the annoyance of special casing it.
I special-cased it because it *is* a contrib script, but also as it
might be able to conflict with whatever shell builtins you have. Now
it isn't particularly likely to do so given that other distros include
it as part of their git-core, but I prefer safe over sorry.

That being said, I could just write it to out if you prefer that.

Cheers
M
M
Maxim Cournoyer wrote on 26 Sep 2023 18:36
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)
87ttrgzybq.fsf@gmail.com
Hi,

Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

Toggle quote (20 lines)
> Am Montag, dem 25.09.2023 um 13:51 -0400 schrieb Maxim Cournoyer:
>> Hello,
>>
>> Liliana Marie Prikler <liliana.prikler@gmail.com> writes:
>>
>> > * gnu/packages/version-control.scm (git)[outputs]: Add
>> > “completion”.
>> > [#:phases]: Add ‘install-completion’.
>> > (git-minimal)[#:phases]: Adjust accordingly.
>>
>> Did something change in git?  I've always had completion in git, so
>> I'm not sure what this extra phase does, or when it's useful?  Does
>> it add *extra* completion or... ?
> Which shell are you using? If it's zsh, then the completion is baked
> in. If it's bash, idk, I haven't tried. I personally use this for the
> included git-prompt, which allows me to have my prompt look like the
> following:
>
> \u@\h /path/to/guix [$branch env] ($SHLVL) \$

I see. I use Bash.

Toggle quote (8 lines)
>
>> Also, a completion output seems a bit over the top.  I doubt its
>> weigh justifies the annoyance of special casing it.
> I special-cased it because it *is* a contrib script, but also as it
> might be able to conflict with whatever shell builtins you have. Now
> it isn't particularly likely to do so given that other distros include
> it as part of their git-core, but I prefer safe over sorry.

Ah, if it's just a contrib I guess a dedicated output is fine, although
i'd perhaps call such output 'contrib', as completions seem to imply
that without it there are no auto-completion support, which is clearly
not the case, at least for Bash.

--
Thanks,
Maxim
E
E
Efraim Flashner wrote on 28 Sep 2023 16:41
Re: [bug#66171] [PATCH] gnu: git: Install shell completions.
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)
ZRWQjsjXZJQppNp5@3900XT
On Mon, Sep 25, 2023 at 08:41:05PM +0200, Liliana Marie Prikler wrote:
Toggle quote (20 lines)
> Am Montag, dem 25.09.2023 um 13:51 -0400 schrieb Maxim Cournoyer:
> > Hello,
> >
> > Liliana Marie Prikler <liliana.prikler@gmail.com> writes:
> >
> > > * gnu/packages/version-control.scm (git)[outputs]: Add
> > > “completion”.
> > > [#:phases]: Add ‘install-completion’.
> > > (git-minimal)[#:phases]: Adjust accordingly.
> >
> > Did something change in git?  I've always had completion in git, so
> > I'm not sure what this extra phase does, or when it's useful?  Does
> > it add *extra* completion or... ?
> Which shell are you using? If it's zsh, then the completion is baked
> in. If it's bash, idk, I haven't tried. I personally use this for the
> included git-prompt, which allows me to have my prompt look like the
> following:
>
> \u@\h /path/to/guix [$branch env] ($SHLVL) \$

/gnu/store/p7zln1rzsccq8vgpnrm4ibz5hcgxrqd9-git-2.41.0/etc/bash_completion.d/git
It looks like there is a bash completion from git. I thought maybe it
was from the bash-completions package.

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmUVkIsACgkQQarn3Mo9
g1ErNQ/6A+R0hpBSs9j/+sdd/FkfugWTfoxaQf6n6Eg8DO4MdDO7yHG+g5Wu6VVY
EWD1CxMYDiLzJlDhWGzeXt1yrTpz3A0ENQXmbA/srmwCSl8Exuh57pcSfc384K5r
UQ7XPDv79GwgMe3LzZNFHjS0/9rHRqC3JXPH0CSSti/AWDbQ/ftBw5Gb1rx3efEW
TRuvfGTTgeTKpzb83Px6MvuwFRXqa4PPgO1B1R+8ZsIpvNZnRRauZEHv6+zwVCfw
vq4bIhRye6IG2Tmhaq96T1VW3QtYSBkQs/h80O2EJ9mhFX2YbuK5Xz1tNWGZXSIJ
uvQizyJ0DlNFA/mabOBOJCUqfJ2hkKdYMhfbs9yakYS3x+HX1vppC5FMU4MC/ibS
FsUzRtGLJfeWMLLTufHUhDuK+FYRb9seJNzCO1ZY6rmWtuMptxLlNj/NNVvsBInv
1JL70WxrhIG8CRVqnLPLaAjk0A4J8RP1R3o+Av2zKXEpcmzN6PkdyLKshj2x6EvN
wgVqv3wZmhk4r9egJyYEWjQhD78N1GAc/+9JaCywAaIPuLRHuW2SXCqW6Bxc7VyQ
RyUeu/vGEmyod3WKCXX3083NhPs9yaqfoLWSd2K0cvshjR9itv5N6But6czXLWRQ
FIBnsQe8bOTR1WdZ0Sc5N6gBCyWxEixT0CIiA6H3DySR6J8hHbk=
=qFhd
-----END PGP SIGNATURE-----


L
L
Liliana Marie Prikler wrote on 23 Sep 2023 21:43
[PATCH v3] gnu: git: Install zsh completions and git-prompt.
(address . 66171@debbugs.gnu.org)
00b2291bb7eaa66b3f62ea4d94e44bf85ec62b51.1695927171.git.liliana.prikler@gmail.com
* gnu/packages/version-control.scm (git)[#:phases]<install-shell-completion>:
Also install git-prompt and zsh _git site function.
---
gnu/packages/version-control.scm | 15 ++++++++++-----
1 file changed, 10 insertions(+), 5 deletions(-)

Toggle diff (35 lines)
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 9716a6f27a..d8c9bf4009 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -448,12 +448,17 @@ (define-public git
"DOCBOOK2X_TEXI=docbook2texi" "PERL_PATH=perl")))
(add-after 'install 'install-shell-completion
(lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (completions (string-append out "/etc/bash_completion.d")))
- ;; TODO: Install the tcsh and zsh completions in the right place.
- (mkdir-p completions)
+ (let* ((out (assoc-ref outputs "out"))
+ (bash (string-append out "/etc/bash_completion.d"))
+ (zsh (string-append out "/share/zsh/site-functions")))
+ ;; TODO: Install the tcsh completions in the right place.
+ (for-each mkdir-p (list bash zsh))
(copy-file "contrib/completion/git-completion.bash"
- (string-append completions "/git")))))
+ (string-append bash "/git"))
+ (copy-file "contrib/completion/git-prompt.sh"
+ (string-append out "/bin/git-prompt"))
+ (copy-file "contrib/completion/git-completion.zsh"
+ (string-append zsh "/_git")))))
(add-after 'install 'install-credential-netrc
(lambda* (#:key outputs #:allow-other-keys)
(let* ((netrc (assoc-ref outputs "credential-netrc")))

base-commit: ce0cc6137df81919389f61671096a6ce701c0889
prerequisite-patch-id: ee5d7299c5790d77e0d409f34165063fcff10a8b
prerequisite-patch-id: 369548fa905a48e7e2164ca4b6c9897e392a5025
prerequisite-patch-id: 7650e691c505ecc63e3b1a1265b3cb3a2869443e
prerequisite-patch-id: 5e7e47f338fa42c4f5c654a803f062b5e3f757a6
--
2.41.0
M
M
Maxim Cournoyer wrote on 2 Oct 2023 05:34
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)
875y3p66jj.fsf@gmail.com
Hi Liliana,

Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

Toggle quote (34 lines)
> * gnu/packages/version-control.scm (git)[#:phases]<install-shell-completion>:
> Also install git-prompt and zsh _git site function.
> ---
> gnu/packages/version-control.scm | 15 ++++++++++-----
> 1 file changed, 10 insertions(+), 5 deletions(-)
>
> diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
> index 9716a6f27a..d8c9bf4009 100644
> --- a/gnu/packages/version-control.scm
> +++ b/gnu/packages/version-control.scm
> @@ -448,12 +448,17 @@ (define-public git
> "DOCBOOK2X_TEXI=docbook2texi" "PERL_PATH=perl")))
> (add-after 'install 'install-shell-completion
> (lambda* (#:key outputs #:allow-other-keys)
> - (let* ((out (assoc-ref outputs "out"))
> - (completions (string-append out "/etc/bash_completion.d")))
> - ;; TODO: Install the tcsh and zsh completions in the right place.
> - (mkdir-p completions)
> + (let* ((out (assoc-ref outputs "out"))
> + (bash (string-append out "/etc/bash_completion.d"))
> + (zsh (string-append out "/share/zsh/site-functions")))
> + ;; TODO: Install the tcsh completions in the right place.
> + (for-each mkdir-p (list bash zsh))
> (copy-file "contrib/completion/git-completion.bash"
> - (string-append completions "/git")))))
> + (string-append bash "/git"))
> + (copy-file "contrib/completion/git-prompt.sh"
> + (string-append out "/bin/git-prompt"))
> + (copy-file "contrib/completion/git-completion.zsh"
> + (string-append zsh "/_git")))))
> (add-after 'install 'install-credential-netrc
> (lambda* (#:key outputs #:allow-other-keys)
> (let* ((netrc (assoc-ref outputs "credential-netrc")))

Sorry if my previous reply was not clear, but with your clarifications I
think it'd be best to keep the 'contrib' output, perhaps documenting in
the description that it contains the 'git-prompt' command as well as
completions for Zsh?

--
Thanks,
Maxim
L
L
Liliana Marie Prikler wrote on 2 Oct 2023 06:30
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)
9829503773a753da78f3e18add0833a6d115305c.camel@gmail.com
Am Sonntag, dem 01.10.2023 um 23:34 -0400 schrieb Maxim Cournoyer:
Toggle quote (9 lines)
> Hi Liliana,
>
> Liliana Marie Prikler <liliana.prikler@gmail.com> writes:
>
> > [...]
> Sorry if my previous reply was not clear, but with your
> clarifications I think it'd be best to keep the 'contrib' output,
> perhaps documenting in the description that it contains the 'git-
> prompt' command as well as completions for Zsh?
IMHO, a ‘contrib’ output would be silly, since so much of what we
install in other outputs are part of contrib. The name lacks meaning.

As for why I put it in ‘out’ instead of ‘completion’, I did miss the
fact that we already install git completions for bash, so not that I
know, I just extended the phase that does that.

Cheers
E
E
Efraim Flashner wrote on 2 Oct 2023 11:12
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)
ZRqJakoaXC0snbry@3900XT
On Mon, Oct 02, 2023 at 06:30:59AM +0200, Liliana Marie Prikler wrote:
Toggle quote (17 lines)
> Am Sonntag, dem 01.10.2023 um 23:34 -0400 schrieb Maxim Cournoyer:
> > Hi Liliana,
> >
> > Liliana Marie Prikler <liliana.prikler@gmail.com> writes:
> >
> > > [...]
> > Sorry if my previous reply was not clear, but with your
> > clarifications I think it'd be best to keep the 'contrib' output,
> > perhaps documenting in the description that it contains the 'git-
> > prompt' command as well as completions for Zsh?
> IMHO, a ‘contrib’ output would be silly, since so much of what we
> install in other outputs are part of contrib. The name lacks meaning.
>
> As for why I put it in ‘out’ instead of ‘completion’, I did miss the
> fact that we already install git completions for bash, so not that I
> know, I just extended the phase that does that.

It's not uncommon to see shell completions in a contrib directory. I
think it'd make more sense to install them to a 'completions' output
than to a 'contrib' output, but I think it would make the most sense to
just install them to the 'out' output.

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmUaiWoACgkQQarn3Mo9
g1HsgA//aQMaHFN58e08ltX26pKC+tZ89vbll339GCSYZBza0GFNfog7RhWoj0nh
VEtD/lidJ/vwzpxY7xzxO32yYK4w4tz0nO+5Ky5X/J0UhmAYlLUImPqAWhj5mppK
KdE7V4YSenWEQwZlh+EkcUI2uFDo7UDxZoyOLY86i19iypFkfXFOZeZr+eek3j7e
bMy6j1+LEioEmSSV1/5jqj2DJjUFWQBXfvj+PN2q37ju2CSRNi9WQKycfq3uJcq0
zGeyQ+PtfKEs5sBaR7g9wADV2oAyY+qEGAlNDTipyKFsz9+Lw+uh/i6gosyp8J/h
67UdNud5X1IZDVsL7Kqz4ORH/bnCPxDZd/xltnWTOseZX27Z2TKi8s6Zpb9f2oWs
LkF67F8aitimOTPhkc8io4iM3a9+2XjT6LrQzw8DcdTP2oZzlm+CAN1oPzNNtaxS
WM4eY8IVIcHDv5Z4l6vit2vOXs1txGibInlu6vSbjgz7cf2McD0LxmXvtKwDesSh
5x753t4xqLLNlg4P/AZ29pFIb0bZivN8NXVPiv+YmUF/3Fw//2CJ8dAwWIlmt7MJ
kfyG7+R6Zqv4HSrKQWKTwlNQgX2KlINjVVcqZgdoYBZZgxHgH+/xSK+LaoE4mfl4
ItODyONAPjBDRO1UMwRIuT2Uh7erynL88VYVqXy75eWeeV9r0YA=
=pfPr
-----END PGP SIGNATURE-----


M
M
Maxim Cournoyer wrote on 4 Oct 2023 02:35
(name . Efraim Flashner)(address . efraim@flashner.co.il)
87r0mb6x7k.fsf@gmail.com
Hi,

Efraim Flashner <efraim@flashner.co.il> writes:

Toggle quote (23 lines)
> On Mon, Oct 02, 2023 at 06:30:59AM +0200, Liliana Marie Prikler wrote:
>> Am Sonntag, dem 01.10.2023 um 23:34 -0400 schrieb Maxim Cournoyer:
>> > Hi Liliana,
>> >
>> > Liliana Marie Prikler <liliana.prikler@gmail.com> writes:
>> >
>> > > [...]
>> > Sorry if my previous reply was not clear, but with your
>> > clarifications I think it'd be best to keep the 'contrib' output,
>> > perhaps documenting in the description that it contains the 'git-
>> > prompt' command as well as completions for Zsh?
>> IMHO, a ‘contrib’ output would be silly, since so much of what we
>> install in other outputs are part of contrib. The name lacks meaning.
>>
>> As for why I put it in ‘out’ instead of ‘completion’, I did miss the
>> fact that we already install git completions for bash, so not that I
>> know, I just extended the phase that does that.
>
> It's not uncommon to see shell completions in a contrib directory. I
> think it'd make more sense to install them to a 'completions' output
> than to a 'contrib' output, but I think it would make the most sense to
> just install them to the 'out' output.

Sounds good!

--
Thanks,
Maxim
M
M
Maxim Cournoyer wrote on 10 Oct 2023 05:33
Re: [bug#66171] [PATCH v3] gnu: git: Install zsh completions and git-prompt.
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)
8734yj883o.fsf@gmail.com
Hello,

Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

Toggle quote (3 lines)
> * gnu/packages/version-control.scm (git)[#:phases]<install-shell-completion>:
> Also install git-prompt and zsh _git site function.

Applied to core-updates, after resolving the conflict.

--
Thanks,
Maxim
Closed
?