* gnu/packages/ocaml.scm (ocaml-toml): New variable.
---
gnu/packages/ocaml.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)
Toggle diff (38 lines)
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 96ef416b30..4941dd91ac 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -5040,6 +5040,31 @@ (define-public ocaml-ezjsonm
JSON.")
(license license:isc)))
+(define-public ocaml-toml
+ (package
+ (name "ocaml-toml")
+ (version "7.1.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ocaml-toml/to.ml")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0z2873mj3i6h9cg8zlkipcjab8jympa4c4avhk4l04755qzphkds"))))
+ (build-system dune-build-system)
+ (propagated-inputs (list ocaml-odoc ocaml-iso8601))
+ (native-inputs (list ocaml-menhir ocaml-ounit2 ocaml-mdx ocaml-bisect-ppx
+ ocaml-ocb))
+ (home-page "https://ocaml-toml.github.io/To.ml/")
+ (synopsis "OCaml library for TOML with a parser, a serializer and a printer")
+ (description
+ "Toml is an OCaml library providing a parser, a serializer and a printer for
+TOML, a minimal configuration file format. Helpful getters to retrieve data as
+OCaml primitive types are also supplied.")
+ (license license:lgpl3)))
+
(define-public ocaml-uri
(package
(name "ocaml-uri")
--
2.41.0