[PATCH 0/3] Some OCaml packages (needed for ocaml-toml)

  • Open
  • quality assurance status badge
Details
3 participants
  • Ludovic Courtès
  • pukkamustard
  • Matthieu Lemerre
Owner
unassigned
Submitted by
Matthieu Lemerre
Severity
normal
M
M
Matthieu Lemerre wrote on 20 Sep 2023 12:45
(address . guix-patches@gnu.org)(name . Matthieu Lemerre)(address . racin@free.fr)
cover.1695203766.git.racin@free.fr
Hello,

Here are three missing OCaml packages. (I have more to come, but I want to make sure that I got the process right)

Best regards,
Matthieu

Matthieu Lemerre (3):
gnu: Add ocaml-iso8601.
gnu: Add ocaml-ocb.
gnu: Add ocaml-toml.

gnu/packages/ocaml.scm | 70 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 70 insertions(+)


base-commit: 15c5f1a2c20b21de0f19f42db1ccab4c42117ebb
--
2.41.0
M
M
Matthieu Lemerre wrote on 20 Sep 2023 12:50
[PATCH 1/3] gnu: Add ocaml-iso8601.
(address . 66119@debbugs.gnu.org)(name . Matthieu Lemerre)(address . racin@free.fr)
2bc75ea490306069a51706e822e49f8af87f00a8.1695203766.git.racin@free.fr
* gnu/packages/ocaml.scm (ocaml-iso8601): New variable.
---
gnu/packages/ocaml.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index ea9d3e3594..5caa2d6185 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -2445,6 +2445,28 @@ (define-public ocaml-calendar
;; With linking exception.
(license license:lgpl2.1+))))
+(define-public ocaml-iso8601
+ (package
+ (name "ocaml-iso8601")
+ (version "0.2.6")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ocaml-community/ISO8601.ml")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0nzadswspizi7s6sf67icn2xgc3w150x8vdg5nk1mjrm2s98n6d3"))))
+ (build-system dune-build-system)
+ (propagated-inputs (list ocaml-odoc))
+ (native-inputs (list ocaml-ounit))
+ (home-page "https://github.com/ocaml-community/ISO8601.ml/")
+ (synopsis "ISO 8601 and RFC 3999 date parsing for OCaml")
+ (description
+ "An OCaml library for parsing dates in ISO 8601 and RFC 3999 format.")
+ (license license:expat)))
+
(define-public ocaml-cmdliner
(package
(name "ocaml-cmdliner")
--
2.41.0
M
M
Matthieu Lemerre wrote on 20 Sep 2023 12:50
[PATCH 2/3] gnu: Add ocaml-ocb.
(address . 66119@debbugs.gnu.org)(name . Matthieu Lemerre)(address . racin@free.fr)
dfa2415028fbc9eaf1ba1a3c572b63ce9e50803f.1695203766.git.racin@free.fr
* gnu/packages/ocaml.scm (ocaml-ocb): New variable.
---
gnu/packages/ocaml.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 5caa2d6185..96ef416b30 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -5834,6 +5834,29 @@ (define-public ocaml-ocb-stubblr
OCaml projects that contain C stubs.")
(license license:isc)))
+
+(define-public ocaml-ocb
+ (package
+ (name "ocaml-ocb")
+ (version "0.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/OCamlPro/ocb")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1nk90jax91ld8qd36qi408mll8a7w1d60fa2qdsnff7cldwixc1d"))))
+ (build-system dune-build-system)
+ (propagated-inputs (list ocaml-odoc))
+ (home-page "https://ocamlpro.github.io/ocb/")
+ (synopsis "ocb (OCaml Badgen): SVG badge generation")
+ (description
+ "ocb (OCaml Badgen) is an OCaml library for SVG badge generation.
+There's also a command-line tool provided.")
+ (license license:isc)))
+
(define-public ocaml-tsdl
(package
(name "ocaml-tsdl")
--
2.41.0
M
M
Matthieu Lemerre wrote on 20 Sep 2023 12:50
[PATCH 3/3] gnu: Add ocaml-toml.
(address . 66119@debbugs.gnu.org)(name . Matthieu Lemerre)(address . racin@free.fr)
a3c875f2855a63ba346e155431397c17794b25b1.1695203766.git.racin@free.fr
* gnu/packages/ocaml.scm (ocaml-toml): New variable.
---
gnu/packages/ocaml.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 96ef416b30..4941dd91ac 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -5040,6 +5040,31 @@ (define-public ocaml-ezjsonm
JSON.")
(license license:isc)))
+(define-public ocaml-toml
+ (package
+ (name "ocaml-toml")
+ (version "7.1.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ocaml-toml/to.ml")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0z2873mj3i6h9cg8zlkipcjab8jympa4c4avhk4l04755qzphkds"))))
+ (build-system dune-build-system)
+ (propagated-inputs (list ocaml-odoc ocaml-iso8601))
+ (native-inputs (list ocaml-menhir ocaml-ounit2 ocaml-mdx ocaml-bisect-ppx
+ ocaml-ocb))
+ (home-page "https://ocaml-toml.github.io/To.ml/")
+ (synopsis "OCaml library for TOML with a parser, a serializer and a printer")
+ (description
+ "Toml is an OCaml library providing a parser, a serializer and a printer for
+TOML, a minimal configuration file format. Helpful getters to retrieve data as
+OCaml primitive types are also supplied.")
+ (license license:lgpl3)))
+
(define-public ocaml-uri
(package
(name "ocaml-uri")
--
2.41.0
P
P
pukkamustard wrote on 14 Oct 2023 08:25
Re: [bug#66119] [PATCH 0/3] Some OCaml packages (needed for ocaml-toml)
(name . Matthieu Lemerre)(address . racin@free.fr)
86jzrp7lqm.fsf@posteo.net
Hello,

Matthieu Lemerre <racin@free.fr> writes:

Toggle quote (2 lines)
> Here are three missing OCaml packages. (I have more to come, but I want to make sure that I got the process right)

Thanks!

Descriptions are good, packages build and lint does not complain. Looks
good to me!

One small thing: It seems like ocaml-ocb is not a real dependency of
ocaml-toml (not even a test dependency). It seems to be used only when
deploying new versions of ocaml-toml and ocaml-toml builds fine without
ocaml-ocb. I would drop ocaml-ocb from inputs of ocaml-toml and if you
have no use of ocaml-ocb directly, drop the entire ocaml-ocb patch.

Cheers,
pukkamustard
L
L
Ludovic Courtès wrote on 24 Oct 2023 17:31
(name . Matthieu Lemerre)(address . racin@free.fr)
87a5s882af.fsf@gnu.org
Hi Matthieu,

Did you get a change to look into what pukkamustard wrote (below)?

If you think everything is fine as-is, please let us know and we’ll
apply the patches.

Thanks,
Ludo’.

pukkamustard <pukkamustard@posteo.net> skribis:

Toggle quote (19 lines)
> Hello,
>
> Matthieu Lemerre <racin@free.fr> writes:
>
>> Here are three missing OCaml packages. (I have more to come, but I want to make sure that I got the process right)
>
> Thanks!
>
> Descriptions are good, packages build and lint does not complain. Looks
> good to me!
>
> One small thing: It seems like ocaml-ocb is not a real dependency of
> ocaml-toml (not even a test dependency). It seems to be used only when
> deploying new versions of ocaml-toml and ocaml-toml builds fine without
> ocaml-ocb. I would drop ocaml-ocb from inputs of ocaml-toml and if you
> have no use of ocaml-ocb directly, drop the entire ocaml-ocb patch.
>
> Cheers,
> pukkamustard
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 66119@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 66119
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch