[PATCH] gnu: routino: Update to 3.4.1.

  • Done
  • quality assurance status badge
Details
2 participants
  • Guillaume Le Vaillant
  • Hendursaga
Owner
unassigned
Submitted by
Hendursaga
Severity
normal

Debbugs page

Hendursaga wrote 1 years ago
(address . guix-patches@gnu.org)
3f7bd68d17e7612af964425d414fcd608800b9e3.1695138908.git.hendursaga@aol.com
* gnu/packages/geo.scm (routino): Update to 3.4.1.
[source]: Use HTTPS.
[arguments]: Use G-expressions.
---
gnu/packages/geo.scm | 67 +++++++++++++++++++++-----------------------
1 file changed, 32 insertions(+), 35 deletions(-)

Toggle diff (84 lines)
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index d702046865..2d0649d174 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -2161,43 +2161,40 @@ (define-public python-geoip2
(define-public routino
(package
- (name "routino")
- (version "3.3.3")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "http://www.routino.org/download/routino-"
- version ".tgz"))
- (sha256
- (base32 "1xa7l2bjn832nk6bc7b481nv8hd2gj41jwhg0d2qy10lqdvjpn5b"))))
- (build-system gnu-build-system)
- (native-inputs
- (list perl))
- (inputs
- (list bzip2 xz zlib))
- (arguments
- `(#:test-target "test"
- #:phases
- (modify-phases %standard-phases
- (replace 'configure
- (lambda* (#:key outputs #:allow-other-keys)
- (substitute* "Makefile.conf"
- (("prefix=/usr/local")
- (string-append "prefix=" (assoc-ref outputs "out")))
- (("LDFLAGS_LDSO=-Wl,-R\\.")
- "LDFLAGS_LDSO=-Wl,-R$(libdir)")
- (("#CFLAGS\\+=-DUSE_XZ")
- "CFLAGS+=-DUSE_XZ")
- (("#LDFLAGS\\+=-llzma")
- "LDFLAGS+=-llzma"))
- #t)))))
- (synopsis "Routing application for OpenStreetMap data")
- (description
- "Routino is an application for finding a route between two points
+ (name "routino")
+ (version "3.4.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://www.routino.org/download/routino-"
+ version ".tgz"))
+ (sha256
+ (base32
+ "0aw5idqz7nv458llgwp5wcgikf34xcblpq46mq7msxfib0m8vahb"))))
+ (build-system gnu-build-system)
+ (native-inputs (list perl))
+ (inputs (list bzip2 xz zlib))
+ (arguments
+ (list #:test-target "test"
+ #:phases #~(modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "Makefile.conf"
+ (("prefix=/usr/local")
+ (string-append "prefix="
+ (assoc-ref outputs "out")))
+ (("LDFLAGS_LDSO=-Wl,-R\\.")
+ "LDFLAGS_LDSO=-Wl,-R$(libdir)")
+ (("#CFLAGS\\+=-DUSE_XZ")
+ "CFLAGS+=-DUSE_XZ")
+ (("#LDFLAGS\\+=-llzma")
+ "LDFLAGS+=-llzma")) #t)))))
+ (synopsis "Routing application for OpenStreetMap data")
+ (description
+ "Routino is an application for finding a route between two points
using the dataset of topographical information collected by
@url{https://www.OpenStreetMap.org}.")
- (home-page "https://www.routino.org/")
- (license license:agpl3+)))
+ (home-page "https://www.routino.org/")
+ (license license:agpl3+)))
(define-public r-rnaturalearthhires
(let ((commit "c3785a8c44738de6ae8f797080c0a337ebed929d")

base-commit: 15c5f1a2c20b21de0f19f42db1ccab4c42117ebb
--
2.41.0
Guillaume Le Vaillant wrote 1 years ago
(name . Hendursaga)(address . hendursaga@aol.com)(address . 66107-done@debbugs.gnu.org)
8734z7wn3f.fsf@kitej
Patch applied as 70fd6721f4921a5ccd0dcf6964458e74636c2c65.
Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCZQxkFA8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j9WwgEAiPO81NoVjrOLe46TsIhb//3QLmutcuLFkKR7
Rw+ciE8A/0XqRDUxSY+vwwa0jdZMx3f7lUsuRSaQeoW+nEXpnL0R
=1l8e
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 66107@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 66107
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help