[PATCH 0/1] gnu: stcgal: Update to 1.10.

  • Done
  • quality assurance status badge
Details
2 participants
  • Christopher Baines
  • Simon South
Owner
unassigned
Submitted by
Simon South
Severity
normal

Debbugs page

Simon South wrote 1 years ago
(address . guix-patches@gnu.org)
cover.1695133090.git.simon@simonsouth.net
This patch updates stcgal, a command-line programming utility for
microcontrollers from STC MCU, to version 1.10.

I've tested this on AArch64 and x86-64 with a real STC89C52RC board and
everything seems fine.

--
Simon South
simon@simonsouth.net


Simon South (1):
gnu: stcgal: Update to 1.10.

gnu/packages/embedded.scm | 20 ++++++--------------
1 file changed, 6 insertions(+), 14 deletions(-)


base-commit: 15c5f1a2c20b21de0f19f42db1ccab4c42117ebb
--
2.41.0
Simon South wrote 1 years ago
[PATCH 1/1] gnu: stcgal: Update to 1.10.
(address . 66101@debbugs.gnu.org)
855fd7094b36aa2d0bd007ae8d2eaa626c6962a1.1695133090.git.simon@simonsouth.net
* gnu/packages/embedded.scm (stcgal): Update to 1.10.
[source]: Update comment; remove obsolete snippet.
[description]: Update.
---
gnu/packages/embedded.scm | 20 ++++++--------------
1 file changed, 6 insertions(+), 14 deletions(-)

Toggle diff (48 lines)
diff --git a/gnu/packages/embedded.scm b/gnu/packages/embedded.scm
index 325013a627..884aee690a 100644
--- a/gnu/packages/embedded.scm
+++ b/gnu/packages/embedded.scm
@@ -1357,12 +1357,11 @@ (define-public fc-host-tools
(define-public stcgal
(package
(name "stcgal")
- (version "1.6")
+ (version "1.10")
(source (origin
- ;; Neither the unit tests nor the "doc" subdirectory referred to
- ;; by stcgal's setup.py is present in the source distribution on
- ;; PyPI, so we fetch directly from the project's git repository
- ;; instead.
+ ;; The "doc" subdirectory referred to by stcgal's setup.py is
+ ;; missing from the source distribution on PyPI so we fetch
+ ;; directly from the project's git repository instead.
(method git-fetch)
(uri (git-reference
(url "https://github.com/grigorig/stcgal")
@@ -1370,14 +1369,7 @@ (define-public stcgal
(file-name (git-file-name name version))
(sha256
(base32
- "1d10qxyghz66zp7iqpm8q8rfv9jz9n609gxmfcav1lssmf1dlyk3"))
- (modules '((guix build utils)))
- (snippet
- ;; Make tests compatible with PyYAML 6 and later.
- '(substitute* '("tests/test_program.py"
- "tests/test_fuzzing.py")
- (("yaml\\.load\\(test_file\\.read\\(\\)\\)")
- "yaml.load(test_file.read(), Loader=yaml.SafeLoader)")))))
+ "04hsj49sw5mb6swhd3sdsm7dzwp1frnzpmq70wgsn5vmjavb1ka8"))))
(build-system python-build-system)
(propagated-inputs
(list python-pyserial python-pyusb python-tqdm))
@@ -1388,7 +1380,7 @@ (define-public stcgal
(synopsis "Programmer for STC 8051-compatible microcontrollers")
(description "stcgal is a command-line flash-programming tool for STC
MCU's line of Intel 8051-compatible microcontrollers, including those in the
-STC89, STC90, STC10, STC11, STC12, STC15 and STC8 series.")
+STC89, STC90, STC10, STC11, STC12, STC15, STC8 and STC32 series.")
(license license:expat)))
(define-public stlink
--
2.41.0
Christopher Baines wrote 1 years ago
Re: [bug#66101] [PATCH 0/1] gnu: stcgal: Update to 1.10.
(name . Simon South)(address . simon@simonsouth.net)
87o7hndgu9.fsf@cbaines.net
Simon South <simon@simonsouth.net> writes:

Toggle quote (17 lines)
> This patch updates stcgal, a command-line programming utility for
> microcontrollers from STC MCU, to version 1.10.
>
> I've tested this on AArch64 and x86-64 with a real STC89C52RC board and
> everything seems fine.
>
> --
> Simon South
> simon@simonsouth.net
>
>
> Simon South (1):
> gnu: stcgal: Update to 1.10.
>
> gnu/packages/embedded.scm | 20 ++++++--------------
> 1 file changed, 6 insertions(+), 14 deletions(-)

Looks like I pushed this as 8ffbcfbe3fb6e83162d239e8bd560f839118baee but
forgot to reply.

Thanks,

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmUUCn5fFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9Xen7w//V1pEdrnlu6WvqEiSI8pLtmFbdr80163A
ST+NZUfssPV7j65ICtZEzwwPtuSzEMVI/e+BiTAps7D302a+aRMYlNEMIq2203NS
J7aMaaS6JsbdHuEncC6I486MNFkmgnaOIKfNqIEwy63E9fyoHRQNhBp1TDPb8I0p
GKIEpkOjrVsDZD15+myNp4gr372c1bfNwqikA8SBRA46D2LW0Ab4f8uQAhgj6wq1
fv/xmkdaFsum+9/tRjQXdYXDWd/1ghBd+vcECkU9al9TVRzdH0tMbU0KcITSxzEA
pTHetwir+idNHpY87QOI7SUro4VAdDK2CKhV1z7m+B7p/CDFwsgYWykFxVmqh96Z
Pr+kpFJ2PxDUaBLzGsDtsUEBtF0UFAQJCmum79086WRSnYdz+xTZ0vBCrItsFjDv
VA4xRvnzsfiQ4BRytkxTZceV9rv95cBYXjAyYf1hdp+6xZx/bP6JwHc73+hFQUri
N6AZu52/nIAntUUmUwUN5M4GiRefCtMdaEXUFQ0fTvoIsAT+lwF/uwlZg7NpFvYg
mbV9RAv0fl4vFMQPQjfssbbh0hbQ30bRILdvQsOReKpX2w3XuUhGvVGY+ma8zzeL
cYXOW3l5Ooiv+KS2wLPnXEFS6eA1m6JrulG3FQrOZHxqRfh18iHfg+LqNNUobX/5
IUqcIFa5s4w=
=NX0W
-----END PGP SIGNATURE-----

?
Your comment

This issue is archived.

To comment on this conversation send an email to 66101@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 66101
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help