Mădălin Ionel Patrașcu wrote 1 years ago
(address . guix-patches@gnu.org)
* gnu/packages/bioinformatics.scm (python-plastid)[arguments]: Add
new phase patch-for-python-3.10.
---
gnu/packages/bioinformatics.scm | 7 +++++++
1 file changed, 7 insertions(+)
Toggle diff (22 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index c78f017a24..d7a9697c6e 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -3787,6 +3787,13 @@ (define-public python-plastid
"-xf" (assoc-ref inputs "test-data"))
;; This one requires bowtie-build
(delete-file "plastid/test/functional/test_crossmap.py")))
+ (add-after 'unpack 'patch-for-python-3.10
+ (lambda _
+ ;; Some classes were moved from collections to collections.abc
+ ;; in Python 3.10.
+ (substitute* "plastid/readers/bigbed.pyx"
+ ((", Iterable")
+ "\nfrom collections.abc import Iterable"))))
(add-before 'check 'build-extensions
(lambda _
;; Cython extensions have to be built before running the tests.
base-commit: 1d30ec935126f316187dfc26446347bc7de9868b
--
2.41.0