[PATCH 0/5] gnu: sigrok-firmware-fx2lafw: Update; improve package.

  • Done
  • quality assurance status badge
Details
2 participants
  • Christopher Baines
  • Simon South
Owner
unassigned
Submitted by
Simon South
Severity
normal

Debbugs page

Simon South wrote 1 years ago
(address . guix-patches@gnu.org)
cover.1694986463.git.simon@simonsouth.net
This patch series updates sigrok-firmware-fx2lafw, firmware for inexpensive
logic analyzers built around the Cypress Semiconductor FX2 microcontroller, to
the latest revision in its source-code repository.

This brings in eight commits[0] that improve the software in small ways, most
importantly allowing it to build with the latest version of SDCC, 4.3.0
(patches to follow). Note the project's last formal release was in 2019.

This series also simplifies and updates the style of the package definition.

I've tested these changes on AArch64 and x86-64 using PulseView and a real
FX2-based device (a MuseTech nanoDLA) and everything seems fine.

--
Simon South
simon@simonsouth.net

[0] See


Simon South (5):
gnu: sigrok-firmware-fx2lafw: Rely on implicit inputs.
gnu: sigrok-firmware-fx2lafw: Remove input labels.
gnu: sigrok-firmware-fx2lafw: Adjust format.
gnu: sigrok-firmware-fx2lafw: Explicitly disable tests.
gnu: sigrok-firmware-fx2lafw: Update to 0.1.7-1.96b0b47.

gnu/packages/electronics.scm | 55 ++++++++++++++++--------------------
1 file changed, 24 insertions(+), 31 deletions(-)


base-commit: fc3a53525ab3dcaf7c22eec8d62294017f9760fe
--
2.41.0
Simon South wrote 1 years ago
[PATCH 1/5] gnu: sigrok-firmware-fx2lafw: Rely on implicit inputs.
(address . 66060@debbugs.gnu.org)
7c9e73a256dc380f5e7fbdbb80c89132c33203af.1694986463.git.simon@simonsouth.net
This effectively reverts commit 79f0bd7, "gnu: sigrok-firmware-fx2lafw: Fix
build."

* gnu/packages/electronics.scm (sigrok-firmware-fx2lafw)[arguments]: Remove
with #:implicit-inputs?.
[native-inputs]: Remove all but sdcc.
---
gnu/packages/electronics.scm | 14 +-------------
1 file changed, 1 insertion(+), 13 deletions(-)

Toggle diff (42 lines)
diff --git a/gnu/packages/electronics.scm b/gnu/packages/electronics.scm
index 6e6071e6e6..182e183312 100644
--- a/gnu/packages/electronics.scm
+++ b/gnu/packages/electronics.scm
@@ -34,7 +34,6 @@ (define-module (gnu packages electronics)
#:use-module (gnu packages algebra)
#:use-module (gnu packages autotools)
#:use-module (gnu packages base)
- #:use-module (gnu packages bash)
#:use-module (gnu packages boost)
#:use-module (gnu packages c)
#:use-module (gnu packages check)
@@ -42,7 +41,6 @@ (define-module (gnu packages electronics)
#:use-module (gnu packages documentation)
#:use-module (gnu packages embedded)
#:use-module (gnu packages fontutils)
- #:use-module (gnu packages gawk)
#:use-module (gnu packages gl)
#:use-module (gnu packages glib)
#:use-module (gnu packages graphviz)
@@ -134,18 +132,8 @@ (define-public sigrok-firmware-fx2lafw
(sha256
(base32
"0fyfd82mvrcf55v5a3afq1mh1kfswk4c37qrbln6x92jm3b41x53"))))
- (arguments
- `(#:implicit-inputs? #f))
(native-inputs
- `(("awk" ,gawk)
- ("bash" ,bash)
- ("coreutils" ,coreutils)
- ("grep" ,grep)
- ("gzip" ,gzip)
- ("make" ,gnu-make)
- ("sdcc" ,sdcc)
- ("sed" ,sed)
- ("tar" ,tar)))
+ `(("sdcc" ,sdcc)))
(build-system gnu-build-system)
(home-page "https://www.sigrok.org/wiki/Fx2lafw")
(synopsis "Firmware for Cypress FX2 chips")
--
2.41.0
Simon South wrote 1 years ago
[PATCH 2/5] gnu: sigrok-firmware-fx2lafw: Remove input labels.
(address . 66060@debbugs.gnu.org)
61c8391915c46b282efa0f26ac1fe94bfbe3b128.1694986463.git.simon@simonsouth.net
* gnu/packages/electronics.scm (sigrok-firmware-fx2lafw)[native-inputs]:
Remove input labels.
---
gnu/packages/electronics.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/electronics.scm b/gnu/packages/electronics.scm
index 182e183312..48d1099c78 100644
--- a/gnu/packages/electronics.scm
+++ b/gnu/packages/electronics.scm
@@ -133,7 +133,7 @@ (define-public sigrok-firmware-fx2lafw
(base32
"0fyfd82mvrcf55v5a3afq1mh1kfswk4c37qrbln6x92jm3b41x53"))))
(native-inputs
- `(("sdcc" ,sdcc)))
+ (list sdcc))
(build-system gnu-build-system)
(home-page "https://www.sigrok.org/wiki/Fx2lafw")
(synopsis "Firmware for Cypress FX2 chips")
--
2.41.0
Simon South wrote 1 years ago
[PATCH 3/5] gnu: sigrok-firmware-fx2lafw: Adjust format.
(address . 66060@debbugs.gnu.org)
607f22d71ef61b53dfb7ef36dc4c178815c64fd8.1694986463.git.simon@simonsouth.net
* gnu/packages/electronics.scm (sigrok-firmware-fx2lafw): Move build-system
above native-inputs.
---
gnu/packages/electronics.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (17 lines)
diff --git a/gnu/packages/electronics.scm b/gnu/packages/electronics.scm
index 48d1099c78..63ca4ae0f1 100644
--- a/gnu/packages/electronics.scm
+++ b/gnu/packages/electronics.scm
@@ -132,9 +132,9 @@ (define-public sigrok-firmware-fx2lafw
(sha256
(base32
"0fyfd82mvrcf55v5a3afq1mh1kfswk4c37qrbln6x92jm3b41x53"))))
+ (build-system gnu-build-system)
(native-inputs
(list sdcc))
- (build-system gnu-build-system)
(home-page "https://www.sigrok.org/wiki/Fx2lafw")
(synopsis "Firmware for Cypress FX2 chips")
(description "Fx2lafw is free firmware for Cypress FX2 chips which makes them usable
--
2.41.0
Simon South wrote 1 years ago
[PATCH 4/5] gnu: sigrok-firmware-fx2lafw: Explicitly disable tests.
(address . 66060@debbugs.gnu.org)
eb81093f34801eb95b4465a6fcfdc0429cf0eb1d.1694986463.git.simon@simonsouth.net
* gnu/packages/electronics.scm (sigrok-firmware-fx2lafw)[arguments]: Add
with #:tests?.
---
gnu/packages/electronics.scm | 2 ++
1 file changed, 2 insertions(+)

Toggle diff (15 lines)
diff --git a/gnu/packages/electronics.scm b/gnu/packages/electronics.scm
index 63ca4ae0f1..2330a5922f 100644
--- a/gnu/packages/electronics.scm
+++ b/gnu/packages/electronics.scm
@@ -133,6 +133,8 @@ (define-public sigrok-firmware-fx2lafw
(base32
"0fyfd82mvrcf55v5a3afq1mh1kfswk4c37qrbln6x92jm3b41x53"))))
(build-system gnu-build-system)
+ (arguments
+ (list #:tests? #f)) ; no test suite
(native-inputs
(list sdcc))
(home-page "https://www.sigrok.org/wiki/Fx2lafw")
--
2.41.0
Simon South wrote 1 years ago
[PATCH 5/5] gnu: sigrok-firmware-fx2lafw: Update to 0.1.7-1.96b0b47.
(address . 66060@debbugs.gnu.org)
ee6fe2c7d42910b2c42e6192a6e7355914a274a1.1694986463.git.simon@simonsouth.net
* gnu/packages/electronics.scm (sigrok-firmware-fx2lafw): Update to
0.1.7-1.96b0b47.
[source]: Switch to git-fetch.
[native-inputs]: Add autoconf, automake.
---
gnu/packages/electronics.scm | 45 +++++++++++++++++++-----------------
1 file changed, 24 insertions(+), 21 deletions(-)

Toggle diff (58 lines)
diff --git a/gnu/packages/electronics.scm b/gnu/packages/electronics.scm
index 2330a5922f..77a9fc2d90 100644
--- a/gnu/packages/electronics.scm
+++ b/gnu/packages/electronics.scm
@@ -121,27 +121,30 @@ (define-public libsigrokdecode
(license license:gpl3+))))
(define-public sigrok-firmware-fx2lafw
- (package
- (name "sigrok-firmware-fx2lafw")
- (version "0.1.7")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "http://sigrok.org/download/source/sigrok-firmware-fx2lafw/"
- "sigrok-firmware-fx2lafw-" version ".tar.gz"))
- (sha256
- (base32
- "0fyfd82mvrcf55v5a3afq1mh1kfswk4c37qrbln6x92jm3b41x53"))))
- (build-system gnu-build-system)
- (arguments
- (list #:tests? #f)) ; no test suite
- (native-inputs
- (list sdcc))
- (home-page "https://www.sigrok.org/wiki/Fx2lafw")
- (synopsis "Firmware for Cypress FX2 chips")
- (description "Fx2lafw is free firmware for Cypress FX2 chips which makes them usable
-as simple logic analyzer and/or oscilloscope hardware.")
- (license license:gpl2+)))
+ (let ((commit "96b0b476522c3f93a47ff8f479ec08105ba6a2a5")
+ (revision "1"))
+ (package
+ (name "sigrok-firmware-fx2lafw")
+ (version (git-version "0.1.7" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "git://sigrok.org/sigrok-firmware-fx2lafw")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1n5nj2g2m5ih59591ny2drrv25zviqcwyx1cfdhy8ijl82yxjkmb"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list #:tests? #f)) ; no test suite
+ (native-inputs
+ (list autoconf automake sdcc))
+ (home-page "https://www.sigrok.org/wiki/Fx2lafw")
+ (synopsis "Firmware for Cypress FX2 chips")
+ (description "Fx2lafw is free firmware for Cypress FX2 chips which makes
+them usable as simple logic analyzer and/or oscilloscope hardware.")
+ (license license:gpl2+))))
(define-public libsigrok
(let ((commit "a7e919a3a6b7fd511acbe1a280536b76c70c28d2")
--
2.41.0
Christopher Baines wrote 1 years ago
Re: [bug#66060] [PATCH 0/5] gnu: sigrok-firmware-fx2lafw: Update; improve package.
(name . Simon South)(address . simon@simonsouth.net)
87y1gu4is0.fsf@cbaines.net
Simon South <simon@simonsouth.net> writes:

Toggle quote (28 lines)
> This patch series updates sigrok-firmware-fx2lafw, firmware for inexpensive
> logic analyzers built around the Cypress Semiconductor FX2 microcontroller, to
> the latest revision in its source-code repository.
>
> This brings in eight commits[0] that improve the software in small ways, most
> importantly allowing it to build with the latest version of SDCC, 4.3.0
> (patches to follow). Note the project's last formal release was in 2019.
>
> This series also simplifies and updates the style of the package definition.
>
> I've tested these changes on AArch64 and x86-64 using PulseView and a real
> FX2-based device (a MuseTech nanoDLA) and everything seems fine.
>
> --
> Simon South
> simon@simonsouth.net
>
> [0] See
> http://sigrok.org/gitweb/?p=sigrok-firmware-fx2lafw.git;a=shortlog;h=96b0b47
>
>
> Simon South (5):
> gnu: sigrok-firmware-fx2lafw: Rely on implicit inputs.
> gnu: sigrok-firmware-fx2lafw: Remove input labels.
> gnu: sigrok-firmware-fx2lafw: Adjust format.
> gnu: sigrok-firmware-fx2lafw: Explicitly disable tests.
> gnu: sigrok-firmware-fx2lafw: Update to 0.1.7-1.96b0b47.

Thanks for the patches Simon, I've added a comment and a bit to the
commit message in the last commit to give the reason for using a VCS
snapshot and pushed these patches to master as
9239c822469259509dbbc7a6966b5b265dd7c4f1.

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmURaO9fFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9Xd2ag/+IMnB0ForHc5eO/X5Khxn8MwcJ60SXZt9
htdcIyMk5LYNNXt70/adUpEeud8SdDMsLXRr32mYDLqlNc7sCAOHpOCEVMKDJqXw
m05s6rozEeAqI1bL6Nko2xDCh5BAjW+B+Aj1kgiZptHpBEvqFNwNhsT/ZzYP73V7
V2Sbo1qCZJbVPCqPbh2awAT69Nh8UyBOvrzeIdM+4fS7jIMVEuOBetzsB3dVMBFZ
5ZDJ/DXw7EK2mcjZItFv2sSO3pPrlc6e6xrd/TeWcBAq46BMN6eCnjs8qGK88K2y
T+Be4czOUzwoRfuDmAo12k93EB1+ShhQYtQJns7mOIrLjkUw2mXdhxdfEFD0xZ7T
r02E/e051guXtOgV04ZCXOHcD675J91vGd9qAXa7OhViASYBq/+Z4sLsdydVgfEH
oDRRD+Qo44j9A4Jud4nkB5u1YSSmRnAGboxwj1OQEdzK1ZKzBz4mstGkBnLskqeu
t0bQ6mAXWkJ27MAIgZt2K1MGZKVL4Vddu3dj9nSFNdMl7kH1JYVYLGsvpx/cYsAd
JU/tn3yleIQ3AhEPSGDuwhccst4kBsYsp6ng8AAXcSRUcvFCIDKYJb9LvKFKpaDZ
oOVe+RC8RLC0N5/KGy+3J6HdzBlflhqzxE9+E1hW69CInXbL4Z1rsueRDoi1uqK/
Yx1u847n130=
=ucLJ
-----END PGP SIGNATURE-----

?
Your comment

This issue is archived.

To comment on this conversation send an email to 66060@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 66060
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help