[PATCH] gnu: Add tree-sitter-lua.

  • Done
  • quality assurance status badge
Details
2 participants
  • john muhl
  • Ludovic Courtès
Owner
unassigned
Submitted by
john muhl
Severity
normal

Debbugs page

john muhl wrote 1 years ago
(address . guix-patches@gnu.org)(name . john muhl)(address . jm@pub.pink)
20230916195341.3370126-1-jm@pub.pink
gnu/packages/tree-sitter.scm (tree-sitter-lua): New variable.
---
gnu/packages/tree-sitter.scm | 7 +++++++
1 file changed, 7 insertions(+)

Toggle diff (17 lines)
diff --git a/gnu/packages/tree-sitter.scm b/gnu/packages/tree-sitter.scm
index 58db2603af..e7a6eaab7d 100644
--- a/gnu/packages/tree-sitter.scm
+++ b/gnu/packages/tree-sitter.scm
@@ -607,3 +607,10 @@ (define-public tree-sitter-plantuml
(use-modules (guix build utils))
(delete-file "binding.gyp")
(delete-file-recursively "bindings"))))))
+
+(define-public tree-sitter-lua
+ (tree-sitter-grammar
+ "lua" "Lua"
+ "05irhg6gg11r9cnzh0h3691pnxjhd396sa1x8xrgqjz2fd09brf3"
+ "0.0.19"
+ #:repository-url "https://github.com/MunifTanjim/tree-sitter-lua"))
--
2.41.0
Ludovic Courtès wrote 1 years ago
(name . john muhl)(address . jm@pub.pink)(address . 66036-done@debbugs.gnu.org)
87h6n0x081.fsf@gnu.org
john muhl <jm@pub.pink> skribis:

Toggle quote (2 lines)
> gnu/packages/tree-sitter.scm (tree-sitter-lua): New variable.

Applied, thanks!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 66036@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 66036
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help