[PATCH 0/2] Fix: Julia is very slow

  • Done
  • quality assurance status badge
Details
One participant
  • Simon Tournier
Owner
unassigned
Submitted by
Simon Tournier
Severity
normal
S
S
Simon Tournier wrote on 16 Sep 2023 12:52
(address . guix-patches@gnu.org)(name . Simon Tournier)(address . zimon.toutoune@gmail.com)
cover.1694859477.git.zimon.toutoune@gmail.com
Hi,

This series is for triggering the rebuild of the Julia world. Some Julia
packages are long to build so let minimize the annoyance and make some
substitutes available before pushing to master. :-)

bug Julia is very slow
Cayetano Santos via Bug reports for GNU Guix <bug-guix@gnu.org>
Fri, 09 Jun 2023 23:42:00 +0200
id:87legsl3cm.fsf@inventati.org


Cheers,
simon

Efraim Flashner (2):
gnu: openblas-ilp64: Add symbol suffix.
gnu: julia: Conditionally use openblas with ILP64 support.

gnu/packages/julia.scm | 22 ++++++++++++++--------
gnu/packages/maths.scm | 4 +++-
2 files changed, 17 insertions(+), 9 deletions(-)


base-commit: eeec8371890fc95c60112da299dde78b21c948c2
--
2.38.1
S
S
Simon Tournier wrote on 16 Sep 2023 12:55
[PATCH 1/2] gnu: openblas-ilp64: Add symbol suffix.
(address . 66030@debbugs.gnu.org)(name . Efraim Flashner)(address . efraim@flashner.co.il)
2f044415efb5dc5703bf2b09439c6f5e2fd1fd72.1694859477.git.zimon.toutoune@gmail.com
From: Efraim Flashner <efraim@flashner.co.il>

* gnu/packages/maths.scm (openblas-ilp64)[arguments]<#:make-flags>: Add the
symbol '64_' as suffix.
---
gnu/packages/maths.scm | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)

Toggle diff (17 lines)
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 6141c0988612..c051e60d5e40 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -4638,7 +4638,9 @@ (define-public openblas-ilp64
(arguments
(substitute-keyword-arguments (package-arguments openblas)
((#:make-flags flags #~'())
- #~(append (list "INTERFACE64=1" "LIBNAMESUFFIX=ilp64")
+ #~(append (list "INTERFACE64=1"
+ "SYMBOLSUFFIX=64_"
+ "LIBPREFIX=libopenblas64_")
#$flags))))
(synopsis "Optimized BLAS library based on GotoBLAS (ILP64 version)")
(license license:bsd-3)))
--
2.38.1
S
S
Simon Tournier wrote on 16 Sep 2023 12:55
[PATCH 2/2] gnu: julia: Conditionally use openblas with ILP64 support.
(address . 66030@debbugs.gnu.org)
7f2347d8e64562e1de563cf1e4cdfd192e81a9df.1694859477.git.zimon.toutoune@gmail.com
From: Efraim Flashner <efraim@flashner.co.il>

Reported by Cayetano Santos <csantosb@inventati.org>.

* gnu/packages/julia.scm (julia)[arguments]<#:phases>: Conditionally use
OpenBLAS with ILP64 support for x86-64 target.
<#:make-flags>: Likewise.
[inputs]: Conditionally replace openblas by openblas-ilp64 for x86-64 target.

Co-authored-by: Simon Tournier <zimon.toutoune@gmail.com>
---
gnu/packages/julia.scm | 22 ++++++++++++++--------
1 file changed, 14 insertions(+), 8 deletions(-)

Toggle diff (49 lines)
diff --git a/gnu/packages/julia.scm b/gnu/packages/julia.scm
index ba541758223e..8ba2b480ce55 100644
--- a/gnu/packages/julia.scm
+++ b/gnu/packages/julia.scm
@@ -269,7 +269,10 @@ (define-public julia
(substitute* (jlpath "nghttp2")
(((from "libnghttp2")) (to "libnghttp2" "libnghttp2")))
(substitute* (jlpath "OpenBLAS")
- (((from "libopenblas")) (to "openblas" "libopenblas")))
+ (((from "libopenblas"))
+ ,@(if (target-x86-64?)
+ `((to "openblas" "libopenblas64_" "libopenblas"))
+ `((to "openblas" "libopenblas")))))
(substitute* (jlpath "OpenLibm")
(((from "libopenlibm")) (to "openlibm" "libopenlibm")))
(substitute* (jlpath "PCRE2")
@@ -479,12 +482,13 @@ (define-public julia
"NO_GIT=1" ; build from release tarball.
"USE_GPL_LIBS=1" ; proudly
- ,@(if (target-aarch64?)
- `("USE_BLAS64=0")
- '())
-
- "LIBBLAS=-lopenblas"
- "LIBBLASNAME=libopenblas"
+ ,@(if (target-x86-64?)
+ `("USE_BLAS64=1"
+ "LIBBLAS=-lopenblas64_"
+ "LIBBLASNAME=libopenblas64_")
+ `("USE_BLAS64=0"
+ "LIBBLAS=-lopenblas"
+ "LIBBLASNAME=libopenblas"))
(string-append "UTF8PROC_INC="
(assoc-ref %build-inputs "utf8proc")
@@ -513,7 +517,9 @@ (define-public julia
("llvm" ,llvm-julia)
("mbedtls-apache" ,mbedtls-apache)
("mpfr" ,mpfr)
- ("openblas" ,openblas)
+ ,@(if (target-x86-64?)
+ `(("openblas" ,openblas-ilp64))
+ `(("openblas" ,openblas)))
("openlibm" ,openlibm)
("p7zip" ,p7zip)
("pcre2" ,pcre2)
--
2.38.1
S
S
Simon Tournier wrote on 17 Sep 2023 13:52
[PATCH v2 1/3] gnu: openblas-ilp64: Add symbol suffix.
(address . 66030@debbugs.gnu.org)(name . Efraim Flashner)(address . efraim@flashner.co.il)
f6d04046adc7b153dbe18bbed86919efde1dc741.1694951428.git.zimon.toutoune@gmail.com
From: Efraim Flashner <efraim@flashner.co.il>

* gnu/packages/maths.scm (openblas-ilp64)[arguments]<#:make-flags>: Add the
symbol '64_' as suffix.
---
gnu/packages/maths.scm | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)

Toggle diff (19 lines)
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 6141c0988612..c051e60d5e40 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -4638,7 +4638,9 @@ (define-public openblas-ilp64
(arguments
(substitute-keyword-arguments (package-arguments openblas)
((#:make-flags flags #~'())
- #~(append (list "INTERFACE64=1" "LIBNAMESUFFIX=ilp64")
+ #~(append (list "INTERFACE64=1"
+ "SYMBOLSUFFIX=64_"
+ "LIBPREFIX=libopenblas64_")
#$flags))))
(synopsis "Optimized BLAS library based on GotoBLAS (ILP64 version)")
(license license:bsd-3)))

base-commit: 9b78699744b0c4c8af28820cc4f0d59b9d317ead
--
2.38.1
S
S
Simon Tournier wrote on 17 Sep 2023 13:52
[PATCH v2 3/3] gnu: julia-arraylayouts: Fix tests.
(address . 66030@debbugs.gnu.org)(name . Simon Tournier)(address . zimon.toutoune@gmail.com)
6026b755ec35e2b30180f7d0a3a2ca92b52a7e0c.1694951428.git.zimon.toutoune@gmail.com
* gnu/packages/julia-xyz.scm (julia-arraylayouts)[arguments]: Remove.
---
gnu/packages/julia-xyz.scm | 8 --------
1 file changed, 8 deletions(-)

Toggle diff (21 lines)
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index a1e65332fa10..a3c158763cb5 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -242,14 +242,6 @@ (define-public julia-arraylayouts
(sha256
(base32 "1j11jid4scw9icrbr8g6myp17nabjzmf4f40cichb20lzf1agz8l"))))
(build-system julia-build-system)
- (arguments
- (list
- #:phases
- #~(modify-phases %standard-phases
- (add-after 'unpack 'adjust-tests
- (lambda _
- (substitute* "test/test_layoutarray.jl"
- (("@test all\\(B") "@test_broken all(B")))))))
(propagated-inputs
(list julia-fillarrays))
(native-inputs
--
2.38.1
S
S
Simon Tournier wrote on 17 Sep 2023 13:52
[PATCH v2 2/3] gnu: julia: Conditionally use openblas with ILP64 support.
(address . 66030@debbugs.gnu.org)
47e7e9f130ea7c7a8065e9b7a9b499d23c553929.1694951428.git.zimon.toutoune@gmail.com
From: Efraim Flashner <efraim@flashner.co.il>

Reported by Cayetano Santos <csantosb@inventati.org>.

* gnu/packages/julia.scm (julia)[arguments]<#:phases>: Conditionally use
OpenBLAS with ILP64 support for x86-64 target.
<#:make-flags>: Likewise.
[inputs]: Conditionally replace openblas by openblas-ilp64 for x86-64 target.

Co-authored-by: Simon Tournier <zimon.toutoune@gmail.com>
---
gnu/packages/julia.scm | 22 ++++++++++++++--------
1 file changed, 14 insertions(+), 8 deletions(-)

Toggle diff (49 lines)
diff --git a/gnu/packages/julia.scm b/gnu/packages/julia.scm
index ba541758223e..8ba2b480ce55 100644
--- a/gnu/packages/julia.scm
+++ b/gnu/packages/julia.scm
@@ -269,7 +269,10 @@ (define-public julia
(substitute* (jlpath "nghttp2")
(((from "libnghttp2")) (to "libnghttp2" "libnghttp2")))
(substitute* (jlpath "OpenBLAS")
- (((from "libopenblas")) (to "openblas" "libopenblas")))
+ (((from "libopenblas"))
+ ,@(if (target-x86-64?)
+ `((to "openblas" "libopenblas64_" "libopenblas"))
+ `((to "openblas" "libopenblas")))))
(substitute* (jlpath "OpenLibm")
(((from "libopenlibm")) (to "openlibm" "libopenlibm")))
(substitute* (jlpath "PCRE2")
@@ -479,12 +482,13 @@ (define-public julia
"NO_GIT=1" ; build from release tarball.
"USE_GPL_LIBS=1" ; proudly
- ,@(if (target-aarch64?)
- `("USE_BLAS64=0")
- '())
-
- "LIBBLAS=-lopenblas"
- "LIBBLASNAME=libopenblas"
+ ,@(if (target-x86-64?)
+ `("USE_BLAS64=1"
+ "LIBBLAS=-lopenblas64_"
+ "LIBBLASNAME=libopenblas64_")
+ `("USE_BLAS64=0"
+ "LIBBLAS=-lopenblas"
+ "LIBBLASNAME=libopenblas"))
(string-append "UTF8PROC_INC="
(assoc-ref %build-inputs "utf8proc")
@@ -513,7 +517,9 @@ (define-public julia
("llvm" ,llvm-julia)
("mbedtls-apache" ,mbedtls-apache)
("mpfr" ,mpfr)
- ("openblas" ,openblas)
+ ,@(if (target-x86-64?)
+ `(("openblas" ,openblas-ilp64))
+ `(("openblas" ,openblas)))
("openlibm" ,openlibm)
("p7zip" ,p7zip)
("pcre2" ,pcre2)
--
2.38.1
S
S
Simon Tournier wrote on 17 Sep 2023 13:49
Re: bug#66030: [PATCH 0/2] Fix: Julia is very slow
(address . 66030@debbugs.gnu.org)
87led581f4.fsf@gmail.com
Hi,

On Sat, 16 Sep 2023 at 12:52, Simon Tournier <zimon.toutoune@gmail.com> wrote:

Toggle quote (4 lines)
> This series is for triggering the rebuild of the Julia world. Some Julia
> packages are long to build so let minimize the annoyance and make some
> substitutes available before pushing to master. :-)

Now, QA is done.


The change introduces a regression for the package julia-arraylayouts;
it is then fixed, see v2.

The regression about the package julia-genericlinearalgebra reads:

Toggle snippet (36 lines)
Singular value decomposition | 57 57 1.7s
Hermitian: Error During Test at /gnu/store/zkx6p7kz3m5k5w5iy0l1d09b2n8b0ib3-julia-genericlinearalgebra-0.2.5/share/julia/loadpath/GenericLinearAlgebra/test/rectfullpacked.jl:12
Got exception outside of a @test
could not load symbol "dsfrk_64_":
/gnu/store/h5mgc7ar7a05f9rwrd1makhzays5wd3s-julia-1.8.3/bin/../lib/julia/liblapack.so: undefined symbol: dsfrk_64_
Stacktrace:
[1] sfrk!(transr::Char, uplo::Char, trans::Char, alpha::Float64, A::Matrix{Float64}, beta::Float64, C::Vector{Float64})
@ GenericLinearAlgebra.LAPACK2 /gnu/store/zkx6p7kz3m5k5w5iy0l1d09b2n8b0ib3-julia-genericlinearalgebra-0.2.5/share/julia/loadpath/GenericLinearAlgebra/src/lapack.jl:523
[2] Ac_mul_A_RFP(A::Matrix{Float64}, uplo::Symbol)
@ GenericLinearAlgebra /gnu/store/zkx6p7kz3m5k5w5iy0l1d09b2n8b0ib3-julia-genericlinearalgebra-0.2.5/share/julia/loadpath/GenericLinearAlgebra/src/rectfullpacked.jl:77
[3] macro expansion
@ /gnu/store/zkx6p7kz3m5k5w5iy0l1d09b2n8b0ib3-julia-genericlinearalgebra-0.2.5/share/julia/loadpath/GenericLinearAlgebra/test/rectfullpacked.jl:13 [inlined]
[4] macro expansion
@ /gnu/store/h5mgc7ar7a05f9rwrd1makhzays5wd3s-julia-1.8.3/share/julia/stdlib/v1.8/Test/src/Test.jl:1360 [inlined]
[5] macro expansion
@ /gnu/store/zkx6p7kz3m5k5w5iy0l1d09b2n8b0ib3-julia-genericlinearalgebra-0.2.5/share/julia/loadpath/GenericLinearAlgebra/test/rectfullpacked.jl:13 [inlined]
[6] macro expansion
@ /gnu/store/h5mgc7ar7a05f9rwrd1makhzays5wd3s-julia-1.8.3/share/julia/stdlib/v1.8/Test/src/Test.jl:1436 [inlined]
[7] macro expansion
@ /gnu/store/zkx6p7kz3m5k5w5iy0l1d09b2n8b0ib3-julia-genericlinearalgebra-0.2.5/share/julia/loadpath/GenericLinearAlgebra/test/rectfullpacked.jl:7 [inlined]
[8] macro expansion
@ /gnu/store/h5mgc7ar7a05f9rwrd1makhzays5wd3s-julia-1.8.3/share/julia/stdlib/v1.8/Test/src/Test.jl:1360 [inlined]
[9] top-level scope
@ /gnu/store/zkx6p7kz3m5k5w5iy0l1d09b2n8b0ib3-julia-genericlinearalgebra-0.2.5/share/julia/loadpath/GenericLinearAlgebra/test/rectfullpacked.jl:7
[10] include(fname::String)
@ Base.MainInclude ./client.jl:476
[11] top-level scope
@ /gnu/store/zkx6p7kz3m5k5w5iy0l1d09b2n8b0ib3-julia-genericlinearalgebra-0.2.5/share/julia/loadpath/GenericLinearAlgebra/test/runtests.jl:10
[12] include(mod::Module, _path::String)
@ Base ./Base.jl:419
[13] exec_options(opts::Base.JLOptions)
@ Base ./client.jl:303
[14] _start()
@ Base ./client.jl:522

Any idea?

Cheers,
simon
S
S
Simon Tournier wrote on 17 Sep 2023 21:12
[PATCH v3 1/6] gnu: openblas-ilp64: Add symbol suffix.
(address . 66030@debbugs.gnu.org)(name . Efraim Flashner)(address . efraim@flashner.co.il)
7b66989703be17ad1f850c2d53bed6ba63446567.1694977883.git.zimon.toutoune@gmail.com
From: Efraim Flashner <efraim@flashner.co.il>

* gnu/packages/maths.scm (openblas-ilp64)[arguments]<#:make-flags>: Add the
symbol '64_' as suffix.
---
gnu/packages/maths.scm | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)

Toggle diff (19 lines)
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 6141c0988612..c051e60d5e40 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -4638,7 +4638,9 @@ (define-public openblas-ilp64
(arguments
(substitute-keyword-arguments (package-arguments openblas)
((#:make-flags flags #~'())
- #~(append (list "INTERFACE64=1" "LIBNAMESUFFIX=ilp64")
+ #~(append (list "INTERFACE64=1"
+ "SYMBOLSUFFIX=64_"
+ "LIBPREFIX=libopenblas64_")
#$flags))))
(synopsis "Optimized BLAS library based on GotoBLAS (ILP64 version)")
(license license:bsd-3)))

base-commit: fc3a53525ab3dcaf7c22eec8d62294017f9760fe
--
2.38.1
S
S
Simon Tournier wrote on 17 Sep 2023 21:12
[PATCH v3 2/6] gnu: julia: Conditionally use openblas with ILP64 support.
(address . 66030@debbugs.gnu.org)
b07cb54b9d3501d120cb334f14480488958172c7.1694977883.git.zimon.toutoune@gmail.com
From: Efraim Flashner <efraim@flashner.co.il>

Reported by Cayetano Santos <csantosb@inventati.org>.

* gnu/packages/julia.scm (julia)[arguments]<#:phases>: Conditionally use
OpenBLAS with ILP64 support for x86-64 target.
<#:make-flags>: Likewise.
[inputs]: Conditionally replace openblas by openblas-ilp64 for x86-64 target.

Co-authored-by: Simon Tournier <zimon.toutoune@gmail.com>
---
gnu/packages/julia.scm | 22 ++++++++++++++--------
1 file changed, 14 insertions(+), 8 deletions(-)

Toggle diff (49 lines)
diff --git a/gnu/packages/julia.scm b/gnu/packages/julia.scm
index ba541758223e..8ba2b480ce55 100644
--- a/gnu/packages/julia.scm
+++ b/gnu/packages/julia.scm
@@ -269,7 +269,10 @@ (define-public julia
(substitute* (jlpath "nghttp2")
(((from "libnghttp2")) (to "libnghttp2" "libnghttp2")))
(substitute* (jlpath "OpenBLAS")
- (((from "libopenblas")) (to "openblas" "libopenblas")))
+ (((from "libopenblas"))
+ ,@(if (target-x86-64?)
+ `((to "openblas" "libopenblas64_" "libopenblas"))
+ `((to "openblas" "libopenblas")))))
(substitute* (jlpath "OpenLibm")
(((from "libopenlibm")) (to "openlibm" "libopenlibm")))
(substitute* (jlpath "PCRE2")
@@ -479,12 +482,13 @@ (define-public julia
"NO_GIT=1" ; build from release tarball.
"USE_GPL_LIBS=1" ; proudly
- ,@(if (target-aarch64?)
- `("USE_BLAS64=0")
- '())
-
- "LIBBLAS=-lopenblas"
- "LIBBLASNAME=libopenblas"
+ ,@(if (target-x86-64?)
+ `("USE_BLAS64=1"
+ "LIBBLAS=-lopenblas64_"
+ "LIBBLASNAME=libopenblas64_")
+ `("USE_BLAS64=0"
+ "LIBBLAS=-lopenblas"
+ "LIBBLASNAME=libopenblas"))
(string-append "UTF8PROC_INC="
(assoc-ref %build-inputs "utf8proc")
@@ -513,7 +517,9 @@ (define-public julia
("llvm" ,llvm-julia)
("mbedtls-apache" ,mbedtls-apache)
("mpfr" ,mpfr)
- ("openblas" ,openblas)
+ ,@(if (target-x86-64?)
+ `(("openblas" ,openblas-ilp64))
+ `(("openblas" ,openblas)))
("openlibm" ,openlibm)
("p7zip" ,p7zip)
("pcre2" ,pcre2)
--
2.38.1
S
S
Simon Tournier wrote on 17 Sep 2023 21:12
[PATCH v3 3/6] gnu: julia-arraylayouts: Fix tests.
(address . 66030@debbugs.gnu.org)(name . Simon Tournier)(address . zimon.toutoune@gmail.com)
1f400ccc15ef81a7af6689a83858d3b524ec0b42.1694977883.git.zimon.toutoune@gmail.com
* gnu/packages/julia-xyz.scm (julia-arraylayouts)[arguments]: Remove.
---
gnu/packages/julia-xyz.scm | 8 --------
1 file changed, 8 deletions(-)

Toggle diff (21 lines)
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index a1e65332fa10..a3c158763cb5 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -242,14 +242,6 @@ (define-public julia-arraylayouts
(sha256
(base32 "1j11jid4scw9icrbr8g6myp17nabjzmf4f40cichb20lzf1agz8l"))))
(build-system julia-build-system)
- (arguments
- (list
- #:phases
- #~(modify-phases %standard-phases
- (add-after 'unpack 'adjust-tests
- (lambda _
- (substitute* "test/test_layoutarray.jl"
- (("@test all\\(B") "@test_broken all(B")))))))
(propagated-inputs
(list julia-fillarrays))
(native-inputs
--
2.38.1
S
S
Simon Tournier wrote on 17 Sep 2023 21:12
[PATCH v3 4/6] gnu: julia-scanbyte: Update to 0.4.0.
(address . 66030@debbugs.gnu.org)(name . Simon Tournier)(address . zimon.toutoune@gmail.com)
07910d593390ad96854bcad0521dd302faed1644.1694977883.git.zimon.toutoune@gmail.com
* gnu/packages/julia-xyz.scm (julia-scanbyte): Update to 0.4.0.
---
gnu/packages/julia-xyz.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index a3c158763cb5..8eedea85184f 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -5527,7 +5527,7 @@ (define-public julia-sass
(define-public julia-scanbyte
(package
(name "julia-scanbyte")
- (version "0.3.2")
+ (version "0.4.0")
(source
(origin
(method git-fetch)
@@ -5536,7 +5536,7 @@ (define-public julia-scanbyte
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1c18hkcb0h6l437v2s02kijjkyly91mqark84czvh8yzxm19hr7k"))))
+ (base32 "1ww7bbh02s4l917dwkzg9pq71xk0db2rba247vz1xfm24msi8lwj"))))
(build-system julia-build-system)
(propagated-inputs
(list julia-simd))
--
2.38.1
S
S
Simon Tournier wrote on 17 Sep 2023 21:12
[PATCH v3 5/6] gnu: Add wcslib-7.12.
(address . 66030@debbugs.gnu.org)(name . Simon Tournier)(address . zimon.toutoune@gmail.com)
cbec61963b6e853ff3774d76ed2cc1dff414e8c2.1694977883.git.zimon.toutoune@gmail.com
* gnu/packages/astronomy.scm (wcslib-7.12): New variable.
---
gnu/packages/astronomy.scm | 16 ++++++++++++++++
1 file changed, 16 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index e8499bb4b4df..402c09a6db4b 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -11,6 +11,7 @@
;;; Copyright © 2021 Foo Chuan Wei <chuanwei.foo@hotmail.com>
;;; Copyright © 2023 Iliya Tikhonenko <tikhonenko@mpe.mpg.de>
;;; Copyright © 2023 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2023 Simon Tournier <zimon.toutoune@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -741,6 +742,21 @@ (define-public wcslib
header.")
(license license:lgpl3+)))
+;;; The version is required for julia-wcs-jll and julia-wcs. They do not
+;;; support version higher than 7.x.
+(define-public wcslib-7.12
+ (package
+ (inherit wcslib)
+ (version "7.12")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://www.atnf.csiro.au/people/mcalabre/WCS/"
+ "wcslib-" version ".tar.bz2"))
+ (sha256
+ (base32 "1m3bx6gh5w3c7vvsqcki0x20mg8lilg13m0i8nh7za89w58dxy4w"))))
+ (properties '((hidden? . #t)))))
+
(define-public weightwatcher
(package
(name "weightwatcher")
--
2.38.1
S
S
Simon Tournier wrote on 17 Sep 2023 21:12
[PATCH v3 6/6] gnu: julia-wcslib-jll: Downgrade wcslib version.
(address . 66030@debbugs.gnu.org)(name . Simon Tournier)(address . zimon.toutoune@gmail.com)
f8912e50f3e8e6e02a209b6f3bb946ed89775bc0.1694977883.git.zimon.toutoune@gmail.com
The package julia-wcs does not support version higher than 7.x.

* gnu/packages/julia-jll.scm (julia-wcslib-jll)[inputs]: Replace wcslib by
wcslib-7.12.
---
gnu/packages/julia-jll.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/julia-jll.scm b/gnu/packages/julia-jll.scm
index 753651cb9e31..1c03b7e58958 100644
--- a/gnu/packages/julia-jll.scm
+++ b/gnu/packages/julia-jll.scm
@@ -1792,7 +1792,7 @@ (define-public julia-wcs-jll
;; There's a Julia file for each platform, override them all
(find-files "src/wrappers/" "\\.jl$")))))))
(inputs
- (list wcslib))
+ (list wcslib-7.12))
(propagated-inputs
(list julia-jllwrappers))
(home-page "https://github.com/JuliaBinaryWrappers/WCS_jll.jl")
--
2.38.1
S
S
Simon Tournier wrote on 4 Oct 2023 20:25
control message for bug #66030
(address . control@debbugs.gnu.org)
87o7hez1mk.fsf@gmail.com
close 66030
quit
?