[PATCH gnome-team] gnu: libshumate: Update to 1.0.5.

  • Done
  • quality assurance status badge
Details
2 participants
  • Liliana Marie Prikler
  • Vivien Kraus
Owner
unassigned
Submitted by
Vivien Kraus
Severity
normal
V
V
Vivien Kraus wrote on 15 Sep 2023 20:07
(address . guix-patches@gnu.org)
75ff5e8356a7498925294d40a2144d4716dcde1c.1694802528.git.vivien@planete-kraus.eu
* gnu/packages/gnome.scm (libshumate): Update to 1.0.5.
[#:phase 'pre-check]: Remove it, and move the modifications to 'check.
[#:phase 'check]: Replace the phase to run the test under dbus-run-session.
[native-inputs]: Add dbus and at-spi2-core for tests.
---
gnu/packages/gnome.scm | 36 +++++++++++++++++++++++-------------
1 file changed, 23 insertions(+), 13 deletions(-)

Toggle diff (65 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index f5ed13565d..49a645b88b 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -4943,7 +4943,7 @@ (define-public rest-next
(define-public libshumate
(package
(name "libshumate")
- (version "1.0.0.beta") ;no stable release yet
+ (version "1.0.5")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -4951,25 +4951,35 @@ (define-public libshumate
name "-" version ".tar.xz"))
(sha256
(base32
- "13xrc07fm0967gzbqab8k0l3dnknh00p0a6f2dm7k0aa56q41sda"))))
+ "0v4m07vxm3m4a2vqkp2wfsc3zsf92fpigc1k8yq49vkpj7gxikx8"))))
(build-system meson-build-system)
- (arguments (list #:configure-flags #~(list "-Dlibsoup3=true")
- #:phases #~(modify-phases %standard-phases
- (add-before 'check 'pre-check
- (lambda _
- ;; The 'coordinate' test requires a
- ;; writable HOME.
- (setenv "HOME" "/tmp")
+ (arguments
+ (list #:configure-flags #~(list "-Dlibsoup3=true")
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? test-options #:allow-other-keys)
+ (when tests?
+ ;; Some tests expect to write to $HOME.
+ (setenv "HOME" "/tmp")
+ (setenv "XDG_RUNTIME_DIR" "/tmp/run")
+ (setenv "XDG_CACHE_HOME" "/tmp/cache")
+
+ ;; Tests require a running X server.
+ (system "Xvfb :1 &")
+ (setenv "DISPLAY" ":1")
- ;; Tests require a running X server.
- (system "Xvfb :1 &")
- (setenv "DISPLAY" ":1"))))))
+ (apply invoke "dbus-run-session" "--" "meson" "test"
+ "--print-errorlogs" test-options)))))))
(native-inputs
(list gi-docgen
`(,glib "bin")
gobject-introspection
pkg-config
- xorg-server-for-tests))
+ ;; For tests:
+ xorg-server-for-tests
+ dbus
+ at-spi2-core))
(propagated-inputs
;; All the libraries are listed as "Requires' in the .pc file.
(list cairo

base-commit: 43cdc8a07517e936812782c313fe145bcf5c7ed3
--
2.41.0
L
L
Liliana Marie Prikler wrote on 24 Sep 2023 12:00
53eec05cf618de30aa067857ced2e45848c57d0f.camel@gmail.com
Am Freitag, dem 15.09.2023 um 20:07 +0200 schrieb Vivien Kraus:
Toggle quote (7 lines)
> * gnu/packages/gnome.scm (libshumate): Update to 1.0.5.
> [#:phase 'pre-check]: Remove it, and move the modifications to
> 'check.
> [#:phase 'check]: Replace the phase to run the test under dbus-run-
> session.
> [native-inputs]: Add dbus and at-spi2-core for tests.
> ---
Pushed with a reworded ChangeLog.

Thanks
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 66012@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 66012
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch