Vivien Kraus wrote 1 years ago
(address . guix-patches@gnu.org)
* gnu/packages/gnome.scm (totem): Update to 43.0.
[#:phase 'skip-gtk-update-icon-cache]: Adjust to build system changes.
---
gnu/packages/gnome.scm | 9 +++++----
1 file changed, 5 insertions(+), 4 deletions(-)
Toggle diff (38 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index f5ed13565d..ad1e09415b 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -6592,7 +6592,7 @@ (define-public grilo-plugins
(define-public totem
(package
(name "totem")
- (version "42.0")
+ (version "43.0")
(source
(origin
(method url-fetch)
@@ -6600,7 +6600,7 @@ (define-public totem
(version-major version) "/"
"totem-" version ".tar.xz"))
(sha256
- (base32 "1az6ay7zhz2naqrzcfldx1yv2ylw1yjx76g3mqrqppwmvcflkw2a"))))
+ (base32 "07m4jiry78m85sqcx7f9r7dkfvfnd8xzhfad5939cn4bj9akcvdk"))))
(build-system meson-build-system)
(native-inputs
(list pkg-config
@@ -6654,8 +6654,9 @@ (define-public totem
(add-after 'unpack 'skip-gtk-update-icon-cache
;; Don't create 'icon-theme.cache'.
(lambda _
- (substitute* "meson_post_install.py"
- (("gtk-update-icon-cache") "true"))))
+ (substitute* "meson.build"
+ (("gtk_update_icon_cache: true")
+ "gtk_update_icon_cache: false"))))
(add-before 'install 'disable-cache-generation
(lambda _
(setenv "DESTDIR" "/")))
base-commit: 43cdc8a07517e936812782c313fe145bcf5c7ed3
--
2.41.0