(address . guix-patches@gnu.org)
* gnu/packages/haskell-xyz.scm (ghc-hsyslog): New variable.
---
gnu/packages/haskell-xyz.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)
Toggle diff (49 lines)
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index c02fd007f9..6d540aee54 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -33,6 +33,7 @@
;;; Copyright © 2022 jgart <jgart@dismail.de>
;;; Copyright © 2023 Josselin Poiret <dev@jpoiret.xyz>
;;; Copyright © 2023 zamfofex <zamfofex@twdb.moe>
+;;; Copyright © 2023 pinoaffe <pinoaffe@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1422,6 +1423,32 @@ (define-public ghc-case-insensitive
the resulting type will be insensitive to cases.")
(license license:bsd-3)))
+(define-public ghc-hsyslog
+ (package
+ (name "ghc-hsyslog")
+ (version "5.0.2")
+ (source (origin
+ (method url-fetch)
+ (uri (hackage-uri "hsyslog" version))
+ (sha256
+ (base32
+ "1kkypn0dd92aqv8dr112bhkr9k9r9mchnyyvy41kvhj2zg447v1y"))))
+ (build-system haskell-build-system)
+ (properties '((upstream-name . "hsyslog")))
+ (arguments
+ `(#:cabal-revision ("1"
+ "0k1j46nk3z64zw4bqmvw5lgy16ih200m66rv4b6ygjqv7nglqq0b")))
+ (home-page "https://github.com/peti/hsyslog")
+ (synopsis "FFI interface to syslog(3) from POSIX.1-2008")
+ (description
+ "This package provides a Haskell interface to @code{syslog} as specified
+in POSIX.1-2008. The entire public API lives in @code{System.Posix.Syslog}.
+There is a set of exposed modules available underneath that one, which contain
+various implementation details that may be useful to other developers who want
+to implement syslog-related functionality. Users of @code{syslog}, however,
+do not need them.")
+ (license license:bsd-3)))
+
(define-public ghc-cassava
(package
(name "ghc-cassava")
base-commit: cf5cb0875b06b5823e9de8bbd01ddd8c0b0d15a7
--
2.41.0