[PATCH] gnu: Add tty-share.

  • Open
  • quality assurance status badge
Details
3 participants
  • B. Wilson
  • Hilton Chain
  • Steve George
Owner
Somebody
Submitted by
B. Wilson
Severity
normal
B
B
B. Wilson wrote on 14 Sep 2023 07:59
(address . guix-patches@gnu.org)(name . B. Wilson)(address . elaexuotee@wilsonb.com)
20230914055917.5487-1-elaexuotee@wilsonb.com
* gnu/packages/tty-share.scm: New file.
* gnu/local.mk (GNU_SYSTEM_MODULES): Add it.
---
gnu/local.mk | 1 +
gnu/packages/tty-share.scm | 59 ++++++++++++++++++++++++++++++++++++++
2 files changed, 60 insertions(+)
create mode 100644 gnu/packages/tty-share.scm

Toggle diff (79 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index 924d497057..75e59e309f 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -622,6 +622,7 @@ GNU_SYSTEM_MODULES = \
%D%/packages/toolkits.scm \
%D%/packages/tor.scm \
%D%/packages/tree-sitter.scm \
+ %D%/packages/tty-share.scm \
%D%/packages/tv.scm \
%D%/packages/uglifyjs.scm \
%D%/packages/uml.scm \
diff --git a/gnu/packages/tty-share.scm b/gnu/packages/tty-share.scm
new file mode 100644
index 0000000000..54dfc97f0f
--- /dev/null
+++ b/gnu/packages/tty-share.scm
@@ -0,0 +1,59 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2023 B. Wilson <elaexuotee@wilsonb.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages tty-share)
+ #:use-module (guix build-system go)
+ #:use-module (guix build-system node)
+ #:use-module (guix gexp)
+ #:use-module (guix git-download)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix packages))
+
+(define-public tty-share
+ (let ((version "2.4.0")
+ (revision "1")
+ (commit "3801cfbdd78246841d1b2abced99b42a0ff1e020"))
+ (package
+ (name "tty-share")
+ (version (git-version version revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/elisescu/tty-share.git")
+ (commit commit)))
+ (sha256
+ (base32 "0vp2gax9vmv8y0y59ya5r8z6xn6rg82203sg0706k8p2p5bhpqka"))
+ (file-name (git-file-name name version))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/elisescu/tty-share"
+ #:install-source? #f ; Package is an end-user application
+ #:tests? #f)) ; Upstream has no tests
+ (home-page "https://tty-share.com/")
+ (synopsis "Collaborative terminal sessions")
+ (description "@code{tty-share} is a very simple tool used to share your
+Linux/OSX terminal over the Internet. The remote participant needs zero setup
+and can join from either a browser or local terminal. The session can be
+shared either over the Internet, or only in the local network. When sharing it
+over the Internet (outside your NAT), @code{tty-share} will connect to proxy
+server that will mediate the communication between the participants. An
+instance of this server runs at @url{tty-share.com}, but you can run your own
+as well.")
+ (license license:expat))))
--
2.41.0
H
H
Hilton Chain wrote on 4 Nov 2023 10:08
(name . B. Wilson)(address . elaexuotee@wilsonb.com)(address . 65937@debbugs.gnu.org)
87v8ahx4v2.wl-hako@ultrarare.space
Hi,

On Thu, 14 Sep 2023 13:59:09 +0800,
B. Wilson via Guix-patches via wrote:
Toggle quote (9 lines)
>
> * gnu/packages/tty-share.scm: New file.
> * gnu/local.mk (GNU_SYSTEM_MODULES): Add it.
> ---
> gnu/local.mk | 1 +
> gnu/packages/tty-share.scm | 59 ++++++++++++++++++++++++++++++++++++++
> 2 files changed, 60 insertions(+)
> create mode 100644 gnu/packages/tty-share.scm

tty-share has vendored dependencies in its repository, can you remove the
"vendor" directory via a snippet and add those dependencies to inputs?

There might be packages not currently available in Guix, so some extra work
should be expected.

Thanks
S
S
Steve George wrote on 16 Apr 10:00 +0200
owner 65937
(address . control@debbugs.gnu.org)
1713254419-1957-bts-steve@futurile.net
owner 65937 !
thanks
?