(address . bug-guix@gnu.org)
Hi,
When doing a guix-deploy on aarch64 with the following command in a
checked out guix git repository with the following command:
Toggle quote (3 lines)
> guix time-machine --commit=$(git rev-parse HEAD) -- deploy -L
> rockpro64/ rockpro64/rockpro64.scm
I've got the following build failure:
Toggle quote (38 lines)
> LD [M] net/openvswitch/openvswitch.ko
> LD [M] net/openvswitch/vport-vxlan.ko
> LD [M] net/openvswitch/vport-geneve.ko
> LD [M] net/openvswitch/vport-gre.ko
> LD [M] net/vmw_vsock/vsock.ko
> LD [M] net/vmw_vsock/vsock_diag.ko
> LD [M] net/vmw_vsock/vmw_vsock_vmci_transport.ko
> LD [M] net/vmw_vsock/vmw_vsock_virtio_transport.ko
> LD [M] net/vmw_vsock/vmw_vsock_virtio_transport_common.ko
> LD [M] net/vmw_vsock/hv_sock.ko
> LD [M] net/vmw_vsock/vsock_loopback.ko
> LD [M] net/nsh/nsh.ko
> LD [M] net/qrtr/qrtr.ko
> LD [M] net/qrtr/qrtr-smd.ko
> LD [M] net/qrtr/qrtr-tun.ko
> LD [M] net/qrtr/qrtr-mhi.ko
> error: in phase 'build': uncaught exception:
> %exception #<&invoke-error program: "make" arguments: ("-j" "6")
> exit-status: 2 term-signal: #f stop-signal: #f> phase `build' failed
> after 16208.5 seconds command "make" "-j" "6" failed with status 2
> builder for
> `/gnu/store/f678azkxiyxv5vm5yacr7pp6c4rhsnaw-linux-libre-6.4.8.drv'
> failed with exit code 1 cannot build derivation
> `/gnu/store/rqdmzzgcydvy485hp3fib2s6pz6ib5pk-linux-modules.drv': 1
> dependencies couldn't be built cannot build derivation
> `/gnu/store/fznw4yyx5s4wdi950hmdw78lyz0chlgr-parameters.drv': 1
> dependencies couldn't be built cannot build derivation
> `/gnu/store/dw3z33as5s7jhppha2bgi3kiab26pix0-profile.drv': 1
> dependencies couldn't be built cannot build derivation
> `/gnu/store/y385isj6ha1dpzcxnws1vq4b9wf3bpcr-system.drv': 1
> dependencies couldn't be built cannot build derivation
> `/gnu/store/791hw1spny38mlhiknf77ihikk2km9zz-switch-to-system.scm.drv':
> 1 dependencies couldn't be built cannot build derivation
> `/gnu/store/3hvlqvfd9x7mylkrr8wsiw4vwpja60hk-remote-exp.scm.drv': 1
> dependencies couldn't be built guix deploy: error: build of
> `/gnu/store/3hvlqvfd9x7mylkrr8wsiw4vwpja60hk-remote-exp.scm.drv'
> failed
So I've bisected and the bisect found this commit:
Toggle quote (15 lines)
> bff1f2d4d07e934ea296f9c724b5337996a27c44 is the first bad commit
> commit bff1f2d4d07e934ea296f9c724b5337996a27c44
> Author: Leo Famulari <leo@famulari.name>
> Date: Tue Aug 8 10:37:16 2023 -0400
>
> gnu: linux-libre: Update to 6.4.8.
>
> * gnu/packages/linux.scm (linux-libre-version,
> linux-libre-gnu-revision, linux-libre-pristine-source,
> linux-libre-source, linux-libre, linux-libre-with-bpf): Update to
> linux-libre 6.4.
>
> gnu/packages/linux.scm | 16 ++++++++--------
> 1 file changed, 8 insertions(+), 8 deletions(-)
Denis.
;;; Copyright © Guix documentation authors
;;; Copyright © 2022 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
;;; This file is not part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(use-modules (gnu)
(gnu machine)
(gnu machine ssh))
(list (machine
(operating-system
(@ (rockpro64-system) rockpro64-operating-system))
(environment managed-host-environment-type)
(configuration
(machine-ssh-configuration
(authorize? #t)
(build-locally? #f)
(host-key
(string-append
"ssh-ed25519"
" "
"AAAAC3NzaC1lZDI1NTE5AAAAIJXJagiYEGOgmij79pO0E5UqjnStKBB8T1H5S/eFYk5S"))
(host-name "192.168.10.35")
(identity "./id_ed25519")
(port 222)
(system "aarch64-linux")
(user "root")))))
-----BEGIN PGP SIGNATURE-----
iQIzBAEBCAAdFiEEeC+d2+Nrp/PU3kkGX138wUF34mMFAmUBvYAACgkQX138wUF3
4mNi4xAApKvpI+zFUQREqAOf6B9LI6KG1AokmcmB5T8cP1utlIuxu8ar/u/DdcFZ
fZxkVSqgM3cdkHPrqmYgTsJ1qRfrKZFR+r/S3vYzC9LFViKuiO/xDQgQg91RwSuY
WhYHLXKmqpsDrsAd3+p7Ih+4cCxaHpHi+PO8Sl+BlYEOGzRXgE33HqfHU64beZtj
rs+laZS1+9Cq658VvzeV+8c1fRWDX0wxUFAqwys7lMJzihvI+9UZi+31G3uPghZe
vt8pk7I4nUX1KPUoXleAAO8recDUN29IXn+Xl3R9Tg+S4tZpZc+TVCcV1Hve2d/z
PrSTM82iyddWdKyaLK7Fd59ld6gkUIcu5BivVZgk3A8CewHhKzzsf7ODom780QnD
dUwmJXlSv7p/w+whBgRiqtecEA2bh9Km6CWxEY27PF4WRzT5iUfuXBSxnuaDdWua
HL/WtfjBZEvxmv+7rUtNm2dDcWdSC1HvJKQEc8Z1XQkDdZ2eUYS31A4saz2rDdla
1tcYAWSJh5jF+5Mikc0UeeC4VbJx5iRm4K+eD7X/FtYGeBi9oQ+fRiKyCdUUZG64
4ezQ41w3wKyXTCC0hVYR+Vva6AsEDkpSqlUdGYXvR9WRE4CmrkKcbDAD+LFEE2zJ
8YKG7UWbZhI39baWL+QEfXrqPKyfKvgSMCmjM/1vnaivsk26eio=
=wLF3
-----END PGP SIGNATURE-----