Mădălin Ionel Patrașcu wrote 1 years ago
(address . guix-patches@gnu.org)
* gnu/packages/bioinformatics.scm (python-hicmatrix): Add new phase
'fix-references that remove the * character from the name of the
requirements.
---
gnu/packages/bioinformatics.scm | 6 +++++-
1 file changed, 5 insertions(+), 1 deletion(-)
Toggle diff (21 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index e24d70e569..06ff34e877 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -16228,7 +16228,11 @@ (define-public python-hicmatrix
(arguments
(list
#:phases
- '(modify-phases %standard-phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-references
+ (lambda _
+ (substitute* "setup.py"
+ ((".\\*\"") ".0\""))))
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
(when tests?
base-commit: 9996896dc252a02ba3b17473a685ce8957237546
--
2.41.0