[core-updates] gnu: ocaml: Allow not to build the native compiler.

  • Done
  • quality assurance status badge
Details
2 participants
  • Andreas Enge
  • Vivien Kraus
Owner
unassigned
Submitted by
Vivien Kraus
Severity
normal

Debbugs page

Vivien Kraus wrote 1 years ago
(address . guix-patches@gnu.org)
fd47373f57c0b871a0e20b93ff8409ad061cdc36.1694551057.git.vivien@planete-kraus.eu
* gnu/packages/ocaml.scm (ocaml-5.0) [entry point]: Build "defaultentry", not
"world.opt", so that the build system decides whether to build the native
compiler or just the bytecode compiler. The native compiler is not available
for 32-bit architectures.
---
gnu/packages/ocaml.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (17 lines)
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 8ff755aea9..ea9d3e3594 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -219,7 +219,7 @@ (define-public ocaml-5.0
(arguments
`(#:configure-flags '("--enable-ocamltest")
#:test-target "tests"
- #:make-flags '("world.opt")
+ #:make-flags '("defaultentry")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'patch-/bin/sh-references

base-commit: e79afd5d2574eb35f54c070a3f6048806721ef04
--
2.41.0
Vivien Kraus wrote 1 years ago
Ocaml optional native compiler: it still fails for i686-linux
(address . 65898@debbugs.gnu.org)
d4e531d5621a0d0ef6dc5e7ba605bf6dea596575.camel@planete-kraus.eu
Hi,

The native compiler for ocaml is not always available, especially for
i686-linux. The first step is to get the "best" possible compiler
instead of requiring the native compiler. However, building for i686-
linux still fails. The test suite reports no failure nor error, but it
still fails. What does that mean?

```
Summary:
2285 tests passed
592 tests skipped
0 tests failed
569 tests not started (parent test skipped or failed)
0 unexpected errors
3446 tests considered
make[1]: Leaving directory '/tmp/guix-build-ocaml-5.0.0.drv-
0/source/testsuite'

Test suite failed, dumping logs.
```

Vivien
Andreas Enge wrote 1 years ago
Closing
(address . 65898-done@debbugs.gnu.org)
ZQVdvBMn10zpQvCA@jurong
Hello Vivien,

it has been built by QA, so I have pushed the patch and close this issue.
Thanks!

Andreas
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 65898@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 65898
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help