[PATCH] gnu: xxhash: Update to 0.8.2.

  • Done
  • quality assurance status badge
Details
4 participants
  • Hendursaga
  • Christopher Baines
  • Maxim Cournoyer
  • Mathieu Othacehe
Owner
unassigned
Submitted by
Hendursaga
Severity
normal

Debbugs page

Hendursaga wrote 2 years ago
(address . guix-patches@gnu.org)
4c5c02439c0e000ad59bbf512d5326fa249b726f.1694447118.git.hendursaga@aol.com
* gnu/packages/digest.scm (xxhash): Update to 0.8.2.
[arguments]: Use Gexp.
<#:phases>: Remove 'fix-man-page-links phase.
[home-page]: Update URL.
---
gnu/packages/digest.scm | 58 ++++++++++++++++++-----------------------
1 file changed, 26 insertions(+), 32 deletions(-)

Toggle diff (81 lines)
diff --git a/gnu/packages/digest.scm b/gnu/packages/digest.scm
index 481771804b..9ed3b895a2 100644
--- a/gnu/packages/digest.scm
+++ b/gnu/packages/digest.scm
@@ -69,46 +69,40 @@ (define-public wyhash
(define-public xxhash
(package
(name "xxhash")
- ;; XXX Remove the 'fix-man-page-links phase when updating.
- (version "0.8.1")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/Cyan4973/xxHash")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1h6080lvcr5mpbvy4fhb4i7wvhpy72nrixk3djmpai4hxq41hsnr"))))
+ (version "0.8.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Cyan4973/xxHash")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1ljsmxcxfyxzxzk435qnjiyy441bgrxirn285lymyvv39nrwz1wj"))))
(build-system gnu-build-system)
(arguments
- (list #:make-flags
- #~(list #$(string-append "CC=" (cc-for-target))
- #$(match (or (%current-target-system)
- (%current-system))
- ;; Detect vector instruction set at run time.
- ((or "i686-linux" "x86_64-linux") "DISPATCH=1")
- (_ "DISPATCH=0"))
- "XXH_FORCE_MEMORY_ACCESS=1" ; improved performance with GCC
- (string-append "prefix=" (assoc-ref %outputs "out")))
- #:phases
- #~(modify-phases %standard-phases
- (add-after 'unpack 'fix-man-page-links
- ;; https://github.com/Cyan4973/xxHash/issues/647
- (lambda _
- (substitute* "Makefile"
- (("ln -sf \\$\\(MAN\\)")
- "ln -sf xxhsum.1"))))
- (delete 'configure)))) ; no configure script
- (home-page "https://cyan4973.github.io/xxHash/")
+ (list #:make-flags #~(list #$(string-append "CC="
+ (cc-for-target))
+ #$(match (or (%current-target-system)
+ (%current-system))
+ ;; Detect vector instruction set at run time.
+ ((or "i686-linux" "x86_64-linux")
+ "DISPATCH=1")
+ (_ "DISPATCH=0"))
+ "XXH_FORCE_MEMORY_ACCESS=1" ;improved performance with GCC
+ (string-append "prefix="
+ (assoc-ref %outputs "out")))
+ #:phases #~(modify-phases %standard-phases
+ (delete 'configure)))) ;no configure script
+ (home-page "https://xxhash.com/")
(synopsis "Extremely fast hash algorithm")
(description
"xxHash is an extremely fast non-cryptographic hash algorithm. It works
at speeds close to RAM limits, and comes in both 32- and 64-bit flavours.
The code is highly portable, and hashes of the same length are identical on all
platforms (both big and little endian).")
- (license (list license:bsd-2 ; xxhash library (xxhash.[ch])
- license:gpl2+)))) ; xxhsum.c
+ (license (list license:bsd-2 ;xxhash library (xxhash.[ch])
+ license:gpl2+)))) ;xxhsum.c
(define-public python-xxhash
(package

base-commit: 2eb6df537c36da8bf8e81ff698421f6fb1bfd1ab
--
2.40.1
Mathieu Othacehe wrote 1 years ago
(name . Hendursaga)(address . hendursaga@aol.com)(address . 65869@debbugs.gnu.org)
87r0m9umoe.fsf_-_@gnu.org
Hey,

Toggle quote (7 lines)
> - #~(list #$(string-append "CC=" (cc-for-target))
> - #$(match (or (%current-target-system)
> - (%current-system))
> - ;; Detect vector instruction set at run time.
> - ((or "i686-linux" "x86_64-linux") "DISPATCH=1")
> - (_ "DISPATCH=0"))

Could you conserve the original indentation here, not to introduce
noise?

Toggle quote (6 lines)
> - "XXH_FORCE_MEMORY_ACCESS=1" ; improved performance with GCC
> - (string-append "prefix=" (assoc-ref %outputs "out")))

> + (string-append "prefix="
> + (assoc-ref %outputs "out")))

You can use #$output here.

Could you please send an updated version :)?

Thanks,

Mathieu
Christopher Baines wrote 1 years ago
tag 65869 moreinfo
(address . control@debbugs.gnu.org)
87mswp5uf5.fsf@cbaines.net
tags 65869 + moreinfo
quit
Maxim Cournoyer wrote 4 months ago
control message for bug #65869
(address . control@debbugs.gnu.org)
878qto7v4b.fsf@gmail.com
close 65869
quit
?
Your comment

This issue is archived.

To comment on this conversation send an email to 65869@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 65869
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help