(address . guix-patches@gnu.org)
* gnu/packages/digest.scm (xxhash): Update to 0.8.2.
[arguments]: Use Gexp.
<#:phases>: Remove 'fix-man-page-links phase.
[home-page]: Update URL.
---
gnu/packages/digest.scm | 58 ++++++++++++++++++-----------------------
1 file changed, 26 insertions(+), 32 deletions(-)
Toggle diff (81 lines)
diff --git a/gnu/packages/digest.scm b/gnu/packages/digest.scm
index 481771804b..9ed3b895a2 100644
--- a/gnu/packages/digest.scm
+++ b/gnu/packages/digest.scm
@@ -69,46 +69,40 @@ (define-public wyhash
(define-public xxhash
(package
(name "xxhash")
- ;; XXX Remove the 'fix-man-page-links phase when updating.
- (version "0.8.1")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/Cyan4973/xxHash")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1h6080lvcr5mpbvy4fhb4i7wvhpy72nrixk3djmpai4hxq41hsnr"))))
+ (version "0.8.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Cyan4973/xxHash")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1ljsmxcxfyxzxzk435qnjiyy441bgrxirn285lymyvv39nrwz1wj"))))
(build-system gnu-build-system)
(arguments
- (list #:make-flags
- #~(list #$(string-append "CC=" (cc-for-target))
- #$(match (or (%current-target-system)
- (%current-system))
- ;; Detect vector instruction set at run time.
- ((or "i686-linux" "x86_64-linux") "DISPATCH=1")
- (_ "DISPATCH=0"))
- "XXH_FORCE_MEMORY_ACCESS=1" ; improved performance with GCC
- (string-append "prefix=" (assoc-ref %outputs "out")))
- #:phases
- #~(modify-phases %standard-phases
- (add-after 'unpack 'fix-man-page-links
- ;; https://github.com/Cyan4973/xxHash/issues/647
- (lambda _
- (substitute* "Makefile"
- (("ln -sf \\$\\(MAN\\)")
- "ln -sf xxhsum.1"))))
- (delete 'configure)))) ; no configure script
- (home-page "https://cyan4973.github.io/xxHash/")
+ (list #:make-flags #~(list #$(string-append "CC="
+ (cc-for-target))
+ #$(match (or (%current-target-system)
+ (%current-system))
+ ;; Detect vector instruction set at run time.
+ ((or "i686-linux" "x86_64-linux")
+ "DISPATCH=1")
+ (_ "DISPATCH=0"))
+ "XXH_FORCE_MEMORY_ACCESS=1" ;improved performance with GCC
+ (string-append "prefix="
+ (assoc-ref %outputs "out")))
+ #:phases #~(modify-phases %standard-phases
+ (delete 'configure)))) ;no configure script
+ (home-page "https://xxhash.com/")
(synopsis "Extremely fast hash algorithm")
(description
"xxHash is an extremely fast non-cryptographic hash algorithm. It works
at speeds close to RAM limits, and comes in both 32- and 64-bit flavours.
The code is highly portable, and hashes of the same length are identical on all
platforms (both big and little endian).")
- (license (list license:bsd-2 ; xxhash library (xxhash.[ch])
- license:gpl2+)))) ; xxhsum.c
+ (license (list license:bsd-2 ;xxhash library (xxhash.[ch])
+ license:gpl2+)))) ;xxhsum.c
(define-public python-xxhash
(package
base-commit: 2eb6df537c36da8bf8e81ff698421f6fb1bfd1ab
--
2.40.1