(address . guix-patches@gnu.org)(address . ngraves@ngraves.fr)
* gnu/packages/maths.scm (scilab): Set SCIHOME default to respect XDG base dirs.
[arguments](phases): Add phase respect-xdg-base-dirs.
---
gnu/packages/maths.scm | 9 ++++++++-
1 file changed, 8 insertions(+), 1 deletion(-)
Toggle diff (22 lines)
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 900a9f0fac..8162ab95d1 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -8553,7 +8553,14 @@ (define-public scilab
"/bin/dirname"))
(("basename")
#$(file-append (this-package-input "coreutils")
- "/bin/basename"))))))))
+ "/bin/basename")))))
+ (add-after 'hardcode-script-inputs 'respect-xdg-base-dirs
+ (lambda _
+ (substitute* (string-append #$output "/bin/scilab")
+ (("IS_SCILAB_BINARY=0" all)
+ (string-append all
+ "\n[ -n \"$SCIHOME\" ] &&\
+ SCIHOME=\"${XDG_STATE_HOME}/scilab\""))))))))
(home-page "https://scilab.org")
(synopsis "Software for engineers and scientists")
(description "This package provides the non-graphical version of the Scilab
--
2.41.0