Bug report: "You found a bug"

  • Done
  • quality assurance status badge
Details
2 participants
  • Josselin Poiret
  • Lasse Schlör
Owner
unassigned
Submitted by
Lasse Schlör
Severity
normal
L
L
Lasse Schlör wrote on 7 Sep 2023 15:42
(address . bug-guix@gnu.org)
1CD6C35A-AAA5-4B30-BDA8-F0368D63E450@uni-tuebingen.de
Hello,

The command that ran into this bug was:
`guix shell --manifest=guix-psychopy-manifest.scm`

The contents of `guix-psychopy-manifest.scm` were as follows:
```
(use-modules (guix inferior) (guix channels)
(srfi srfi-1))

(define channels
(list (channel
(name 'guix)
(commit
;; Last commit with Python 3.8
"f1eea19c9ae27e5d275b083bbf280e5b59e5e57a"))))

(define inferior
(inferior-for-channels channels))

(packages->manifest
(list (first (lookup-inferior-packages inferior "python"))
(specification->package "git")))
```

The command fetched/downloaded a lot of packages without issues. Then, the following output happened:
[…]
```
fetching path `/gnu/store/rw5z0mmdlcwkdzvr94bgihwlnhzwyky4-bzip2-boot0-1.0.8'...
-guix substitute: warning: while fetching https://ci.guix.gnu.org/nar/gzip/rw5z0mmdlcwkdzvr94bgihwlnhzwyky4-bzip2-boot0-1.0.8:server is somewhat slow
guix substitute: warning: try `--no-substitutes' if the problem persists
guix substitute: warning: download from 'https://ci.guix.gnu.org/nar/gzip/rw5z0mmdlcwkdzvr94bgihwlnhzwyky4-bzip2-boot0-1.0.8'failed, trying next URL
-guix substitute: warning: while fetching https://ci.guix.gnu.org/nar/lzip/rw5z0mmdlcwkdzvr94bgihwlnhzwyky4-bzip2-boot0-1.0.8:server is somewhat slow
guix substitute: warning: try `--no-substitutes' if the problem persists
guix substitute: warning: download from 'https://ci.guix.gnu.org/nar/lzip/rw5z0mmdlcwkdzvr94bgihwlnhzwyky4-bzip2-boot0-1.0.8'failed: 504, "Gateway Time-out"
retrying download of '/gnu/store/rw5z0mmdlcwkdzvr94bgihwlnhzwyky4-bzip2-boot0-1.0.8' with other substitute URLs...
guix substitute: warning: download from 'https://ci.guix.gnu.org/nar/gzip/rw5z0mmdlcwkdzvr94bgihwlnhzwyky4-bzip2-boot0-1.0.8'failed, trying next URL
guix substitute: warning: download from 'https://ci.guix.gnu.org/nar/lzip/rw5z0mmdlcwkdzvr94bgihwlnhzwyky4-bzip2-boot0-1.0.8'failed: 504, "Gateway Time-out"
guix substitute: error: failed to find alternative substitute for '/gnu/store/rw5z0mmdlcwkdzvr94bgihwlnhzwyky4-bzip2-boot0-1.0.8'
fetching path `/gnu/store/rw5z0mmdlcwkdzvr94bgihwlnhzwyky4-bzip2-boot0-1.0.8' (empty status: '')
fetching path `/gnu/store/gcl0d5i1hfg4s0fv21dgaf7r5z3i16zd-coreutils-boot0-8.32'...
Backtrace:
15 (primitive-load "/gnu/store/fnyqpbdxbm4ipwvq9vfmxpkphdlqjcg3-compute-guix-derivation")
In ice-9/eval.scm:
155:9 14 (_ _)
159:9 13 (_ #(#(#(#(#(#(#(#(#(#(#(#(#(#<directory (guile-user) 7f51587cfc?> ?) ?) ?) ?) ?) ?) ?) ?) ?) ?) ?) ?) ?))
In ./guix/store.scm:
2049:24 12 (run-with-store #<store-connection 256.99 7f51530fae60> #<procedure 7f5147f4bbc0 at ./guix/self.scm:12?> ?)
\ 1883:8 11 (_ #<store-connection 256.99 7f51530fae60>)
In ./guix/gexp.scm:
258:18 10 (_ #<store-connection 256.99 7f51530fae60>)
1123:2 9 (_ #<store-connection 256.99 7f51530fae60>)
982:2 8 (_ #<store-connection 256.99 7f51530fae60>)
843:4 7 (_ #<store-connection 256.99 7f51530fae60>)
In ./guix/store.scm:
1931:12 6 (_ #<store-connection 256.99 7f51530fae60>)
1358:5 5 (map/accumulate-builds #<store-connection 256.99 7f51530fae60> #<procedure 7f514d350d40 at ./guix/stor?> ?)
1369:15 4 (_ #<store-connection 256.99 7f51530fae60> ("/gnu/store/jwi2rqsz16lipgfl1h3084z8hiincnwv-guile-git-?" ?) ?)
1369:15 3 (loop #f)
715:11 2 (process-stderr #<store-connection 256.99 7f51530fae60> _)
In ./guix/serialization.scm:
101:11 1 (read-int #<input-output: file 10>)
79:6 0 (get-bytevector-n* #<input-output: file 10> 8)

./guix/serialization.scm:79:6: In procedure get-bytevector-n*:
ERROR:
1. &nar-error:
file: #f
port: #<input-output: file 10>
guix shell: error: You found a bug: the program '/gnu/store/fnyqpbdxbm4ipwvq9vfmxpkphdlqjcg3-compute-guix-derivation'
failed to compute the derivation for Guix (version: "f1eea19c9ae27e5d275b083bbf280e5b59e5e57a"; system: "x86_64-linux";
host version: "6113e0529d61df7425f64e30a6bf77f7cfdfe5a5"; pull-version: 1).
Please report it by email to <bug-guix@gnu.org>.
```

As requested by Guix, I am reporting the bug with this email.

I assume this bug happened upon a temporary loss of the internet connection. Running the command anew continued fetching/downloading just fine.

Kind regards
Lasse Schlör
J
J
Josselin Poiret wrote on 12 Sep 2023 14:10
878r9b4moa.fsf@jpoiret.xyz
Hi Lasse,

Lasse Schlör <lasse.schloer@uni-tuebingen.de> writes:

Toggle quote (4 lines)
> As requested by Guix, I am reporting the bug with this email.
>
> I assume this bug happened upon a temporary loss of the internet connection. Running the command anew continued fetching/downloading just fine.

Seems to be the case, yes. Closing.

Best,
--
Josselin Poiret
-----BEGIN PGP SIGNATURE-----

iQHEBAEBCgAuFiEEOSSM2EHGPMM23K8vUF5AuRYXGooFAmUAVTUQHGRldkBqcG9p
cmV0Lnh5egAKCRBQXkC5Fhcaiu5yC/0YqJJtxPUtJoVY1txSU0L9nO+2LBkMiiIS
NH+bhv0AXt9f8A7LGASUp/lgEuTaYNkd0yDVh76fwxTQ/+gUUCZj+TFEXqfwWuDF
xtx7dNpcaH2rTLG0Ld/VkhajAe11dbYcNMp2LXDu1XzFAa+bZlUthrxoGB0mKL4D
RgFNyDDhjw8INUuKVF/2q5XU2rHeXLl1UhrQqkOTfjr1TeNYemcrNr5gLbLpXQ/2
NdgPsX8E/nn6dYarUhqtPmED/MUIKER8qkN2xvWhrQcpkEH+5k+cYyL9fCyJgIPe
A8fNwQaN+vId0bQ/8obd53d7Q2Ngyuyi115LQ4CVJUB1qE5/jpLY11LI2uI3O1nn
x1njI1NL+Df3N3iviA3sAQXz8Ln9456c9PBCyzGkyUxDRqVWxkwwCLLZzI273Q2M
t2nTF16nXnPz6iAJeq9nA24LkBxVdl+r+zaTN+GLpJ1u5GBOhhVUonAwna9rZH5h
0EEbmPXm4sNnDCaHOn639lj6t0sXefk=
=xZka
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 65804@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 65804
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch