(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
This avoids an issue where rottlog will delete the entire /tmp directory
if gawk is not installed.
* gnu/packages/admin.scm (rottlog): Add gawk input, also update the
patch-paths build phase for awk invocations.
---
gnu/packages/admin.scm | 8 ++++++--
1 file changed, 6 insertions(+), 2 deletions(-)
Toggle diff (28 lines)
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 604cd70c02..ea437e9f26 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -1931,7 +1931,11 @@ (define-public rottlog
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "rc/rc"
(("/usr/sbin/sendmail")
- (search-input-file inputs "/bin/mail")))))
+ (search-input-file inputs "/bin/mail")))
+ (with-fluids ((%default-port-encoding "ISO-8859-1"))
+ (substitute* "src/rottlog"
+ (("awk")
+ (search-input-file inputs "/bin/awk"))))))
(add-after 'build 'set-packdir
(lambda _
;; Set a default location for archived logs.
@@ -1950,7 +1954,7 @@ (define-public rottlog
(lambda _
(invoke "make" "install-info"))))))
(native-inputs (list autoconf automake texinfo util-linux)) ; for 'cal'
- (inputs (list coreutils mailutils))
+ (inputs (list coreutils gawk mailutils))
(home-page "https://www.gnu.org/software/rottlog/")
(synopsis "Log rotation and management")
(description
base-commit: e365c26a34fa485f9af46538fcea128db681c33d
--
2.41.0