[PATCH] gnu: rottlog: Add gawk as an input.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Skyler
Owner
unassigned
Submitted by
Skyler
Severity
normal
Merged with
S
S
Skyler wrote on 7 Sep 2023 04:01
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
3IilDZKPeNEORKD6Akuetp_2bSYOEVBciL75gWUJdaGyfMJd440tbB6yd0DeZBF6yPGQgQnORVb0OPdqJChgRYXJ4oUSdXAO3u7hOOXhyP4=@protonmail.com
This avoids an issue where rottlog will delete the entire /tmp directory
if gawk is not installed.

* gnu/packages/admin.scm (rottlog): Add gawk input, also update the
patch-paths build phase for awk invocations.
---
gnu/packages/admin.scm | 8 ++++++--
1 file changed, 6 insertions(+), 2 deletions(-)

Toggle diff (28 lines)
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 604cd70c02..ea437e9f26 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -1931,7 +1931,11 @@ (define-public rottlog
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "rc/rc"
(("/usr/sbin/sendmail")
- (search-input-file inputs "/bin/mail")))))
+ (search-input-file inputs "/bin/mail")))
+ (with-fluids ((%default-port-encoding "ISO-8859-1"))
+ (substitute* "src/rottlog"
+ (("awk")
+ (search-input-file inputs "/bin/awk"))))))
(add-after 'build 'set-packdir
(lambda _
;; Set a default location for archived logs.
@@ -1950,7 +1954,7 @@ (define-public rottlog
(lambda _
(invoke "make" "install-info"))))))
(native-inputs (list autoconf automake texinfo util-linux)) ; for 'cal'
- (inputs (list coreutils mailutils))
+ (inputs (list coreutils gawk mailutils))
(home-page "https://www.gnu.org/software/rottlog/")
(synopsis "Log rotation and management")
(description

base-commit: e365c26a34fa485f9af46538fcea128db681c33d
--
2.41.0
Attachment: file
S
L
L
Ludovic Courtès wrote on 14 Sep 2023 16:48
control message for bug #65792
(address . control@debbugs.gnu.org)
87il8cajzt.fsf@gnu.org
merge 65792 65792
quit
L
L
Ludovic Courtès wrote on 14 Sep 2023 16:48
(address . control@debbugs.gnu.org)
87h6nwajzl.fsf@gnu.org
merge 65792 65793
quit
L
L
Ludovic Courtès wrote on 14 Sep 2023 16:54
Re: bug#65792: [PATCH] gnu: rottlog: Add gawk as an input.
(name . Skyler)(address . skyvine@protonmail.com)(address . 65792-done@debbugs.gnu.org)
87a5toajqp.fsf@gnu.org
Hi,

Skyler <skyvine@protonmail.com> skribis:

Toggle quote (6 lines)
> This avoids an issue where rottlog will delete the entire /tmp directory
> if gawk is not installed.
>
> * gnu/packages/admin.scm (rottlog): Add gawk input, also update the
> patch-paths build phase for awk invocations.

Applied, thank you, and thanks for explaining!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 65792@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 65792
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch