[PATCH] gnu: Add woeusb.

  • Open
  • quality assurance status badge
Details
2 participants
  • Adam Kandur
  • Christopher Baines
Owner
unassigned
Submitted by
Adam Kandur
Severity
normal
A
A
Adam Kandur wrote on 6 Sep 2023 15:01
(address . guix-patches@gnu.org)(name . Adam Kandur)(address . adam.mohidin.kandur@gmail.com)
20230906130103.3121-1-adam.mohidin.kandur@gmail.com
* gnu/packages/admin.scm (woeusb): New variable.
---
gnu/packages/admin.scm | 65 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 65 insertions(+)

Toggle diff (78 lines)
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 604cd70..6b971e8 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -2388,6 +2388,71 @@ (define-public wakelan
network, which causes enabled computers to power on.")
(license license:gpl2+)))
+(define-public woeusb
+ (let ((revision "0")
+ ;; named branch is outdated
+ (commit "34b400d99d3c4089f487e1d4f7d71970b2d4429e"))
+ (package
+ (name "woeusb")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/WoeUSB/WoeUSB.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "05ghja2rpn4kqak9yll398na54dscsfnm3z5f2pi54lan98wzimh"))))
+ (build-system trivial-build-system)
+ (inputs
+ (list ntfs-3g grub ncurses parted coreutils util-linux wimlib))
+ (arguments
+ `(#:modules ((guix build utils))
+ #:builder
+ (begin
+ (use-modules (guix build utils))
+ ;; copy source
+ (copy-recursively (assoc-ref %build-inputs "source") ".")
+ ;; patch source
+ (substitute* "sbin/woeusb"
+ (("tput sgr0") (string-append (assoc-ref %build-inputs "ncurses")
+ "/bin/tput"
+ " sgr0"))
+ (("parted --script")
+ (string-append (assoc-ref %build-inputs "parted")
+ "/sbin/parted --script"))
+ (("parted \\\\")
+ (string-append (assoc-ref %build-inputs "parted")
+ "/sbin/parted \\"))
+ (("grub-install") (string-append (assoc-ref %build-inputs "grub")
+ "/sbin/grub-install"))
+ (("command -v mkntfs") (string-append
+ "command -v "
+ (assoc-ref %build-inputs "ntfs-3g")
+ "/sbin/mkntfs"))
+ (("command_mkntfs_ref=mkntfs") (string-append
+ "command_mkntfs_ref="
+ (assoc-ref %build-inputs "ntfs-3g")
+ "/sbin/mkntfs"))
+ (("readlink \\\\") (string-append
+ (assoc-ref %build-inputs "coreutils")
+ "/bin/readlink \\"))
+ (("wimlib-imagex") (string-append
+ (assoc-ref %build-inputs "wimlib")
+ "/bin/wimlib-imagex"))
+ ;; could not find partprobe package
+ ;; as i see this command never used in the program
+ (("partprobe \\\\") "\\"))
+ ;; install phase
+ (install-file "sbin/woeusb" (string-append %output "/bin"))
+ #t)))
+ (home-page "https://github.com/WoeUSB/WoeUSB")
+ (synopsis "A Microsoft Windows® USB installation media preparer for GNU+Linux")
+ (description "Very usefull package for anyone who wants to make a bootable Windows® USB stick
+using free and open source operating system.")
+ (license license:gpl3+))))
+
(define-public dmidecode
(package
(name "dmidecode")
--
2.41.0
C
C
Christopher Baines wrote on 20 Oct 2023 11:42
(name . Adam Kandur)(address . adam.mohidin.kandur@gmail.com)
87lebx4oj6.fsf@cbaines.net
Adam Kandur <adam.mohidin.kandur@gmail.com> writes:

Toggle quote (82 lines)
> * gnu/packages/admin.scm (woeusb): New variable.
> ---
> gnu/packages/admin.scm | 65 ++++++++++++++++++++++++++++++++++++++++++
> 1 file changed, 65 insertions(+)
>
> diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
> index 604cd70..6b971e8 100644
> --- a/gnu/packages/admin.scm
> +++ b/gnu/packages/admin.scm
> @@ -2388,6 +2388,71 @@ (define-public wakelan
> network, which causes enabled computers to power on.")
> (license license:gpl2+)))
>
> +(define-public woeusb
> + (let ((revision "0")
> + ;; named branch is outdated
> + (commit "34b400d99d3c4089f487e1d4f7d71970b2d4429e"))
> + (package
> + (name "woeusb")
> + (version (git-version "0.0.0" revision commit))
> + (source
> + (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/WoeUSB/WoeUSB.git")
> + (commit commit)))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32 "05ghja2rpn4kqak9yll398na54dscsfnm3z5f2pi54lan98wzimh"))))
> + (build-system trivial-build-system)
> + (inputs
> + (list ntfs-3g grub ncurses parted coreutils util-linux wimlib))
> + (arguments
> + `(#:modules ((guix build utils))
> + #:builder
> + (begin
> + (use-modules (guix build utils))
> + ;; copy source
> + (copy-recursively (assoc-ref %build-inputs "source") ".")
> + ;; patch source
> + (substitute* "sbin/woeusb"
> + (("tput sgr0") (string-append (assoc-ref %build-inputs "ncurses")
> + "/bin/tput"
> + " sgr0"))
> + (("parted --script")
> + (string-append (assoc-ref %build-inputs "parted")
> + "/sbin/parted --script"))
> + (("parted \\\\")
> + (string-append (assoc-ref %build-inputs "parted")
> + "/sbin/parted \\"))
> + (("grub-install") (string-append (assoc-ref %build-inputs "grub")
> + "/sbin/grub-install"))
> + (("command -v mkntfs") (string-append
> + "command -v "
> + (assoc-ref %build-inputs "ntfs-3g")
> + "/sbin/mkntfs"))
> + (("command_mkntfs_ref=mkntfs") (string-append
> + "command_mkntfs_ref="
> + (assoc-ref %build-inputs "ntfs-3g")
> + "/sbin/mkntfs"))
> + (("readlink \\\\") (string-append
> + (assoc-ref %build-inputs "coreutils")
> + "/bin/readlink \\"))
> + (("wimlib-imagex") (string-append
> + (assoc-ref %build-inputs "wimlib")
> + "/bin/wimlib-imagex"))
> + ;; could not find partprobe package
> + ;; as i see this command never used in the program
> + (("partprobe \\\\") "\\"))
> + ;; install phase
> + (install-file "sbin/woeusb" (string-append %output "/bin"))
> + #t)))
> + (home-page "https://github.com/WoeUSB/WoeUSB")
> + (synopsis "A Microsoft Windows® USB installation media preparer for GNU+Linux")
> + (description "Very usefull package for anyone who wants to make a bootable Windows® USB stick
> +using free and open source operating system.")
> + (license license:gpl3+))))
> +
> (define-public dmidecode
> (package
> (name "dmidecode")

Hi Adam,

Does this build for you locally? According to QA, grub is undefined, so
maybe there's an import missing.

Thanks,

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmUyS81fFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XfusRAAjCt8VA5TN7Vd2E8MHzF3b3zQ1cSw1hKL
rFRmK3ecCYpshS0s6xuOSKCSjpeGfPBkK/kzCBAlsOnS8TkejmZI3YZI1CQ3AAxX
B6DGs8ZFU+5hqe/Sa9M03txk3iF2KqPQVfYtvKi/9ZkXBAWg3pspsLozw0Vsopcm
vH0NESpXbEjq9GH35h9zNaMmNq8zyU9GAZhjnd8koXhSORa/YusiykLU1jJviaCr
yjETwsYPQysrWDYk4eegRbXNYZsXKzPryujvmpNYI/ONprzkC/6gs3HvdSeVFxfC
fKya9pzuozqEkhNzrZtOvaC6KobT1Yt+JvkFxXRuKn3zyEgtm1MT9LVEgfUsXSW1
e+QWnv7dcrSs1cpVAqKrEnMvthAtoMegESTF6IqbF/1GlyDiLdxnz/Tc6T4OyPDP
2OfW6JlXnZqkzskuEYeE3iyIkZNkfSZJi6rp4YmOtqYPSIs/uN0BlaJlDGgZA2Vz
BZgTxkJBY00Hru/26vQJ/UaEWsTs24OcHcQaxQchUa+2LWshsvFv1XNj/wEUqSbI
JWEk5fP3BiWy6W0gbILM3KfibFHZsJg5amx2OoKJaoSSQu7OZ1kIMFiWz02hqQ5I
hvagkXB2XS82xFlGvVFAvx0paiBgPnd0Ey5OWNqgZ6zDPxcZyq2l5XEyR+mjaQIc
w7tsoWEPWis=
=Sujh
-----END PGP SIGNATURE-----

A
(name . Christopher Baines)(address . mail@cbaines.net)(address . 65784@debbugs.gnu.org)
CAPCy7tUfd3aWdA4w0_DHGL+OXM+sZqkUbAtj6N6gc=0uAD+00Q@mail.gmail.com
yeah, my bad
will send a new one


On Fri, 20 Oct 2023 at 12:43, Christopher Baines <mail@cbaines.net> wrote:
Toggle quote (94 lines)
>
>
> Adam Kandur <adam.mohidin.kandur@gmail.com> writes:
>
> > * gnu/packages/admin.scm (woeusb): New variable.
> > ---
> > gnu/packages/admin.scm | 65 ++++++++++++++++++++++++++++++++++++++++++
> > 1 file changed, 65 insertions(+)
> >
> > diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
> > index 604cd70..6b971e8 100644
> > --- a/gnu/packages/admin.scm
> > +++ b/gnu/packages/admin.scm
> > @@ -2388,6 +2388,71 @@ (define-public wakelan
> > network, which causes enabled computers to power on.")
> > (license license:gpl2+)))
> >
> > +(define-public woeusb
> > + (let ((revision "0")
> > + ;; named branch is outdated
> > + (commit "34b400d99d3c4089f487e1d4f7d71970b2d4429e"))
> > + (package
> > + (name "woeusb")
> > + (version (git-version "0.0.0" revision commit))
> > + (source
> > + (origin
> > + (method git-fetch)
> > + (uri (git-reference
> > + (url "https://github.com/WoeUSB/WoeUSB.git")
> > + (commit commit)))
> > + (file-name (git-file-name name version))
> > + (sha256
> > + (base32 "05ghja2rpn4kqak9yll398na54dscsfnm3z5f2pi54lan98wzimh"))))
> > + (build-system trivial-build-system)
> > + (inputs
> > + (list ntfs-3g grub ncurses parted coreutils util-linux wimlib))
> > + (arguments
> > + `(#:modules ((guix build utils))
> > + #:builder
> > + (begin
> > + (use-modules (guix build utils))
> > + ;; copy source
> > + (copy-recursively (assoc-ref %build-inputs "source") ".")
> > + ;; patch source
> > + (substitute* "sbin/woeusb"
> > + (("tput sgr0") (string-append (assoc-ref %build-inputs "ncurses")
> > + "/bin/tput"
> > + " sgr0"))
> > + (("parted --script")
> > + (string-append (assoc-ref %build-inputs "parted")
> > + "/sbin/parted --script"))
> > + (("parted \\\\")
> > + (string-append (assoc-ref %build-inputs "parted")
> > + "/sbin/parted \\"))
> > + (("grub-install") (string-append (assoc-ref %build-inputs "grub")
> > + "/sbin/grub-install"))
> > + (("command -v mkntfs") (string-append
> > + "command -v "
> > + (assoc-ref %build-inputs "ntfs-3g")
> > + "/sbin/mkntfs"))
> > + (("command_mkntfs_ref=mkntfs") (string-append
> > + "command_mkntfs_ref="
> > + (assoc-ref %build-inputs "ntfs-3g")
> > + "/sbin/mkntfs"))
> > + (("readlink \\\\") (string-append
> > + (assoc-ref %build-inputs "coreutils")
> > + "/bin/readlink \\"))
> > + (("wimlib-imagex") (string-append
> > + (assoc-ref %build-inputs "wimlib")
> > + "/bin/wimlib-imagex"))
> > + ;; could not find partprobe package
> > + ;; as i see this command never used in the program
> > + (("partprobe \\\\") "\\"))
> > + ;; install phase
> > + (install-file "sbin/woeusb" (string-append %output "/bin"))
> > + #t)))
> > + (home-page "https://github.com/WoeUSB/WoeUSB")
> > + (synopsis "A Microsoft Windows® USB installation media preparer for GNU+Linux")
> > + (description "Very usefull package for anyone who wants to make a bootable Windows® USB stick
> > +using free and open source operating system.")
> > + (license license:gpl3+))))
> > +
> > (define-public dmidecode
> > (package
> > (name "dmidecode")
>
> Hi Adam,
>
> Does this build for you locally? According to QA, grub is undefined, so
> maybe there's an import missing.
>
> Thanks,
>
> Chris
A
A
Adam Kandur wrote on 26 Oct 2023 02:19
[PATCH] gnu: Add woeusb.
(address . 65784@debbugs.gnu.org)(name . Adam Kandur)(address . adam.mohidin.kandur@gmail.com)
20231026001939.13847-1-adam.mohidin.kandur@gmail.com
* gnu/packages/admin.scm (woeusb): New variable.
---
gnu/packages/admin.scm | 68 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 68 insertions(+)

Toggle diff (99 lines)
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 8f72b0e..2c35562 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -102,10 +102,12 @@ (define-module (gnu packages admin)
#:use-module (gnu packages algebra)
#:use-module (gnu packages attr)
#:use-module (gnu packages autotools)
+ #:use-module (gnu packages backup)
#:use-module (gnu packages base)
#:use-module (gnu packages bash)
#:use-module (gnu packages bison)
#:use-module (gnu packages boost)
+ #:use-module (gnu packages bootloaders)
#:use-module (gnu packages c)
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
@@ -116,6 +118,7 @@ (define-module (gnu packages admin)
#:use-module (gnu packages curl)
#:use-module (gnu packages cyrus-sasl)
#:use-module (gnu packages datastructures)
+ #:use-module (gnu packages disk)
#:use-module (gnu packages dns)
#:use-module (gnu packages elf)
#:use-module (gnu packages file)
@@ -2437,6 +2440,71 @@ (define-public wakelan
network, which causes enabled computers to power on.")
(license license:gpl2+)))
+(define-public woeusb
+ (let ((revision "0")
+ ;; named branch is outdated
+ (commit "34b400d99d3c4089f487e1d4f7d71970b2d4429e"))
+ (package
+ (name "woeusb")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/WoeUSB/WoeUSB.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "05ghja2rpn4kqak9yll398na54dscsfnm3z5f2pi54lan98wzimh"))))
+ (build-system trivial-build-system)
+ (inputs
+ (list ntfs-3g grub ncurses parted coreutils util-linux wimlib))
+ (arguments
+ `(#:modules ((guix build utils))
+ #:builder
+ (begin
+ (use-modules (guix build utils))
+ ;; copy source
+ (copy-recursively (assoc-ref %build-inputs "source") ".")
+ ;; patch source
+ (substitute* "sbin/woeusb"
+ (("tput sgr0") (string-append (assoc-ref %build-inputs "ncurses")
+ "/bin/tput"
+ " sgr0"))
+ (("parted --script")
+ (string-append (assoc-ref %build-inputs "parted")
+ "/sbin/parted --script"))
+ (("parted \\\\")
+ (string-append (assoc-ref %build-inputs "parted")
+ "/sbin/parted \\"))
+ (("grub-install") (string-append (assoc-ref %build-inputs "grub")
+ "/sbin/grub-install"))
+ (("command -v mkntfs") (string-append
+ "command -v "
+ (assoc-ref %build-inputs "ntfs-3g")
+ "/sbin/mkntfs"))
+ (("command_mkntfs_ref=mkntfs") (string-append
+ "command_mkntfs_ref="
+ (assoc-ref %build-inputs "ntfs-3g")
+ "/sbin/mkntfs"))
+ (("readlink \\\\") (string-append
+ (assoc-ref %build-inputs "coreutils")
+ "/bin/readlink \\"))
+ (("wimlib-imagex") (string-append
+ (assoc-ref %build-inputs "wimlib")
+ "/bin/wimlib-imagex"))
+ ;; could not find partprobe package
+ ;; as i see this command never used in the program
+ (("partprobe \\\\") "\\"))
+ ;; install phase
+ (install-file "sbin/woeusb" (string-append %output "/bin"))
+ #t)))
+ (home-page "https://github.com/WoeUSB/WoeUSB")
+ (synopsis "A Microsoft Windows® USB installation media preparer for GNU+Linux")
+ (description "Very usefull package for anyone who wants to make a bootable Windows® USB stick
+using free and open source operating system.")
+ (license license:gpl3+))))
+
(define-public dmidecode
(package
(name "dmidecode")
--
2.41.0
?