python updater clears inputs, leaves propagated-inputs empty

  • Open
  • quality assurance status badge
Details
2 participants
  • Maxim Cournoyer
  • Sergio Pastor Pérez
Owner
unassigned
Submitted by
Maxim Cournoyer
Severity
normal
M
M
Maxim Cournoyer wrote on 6 Sep 2023 07:15
(name . bug-guix)(address . bug-guix@gnu.org)
87tts77ugh.fsf@gmail.com
Hi,

I've had the Python updater produce this when attempting to update
fontmake:

gnu/packages/fontutils.scm:780:2: warning: fontmake: 'propagated-inputs'
field not found; leaving it unchanged

gnu/packages/fontutils.scm:780:2: warning: fontmake: expected
'propagated-inputs' value: (python-attrs python-fontmath
python-fonttools python-glyphslib python-ufo2ft python-ufolib2)

Toggle snippet (24 lines)
modified gnu/packages/fontutils.scm
@@ -779,16 +779,16 @@ (define-public psautohint-font-data
(define-public fontmake
(package
(name "fontmake")
- (version "3.4.0")
+ (version "3.7.1")
(source (origin
(method url-fetch)
(uri (pypi-uri "fontmake" version ".zip"))
(sha256
(base32
- "0fc5c9csjpy1aa4c03p7nvjgls5wjplhmmf42n0cmvrlh6cm7wl3"))))
+ "0ib7fvwgwazm7qfj4a3rkqkb40xfbj40rnvsmkvl2isg2ky3vg9m"))))
(build-system python-build-system)
- (inputs (list python-fontmath python-glyphslib))
- (native-inputs (list unzip python-setuptools-scm))
+ (inputs (list))
+ (native-inputs (list zip))
(home-page "https://github.com/googlefonts/fontmake")
(synopsis
"Compile fonts from sources (UFO, Glyphs) to binary (OpenType, TrueType)")

The choice of using inputs here was conscious, as it is a command, not a
library. Perhaps it could check if the name starts with 'python-' or
not? It's a bit 'magic', but it would help.

--
Thanks,
Maxim
S
S
Sergio Pastor Pérez wrote on 6 Sep 2023 19:18
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)
DU2P193MB21321D25B8E08DAC9C0DD4A5F3EFA@DU2P193MB2132.EURP193.PROD.OUTLOOK.COM
Hi,

I'm afraid you lost me here. Why is the `inputs' field empty? I don't
understand what you meand with the checking of 'python-'.

Keep in mind that I have very little experince with python packaging so
I'm may not understand you due to my lack of background.


Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:

Toggle quote (40 lines)
> Hi,
>
> I've had the Python updater produce this when attempting to update
> fontmake:
>
> gnu/packages/fontutils.scm:780:2: warning: fontmake: 'propagated-inputs'
> field not found; leaving it unchanged
>
> gnu/packages/fontutils.scm:780:2: warning: fontmake: expected
> 'propagated-inputs' value: (python-attrs python-fontmath
> python-fonttools python-glyphslib python-ufo2ft python-ufolib2)
>
> --8<---------------cut here---------------start------------->8---
> modified gnu/packages/fontutils.scm
> @@ -779,16 +779,16 @@ (define-public psautohint-font-data
> (define-public fontmake
> (package
> (name "fontmake")
> - (version "3.4.0")
> + (version "3.7.1")
> (source (origin
> (method url-fetch)
> (uri (pypi-uri "fontmake" version ".zip"))
> (sha256
> (base32
> - "0fc5c9csjpy1aa4c03p7nvjgls5wjplhmmf42n0cmvrlh6cm7wl3"))))
> + "0ib7fvwgwazm7qfj4a3rkqkb40xfbj40rnvsmkvl2isg2ky3vg9m"))))
> (build-system python-build-system)
> - (inputs (list python-fontmath python-glyphslib))
> - (native-inputs (list unzip python-setuptools-scm))
> + (inputs (list))
> + (native-inputs (list zip))
> (home-page "https://github.com/googlefonts/fontmake")
> (synopsis
> "Compile fonts from sources (UFO, Glyphs) to binary (OpenType, TrueType)")
> --8<---------------cut here---------------end--------------->8---
>
> The choice of using inputs here was conscious, as it is a command, not a
> library. Perhaps it could check if the name starts with 'python-' or
> not? It's a bit 'magic', but it would help.
M
M
Maxim Cournoyer wrote on 6 Sep 2023 20:38
(name . Sergio Pastor Pérez)(address . sergio.pastorperez@outlook.es)(address . 65774@debbugs.gnu.org)
87msxzqh99.fsf@gmail.com
Hi,

Sergio Pastor Pérez <sergio.pastorperez@outlook.es> writes:

Toggle quote (4 lines)
> Hi,
>
> I'm afraid you lost me here. Why is the `inputs' field empty?

I don't know! That's the current behavior of the Python updater, at
least when I ran it on fontmake (in our patches tracker at

Toggle quote (2 lines)
> understand what you meand with the checking of 'python-'.

I meant looking whether the package variable (usually also its name) is
prefixed by "python-" to differentiate between a library or a command.
It's not a very good heuristic/test, I'm afraid.

--
Thanks,
Maxim
?