(name . bug-guix)(address . bug-guix@gnu.org)
Hi,
I've had the Python updater produce this when attempting to update
fontmake:
gnu/packages/fontutils.scm:780:2: warning: fontmake: 'propagated-inputs'
field not found; leaving it unchanged
gnu/packages/fontutils.scm:780:2: warning: fontmake: expected
'propagated-inputs' value: (python-attrs python-fontmath
python-fonttools python-glyphslib python-ufo2ft python-ufolib2)
Toggle snippet (24 lines)
modified gnu/packages/fontutils.scm
@@ -779,16 +779,16 @@ (define-public psautohint-font-data
(define-public fontmake
(package
(name "fontmake")
- (version "3.4.0")
+ (version "3.7.1")
(source (origin
(method url-fetch)
(uri (pypi-uri "fontmake" version ".zip"))
(sha256
(base32
- "0fc5c9csjpy1aa4c03p7nvjgls5wjplhmmf42n0cmvrlh6cm7wl3"))))
+ "0ib7fvwgwazm7qfj4a3rkqkb40xfbj40rnvsmkvl2isg2ky3vg9m"))))
(build-system python-build-system)
- (inputs (list python-fontmath python-glyphslib))
- (native-inputs (list unzip python-setuptools-scm))
+ (inputs (list))
+ (native-inputs (list zip))
(home-page "https://github.com/googlefonts/fontmake")
(synopsis
"Compile fonts from sources (UFO, Glyphs) to binary (OpenType, TrueType)")
The choice of using inputs here was conscious, as it is a command, not a
library. Perhaps it could check if the name starts with 'python-' or
not? It's a bit 'magic', but it would help.
--
Thanks,
Maxim