html updater may fail when page has moved (guix refresh gambit-c)

  • Done
  • quality assurance status badge
Details
One participant
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Maxim Cournoyer
Severity
normal
M
M
Maxim Cournoyer wrote on 6 Sep 2023 06:16
(name . bug-guix)(address . bug-guix@gnu.org)
875y4o9bs1.fsf@gmail.com
Hi,

Attempting to 'guix refresh gambit-c' currently fails like:

Toggle snippet (41 lines)
./pre-inst-env guix refresh gambit-c
Backtrace:
In ice-9/eval.scm:
619:8 19 (_ #(#(#<directory (guile-user) 7f98520bfc80>)))
In guix/ui.scm:
2323:7 18 (run-guix . _)
2286:10 17 (run-guix-command _ . _)
In ice-9/boot-9.scm:
1752:10 16 (with-exception-handler _ _ #:unwind? _ # _)
1752:10 15 (with-exception-handler _ _ #:unwind? _ # _)
In guix/store.scm:
659:37 14 (thunk)
2168:25 13 (run-with-store #<store-connection 256.99 7f983bf81eb0> …)
In guix/scripts/refresh.scm:
632:14 12 (_ _)
In srfi/srfi-1.scm:
634:9 11 (for-each #<procedure 7f983740aab0 at guix/scripts/ref…> …)
In guix/scripts/refresh.scm:
402:10 10 (check-for-package-update #<<update-spec> package: #<p…> …)
In srfi/srfi-1.scm:
858:15 9 (any1 #<procedure 7f983740aa80 at guix/upstream.scm:25…> …)
In guix/import/utils.scm:
131:4 8 (call-with-networking-exception-handler _)
In ice-9/boot-9.scm:
1752:10 7 (with-exception-handler _ _ #:unwind? _ # _)
In guix/gnu-maintenance.scm:
643:18 6 (import-html-release _ _ #:rewrite-url? _ #:version _ # …)
568:6 5 (rewrite-url _ "4.9.5" #:to-version _)
In srfi/srfi-1.scm:
460:18 4 (fold #<procedure 7f9837412d40 at guix/gnu-maintenance…> …)
In guix/gnu-maintenance.scm:
603:25 3 (_ _ _)
In ice-9/boot-9.scm:
1685:16 2 (raise-exception _ #:continuable? _)
1685:16 1 (raise-exception _ #:continuable? _)
1685:16 0 (raise-exception _ #:continuable? _)

ice-9/boot-9.scm:1685:16: In procedure raise-exception:
no candidates found in rewrite-url

That's because http-fetch/cached doesn't following redirection:

Toggle snippet (10 lines)
$ curl http://www.gambitscheme.org/4.9.4
<html>
<head><title>301 Moved Permanently</title></head>
<body>
<center><h1>301 Moved Permanently</h1></center>
<hr><center>nginx</center>
</body>
</html>

which means the page is reachable but doesn't contain the expected
content.

--
Thanks,
Maxim
M
M
Maxim Cournoyer wrote on 6 Sep 2023 06:38
(address . 65773-done@debbugs.gnu.org)
87zg1z9ar7.fsf@gmail.com
Hi,

Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:

Toggle quote (44 lines)
> Hi,
>
> Attempting to 'guix refresh gambit-c' currently fails like:
>
> ./pre-inst-env guix refresh gambit-c
> Backtrace:
> In ice-9/eval.scm:
> 619:8 19 (_ #(#(#<directory (guile-user) 7f98520bfc80>)))
> In guix/ui.scm:
> 2323:7 18 (run-guix . _)
> 2286:10 17 (run-guix-command _ . _)
> In ice-9/boot-9.scm:
> 1752:10 16 (with-exception-handler _ _ #:unwind? _ # _)
> 1752:10 15 (with-exception-handler _ _ #:unwind? _ # _)
> In guix/store.scm:
> 659:37 14 (thunk)
> 2168:25 13 (run-with-store #<store-connection 256.99 7f983bf81eb0> …)
> In guix/scripts/refresh.scm:
> 632:14 12 (_ _)
> In srfi/srfi-1.scm:
> 634:9 11 (for-each #<procedure 7f983740aab0 at guix/scripts/ref…> …)
> In guix/scripts/refresh.scm:
> 402:10 10 (check-for-package-update #<<update-spec> package: #<p…> …)
> In srfi/srfi-1.scm:
> 858:15 9 (any1 #<procedure 7f983740aa80 at guix/upstream.scm:25…> …)
> In guix/import/utils.scm:
> 131:4 8 (call-with-networking-exception-handler _)
> In ice-9/boot-9.scm:
> 1752:10 7 (with-exception-handler _ _ #:unwind? _ # _)
> In guix/gnu-maintenance.scm:
> 643:18 6 (import-html-release _ _ #:rewrite-url? _ #:version _ # …)
> 568:6 5 (rewrite-url _ "4.9.5" #:to-version _)
> In srfi/srfi-1.scm:
> 460:18 4 (fold #<procedure 7f9837412d40 at guix/gnu-maintenance…> …)
> In guix/gnu-maintenance.scm:
> 603:25 3 (_ _ _)
> In ice-9/boot-9.scm:
> 1685:16 2 (raise-exception _ #:continuable? _)
> 1685:16 1 (raise-exception _ #:continuable? _)
> 1685:16 0 (raise-exception _ #:continuable? _)
>
> ice-9/boot-9.scm:1685:16: In procedure raise-exception:
> no candidates found in rewrite-url

Mitigated with 589384102f ("gnu-maintenance: Do not error when there are
no candidates.").

--
Thanks,
Maxim
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 65773@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 65773
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch