[PATCH 0/2] gnu: python-qtsass: Update to 0.4.0, fix build.

  • Done
  • quality assurance status badge
Details
3 participants
  • Christopher Baines
  • Maxim Cournoyer
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal

Debbugs page

Sharlatan Hellseher wrote 2 years ago
(address . guix-patches@gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
cover.1693849464.git.sharlatanus@gmail.com
Hi Guix!

As I investigated the circular dependency between (gnu packages python-xyz)
and (gnu packages astronomy), I discovered several packages that were failing
to build and had only a few dependencies. To resolve this issue, I have
created a patch set that includes minor tweaks and updates.

Sharlatan Hellseher (2):
gnu: python-libsass: Update to 0.22.0.
gnu: python-qtsass: Update to 0.4.0, fix build.

gnu/packages/python-xyz.scm | 18 +++++++++++++-----
1 file changed, 13 insertions(+), 5 deletions(-)


base-commit: 710d9050524213a83e4ce9efe9765d7fbc233839
--
2.40.1
Sharlatan Hellseher wrote 2 years ago
[PATCH 1/2] gnu: python-libsass: Update to 0.22.0.
(address . 65743@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
08faecba8e89f6839eece3160180b46f52202e36.1693849464.git.sharlatanus@gmail.com
* gnu/packages/python-xyz.scm (python-libsass): Update to 0.22.0.
[phases]: Add new phase 'silent-failing-tests and disable 2 failing
tests to complete build.
---
gnu/packages/python-xyz.scm | 12 ++++++++++--
1 file changed, 10 insertions(+), 2 deletions(-)

Toggle diff (39 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a950de3b46..5410f294d5 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -14359,7 +14359,7 @@ (define-public python-idna
(define-public python-libsass
(package
(name "python-libsass")
- (version "0.20.1")
+ (version "0.22.0")
(source
(origin
;; PyPI tarball is missing some test files.
@@ -14369,7 +14369,7 @@ (define-public python-libsass
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "1r0kgl7i6nnhgjl44sjw57k08gh2qr7l8slqih550dyxbf1akbxh"))))
+ (base32 "0j6c7jb1bnpmz76gs5za41qwgrs7v1yd1jkgvsy5ql6dg2ph9vp4"))))
(build-system python-build-system)
(arguments
'(#:phases
@@ -14377,6 +14377,14 @@ (define-public python-libsass
;; Use Guix package of libsass instead of compiling from a checkout.
(add-before 'build 'set-libsass
(lambda _ (setenv "SYSTEM_SASS" "indeed")))
+ ;; XXX: Silent 2 failing test, check why they are failing.
+ (add-before 'check 'silent-failing-tests
+ (lambda _
+ (substitute* "sasstests.py"
+ (("def test_build_one")
+ "def __off_test_build_one")
+ (("def test_stack_trace_formatting")
+ "def __off_test_stack_trace_formatting"))))
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
(when tests?
--
2.40.1
Sharlatan Hellseher wrote 2 years ago
[PATCH 2/2] gnu: python-qtsass: Update to 0.4.0, fix build.
(address . 65743@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
e96b1b6dfe811bf406d2e4ed6ea7b55efd77362a.1693849464.git.sharlatanus@gmail.com
* gnu/packages/python-xyz.scm (python-qtsass): Update to 0.4.0, fix
build.
[native-inputs]: Add python-flaky.
---
gnu/packages/python-xyz.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (33 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5410f294d5..16bb186a29 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -30006,7 +30006,7 @@ (define-public python-helper
(define-public python-qtsass
(package
(name "python-qtsass")
- (version "0.3.0")
+ (version "0.4.0")
(source
(origin
;; There are no tests in the PyPI tarball.
@@ -30016,7 +30016,7 @@ (define-public python-qtsass
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "09s04aa14d8jqbh71clrb5y7vcmkxlp94mwmvzrkxahry3bk03cb"))))
+ (base32 "1skdihfby2f41zxgwa5zv44vdxjrw301rh88rjmzj4xbdlix6cig"))))
(build-system python-build-system)
(arguments
`(#:test-target "pytest"
@@ -30028,7 +30028,7 @@ (define-public python-qtsass
(for-each make-file-writable (find-files "."))
#t)))))
(native-inputs
- (list python-pytest python-pytest-cov python-pytest-runner))
+ (list python-flaky python-pytest python-pytest-cov python-pytest-runner))
(propagated-inputs
(list python-libsass))
(home-page "https://github.com/spyder-ide/qtsass")
--
2.40.1
Maxim Cournoyer wrote 2 years ago
Re: bug#65743: [PATCH 0/2] gnu: python-qtsass: Update to 0.4.0, fix build.
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
87sf7slpt0.fsf_-_@gmail.com
Hi Sharlatan,

Sharlatan Hellseher <sharlatanus@gmail.com> writes:

Toggle quote (42 lines)
> * gnu/packages/python-xyz.scm (python-libsass): Update to 0.22.0.
> [phases]: Add new phase 'silent-failing-tests and disable 2 failing
> tests to complete build.
> ---
> gnu/packages/python-xyz.scm | 12 ++++++++++--
> 1 file changed, 10 insertions(+), 2 deletions(-)
>
> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
> index a950de3b46..5410f294d5 100644
> --- a/gnu/packages/python-xyz.scm
> +++ b/gnu/packages/python-xyz.scm
> @@ -14359,7 +14359,7 @@ (define-public python-idna
> (define-public python-libsass
> (package
> (name "python-libsass")
> - (version "0.20.1")
> + (version "0.22.0")
> (source
> (origin
> ;; PyPI tarball is missing some test files.
> @@ -14369,7 +14369,7 @@ (define-public python-libsass
> (commit version)))
> (file-name (git-file-name name version))
> (sha256
> - (base32 "1r0kgl7i6nnhgjl44sjw57k08gh2qr7l8slqih550dyxbf1akbxh"))))
> + (base32 "0j6c7jb1bnpmz76gs5za41qwgrs7v1yd1jkgvsy5ql6dg2ph9vp4"))))
> (build-system python-build-system)
> (arguments
> '(#:phases
> @@ -14377,6 +14377,14 @@ (define-public python-libsass
> ;; Use Guix package of libsass instead of compiling from a checkout.
> (add-before 'build 'set-libsass
> (lambda _ (setenv "SYSTEM_SASS" "indeed")))
> + ;; XXX: Silent 2 failing test, check why they are failing.
> + (add-before 'check 'silent-failing-tests
> + (lambda _
> + (substitute* "sasstests.py"
> + (("def test_build_one")
> + "def __off_test_build_one")
> + (("def test_stack_trace_formatting")
> + "def __off_test_stack_trace_formatting"))))

In my experience, it's nice to do a minimal investigation up-front and
report upstream; otherwise odds are that it will never happen :-).

--
Thanks,
Maxim
Sharlatan Hellseher wrote 2 years ago
[PATCH v2 1/2] gnu: python-libsass: Update to 0.22.0.
(address . 65743@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
8af02a1d9b7324d2f3c1dcb106c709114902b7e8.1693952609.git.sharlatanus@gmail.com
* gnu/packages/python-xyz.scm (python-libsass): Update to 0.22.0.
[phases]: Add new phase 'silent-failing-tests and disable 2 failing
tests to complete build.
---
gnu/packages/python-xyz.scm | 15 +++++++++++++--
1 file changed, 13 insertions(+), 2 deletions(-)

Toggle diff (42 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a950de3b46..cdf5ee6293 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -14359,7 +14359,7 @@ (define-public python-idna
(define-public python-libsass
(package
(name "python-libsass")
- (version "0.20.1")
+ (version "0.22.0")
(source
(origin
;; PyPI tarball is missing some test files.
@@ -14369,7 +14369,7 @@ (define-public python-libsass
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "1r0kgl7i6nnhgjl44sjw57k08gh2qr7l8slqih550dyxbf1akbxh"))))
+ (base32 "0j6c7jb1bnpmz76gs5za41qwgrs7v1yd1jkgvsy5ql6dg2ph9vp4"))))
(build-system python-build-system)
(arguments
'(#:phases
@@ -14377,6 +14377,17 @@ (define-public python-libsass
;; Use Guix package of libsass instead of compiling from a checkout.
(add-before 'build 'set-libsass
(lambda _ (setenv "SYSTEM_SASS" "indeed")))
+ ;; XXX: Silent 2 failing tests, reported to upstream (closed), see
+ ;; https://github.com/sass/libsass-python/issues/440. It passed with
+ ;; libsass@3.6.5 which requires rebuild the world (1200+ packages),
+ ;; remove when v3.6.5 is available.
+ (add-before 'check 'silent-failing-tests
+ (lambda _
+ (substitute* "sasstests.py"
+ (("def test_build_one")
+ "def __off_test_build_one")
+ (("def test_stack_trace_formatting")
+ "def __off_test_stack_trace_formatting"))))
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
(when tests?
--
2.41.0
Sharlatan Hellseher wrote 2 years ago
[PATCH v2 2/2] gnu: python-qtsass: Update to 0.4.0, fix build.
(address . 65743@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
bba774d581b9485bb6e071a81452fdadc0dab444.1693952609.git.sharlatanus@gmail.com
* gnu/packages/python-xyz.scm (python-qtsass): Update to 0.4.0, fix
build.
[native-inputs]: Add python-flaky.
---
gnu/packages/python-xyz.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (33 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index cdf5ee6293..1d273bbb4d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -30009,7 +30009,7 @@ (define-public python-helper
(define-public python-qtsass
(package
(name "python-qtsass")
- (version "0.3.0")
+ (version "0.4.0")
(source
(origin
;; There are no tests in the PyPI tarball.
@@ -30019,7 +30019,7 @@ (define-public python-qtsass
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "09s04aa14d8jqbh71clrb5y7vcmkxlp94mwmvzrkxahry3bk03cb"))))
+ (base32 "1skdihfby2f41zxgwa5zv44vdxjrw301rh88rjmzj4xbdlix6cig"))))
(build-system python-build-system)
(arguments
`(#:test-target "pytest"
@@ -30031,7 +30031,7 @@ (define-public python-qtsass
(for-each make-file-writable (find-files "."))
#t)))))
(native-inputs
- (list python-pytest python-pytest-cov python-pytest-runner))
+ (list python-flaky python-pytest python-pytest-cov python-pytest-runner))
(propagated-inputs
(list python-libsass))
(home-page "https://github.com/spyder-ide/qtsass")
--
2.41.0
Christopher Baines wrote 1 years ago
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
87bke6v4r5.fsf@cbaines.net
Sharlatan Hellseher <sharlatanus@gmail.com> writes:

Toggle quote (7 lines)
> * gnu/packages/python-xyz.scm (python-qtsass): Update to 0.4.0, fix
> build.
> [native-inputs]: Add python-flaky.
> ---
> gnu/packages/python-xyz.scm | 6 +++---
> 1 file changed, 3 insertions(+), 3 deletions(-)

Thanks, I've pushed both of these patches to master as
7f150a18957daddb53caf11e23eb12122198d65c.

I tweaked the commit message in the first one just to mention the update
in the first line, then the previously failing tests later.

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmUBdy5fFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XevNA/8C034rqWbKSt9WML3OuM1/CvFy8ohyll6
jWG8QSxchSFOC6Yy/NR9QXfSpOejUzZMoDugH1GOdvcC93jfQw0mqvomBO1Aw323
XfGym65OMJHOSvlnePvn2y2/+tDIsgRSmkJo4f0lq0oIhMVZnTsqIABBmh4tlriB
MUt8CZuMVcK4Ea8BkIyO4VkZNiqa9GjgTfMk8hEiB91Md7dLJrRZGJBhv1swzRHh
AO3S8fIQNEqNJfbU/qk+dK/FW4JWgd5KE5Es6gwI4/1KgV0wHRvyKLQ40udcA243
ZBed3WuWQm+BLXsIeMG5W7DHV78Qfiwk1aQrEIigVy9uiOWwXjMLM2CD/kIpMAUZ
Y3oc/8ELr5JoQODq4hqFbsAc5EpoKmF2bIqtrrc1rEkFIIcXdsksSuVwyjdCRcW+
LtCR70W/PIXkqVlJgeu4B6EhPpApci2pudsjp/tXX40hCljLWTXgeOr0jyCAdeMh
HrwbST5ltzDJD6wN1NxKM6aAtE6vwsP565mjWQ9HmvmKdAv/Wqv/n+8looSnch7c
yIyZq7JWpiP6nAMRHjZ4YsagVVun8bRTZfAbibz+DgPR1VUOmfF5eLHaGDOnAHca
FzJXEd7mw+yinTJwNdzz9GIW7iKAfrjGgQsrZA/F9F4ok54OV64HO2a70hLUgSTU
goLps/7ZGtk=
=FXPt
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 65743@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 65743
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help