[PATCH] gnu: ibus: Disable registry cache.

  • Done
  • quality assurance status badge
Details
2 participants
  • iyzsong
  • Maxim Cournoyer
Owner
unassigned
Submitted by
iyzsong
Severity
normal
I
I
iyzsong wrote on 4 Sep 2023 12:24
(address . guix-patches@gnu.org)(name . ???)(address . iyzsong@member.fsf.org)
22876547edd70bd6fbc7e6808a6931c7648552e1.1693823061.git.iyzsong@member.fsf.org
From: ??? <iyzsong@member.fsf.org>


* gnu/packages/ibus.scm (ibus)[arguments]: Add 'disable-registry-cache' phase.
---
gnu/packages/ibus.scm | 6 ++++++
1 file changed, 6 insertions(+)

Toggle diff (21 lines)
diff --git a/gnu/packages/ibus.scm b/gnu/packages/ibus.scm
index f9ef44a6d9..62323ece6f 100644
--- a/gnu/packages/ibus.scm
+++ b/gnu/packages/ibus.scm
@@ -241,6 +241,12 @@ (define-public ibus
#$flags))
((#:phases phases '%standard-phases)
#~(modify-phases #$phases
+ (add-after 'unpack 'disable-registry-cache
+ ;; IBus registry cache depends on mtime, which doesn't work on
+ ;; Guix.
+ (lambda _
+ (substitute* "bus/main.c"
+ (("ibus_init") "g_cache = \"none\"; ibus_init"))))
(replace 'wrap-with-additional-paths
(lambda* (#:key outputs #:allow-other-keys)
;; Make sure 'ibus-setup' and 'ibus-daemon' runs with the

base-commit: c72bc0bb71a7315241c174636f96faee46a6dfa8
--
2.41.0
M
M
Maxim Cournoyer wrote on 6 Sep 2023 02:58
(address . iyzsong@envs.net)
87wmx4dsmq.fsf@gmail.com
iyzsong@envs.net writes:

Toggle quote (29 lines)
> From: ??? <iyzsong@member.fsf.org>
>
> Fixes <https://issues.guix.gnu.org/22707>.
>
> * gnu/packages/ibus.scm (ibus)[arguments]: Add 'disable-registry-cache' phase.
> ---
> gnu/packages/ibus.scm | 6 ++++++
> 1 file changed, 6 insertions(+)
>
> diff --git a/gnu/packages/ibus.scm b/gnu/packages/ibus.scm
> index f9ef44a6d9..62323ece6f 100644
> --- a/gnu/packages/ibus.scm
> +++ b/gnu/packages/ibus.scm
> @@ -241,6 +241,12 @@ (define-public ibus
> #$flags))
> ((#:phases phases '%standard-phases)
> #~(modify-phases #$phases
> + (add-after 'unpack 'disable-registry-cache
> + ;; IBus registry cache depends on mtime, which doesn't work on
> + ;; Guix.
> + (lambda _
> + (substitute* "bus/main.c"
> + (("ibus_init") "g_cache = \"none\"; ibus_init"))))
> (replace 'wrap-with-additional-paths
> (lambda* (#:key outputs #:allow-other-keys)
> ;; Make sure 'ibus-setup' and 'ibus-daemon' runs with the
>
> base-commit: c72bc0bb71a7315241c174636f96faee46a6dfa8

Thanks, installed!

--
Thanks,
Maxim
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 65728@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 65728
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch