(address . guix-patches@gnu.org)(name . altadil)(address . altadil@protonmail.com)
* gnu/packages/pantheon (pantheon-calculator): Update to 2.0.2.
---
This patch must be applied after the one for granite
This version of calculator cannot build with the current version of
granite but I tested locally that it does build
(on x86_64, i686 and aarch64) once granite is up-to-date.
gnu/packages/pantheon.scm | 16 ++++++++--------
1 file changed, 8 insertions(+), 8 deletions(-)
Toggle diff (49 lines)
diff --git a/gnu/packages/pantheon.scm b/gnu/packages/pantheon.scm
index c5cbde24c0..8bd15622f3 100644
--- a/gnu/packages/pantheon.scm
+++ b/gnu/packages/pantheon.scm
@@ -74,7 +74,7 @@ (define-public granite
(define-public pantheon-calculator
(package
(name "pantheon-calculator")
- (version "1.7.2")
+ (version "2.0.2")
(source
(origin
(method git-fetch)
@@ -84,7 +84,7 @@ (define-public pantheon-calculator
(file-name (git-file-name name version))
(sha256
(base32
- "11rwwi6nlhwpcm29dn2mbz0239nfjdwlqlqbchm0j9sr1ypifk2k"))))
+ "1w59sgznzybawhz411avqayws8jq0471n6hwhkplvcz7inxlzdrw"))))
(build-system meson-build-system)
(arguments
`(#:glib-or-gtk? #t
@@ -96,15 +96,15 @@ (define-public pantheon-calculator
(inputs
(list granite
glib
- gtk+
+ gtk
libgee
libhandy))
(native-inputs
- `(("cmake" ,cmake)
- ("glib:bin" ,glib "bin") ; for glib-compile-schemas
- ("gettext" ,gettext-minimal)
- ("pkg-config" ,pkg-config)
- ("vala" ,vala)))
+ (list cmake
+ `(,glib "bin") ; for glib-compile-schemas
+ gettext-minimal
+ pkg-config
+ vala))
(home-page "https://github.com/elementary/calculator")
(synopsis "Desktop calculator")
(description "Calculator is an application for performing simple
base-commit: 52af65cf661603b4f6bdc39c2565105577003992
prerequisite-patch-id: 36af07118dd514ad62778401445fbd484b27ac86
--
2.41.0