[PATCH 0/2] Add wl-mirror.

  • Done
  • quality assurance status badge
Details
3 participants
  • Julian Flake
  • Hilton Chain
  • kiasoc5
Owner
unassigned
Submitted by
kiasoc5
Severity
normal
K
K
kiasoc5 wrote on 3 Sep 2023 01:20
(address . guix-patches@gnu.org)(name . kiasoc5)(address . kiasoc5@disroot.org)
20230902232057.48289-1-kiasoc5@disroot.org
Requires wlr-protocols, which doesn't have a release, so use the latest tag.

Helps wlroots compositors (eg Sway) work around sharing windows of applications.

kiasoc5 (2):
gnu: Add wlr-protocols.
gnu: Add wl-mirror.

gnu/packages/freedesktop.scm | 28 ++++++++++++++++++++
gnu/packages/wm.scm | 51 ++++++++++++++++++++++++++++++++++++
2 files changed, 79 insertions(+)


base-commit: 4818ad5ba204e094fd8995c90c16ee1940e76210
--
2.39.2
K
K
kiasoc5 wrote on 18 Sep 2023 04:08
(no subject)
(address . 65711@debbugs.gnu.org)
65f6ea07016433c4e9fcf65d1b16379c@disroot.org
For some reason git send-email didn't work with this address so I send
the patches as attachments.
From 7c41cab39fc260dd5467277e60a27d288dad8e99 Mon Sep 17 00:00:00 2001
From: kiasoc5 <kiasoc5@disroot.org>
Date: Fri, 18 Aug 2023 21:11:24 -0400
Subject: [PATCH 1/2] gnu: Add wlr-protocols.

* gnu/packages/freedesktop.scm (wlr-protocols): New variable.
---
gnu/packages/freedesktop.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 0a1c9bffb3..b81af2c344 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -1250,6 +1250,34 @@ (define-public wayland-protocols
. "https://wayland.freedesktop.org/releases.html")))
(license license:expat)))
+(define-public wlr-protocols
+ (let ((commit "4264185db3b7e961e7f157e1cc4fd0ab75137568")
+ (revision "0"))
+ (package
+ (name "wlr-protocols")
+ (version (git-version "0.0.0" revision commit)) ;no release tag
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.freedesktop.org/wlroots/wlr-protocols.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "045jj3mbhi7p2qn59krz0vap0wd3i6zgwkvpl97idy702bnk9mv6"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list #:make-flags
+ #~(list (string-append "PREFIX=" #$output))
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure))))
+ (native-inputs (list wayland))
+ (home-page "https://gitlab.freedesktop.org/wlroots/wlr-protocols")
+ (synopsis "wlroots protocols")
+ (description "This package contains Wayland protocols designed for
+use in wlroots (and other compositors).")
+ (license license:expat)))) ; license is included in xml files
+
(define-public wayland-utils
(package
(name "wayland-utils")

base-commit: 4818ad5ba204e094fd8995c90c16ee1940e76210
--
2.39.2
From 845e76209013521274200facea7fe80f52bf39f0 Mon Sep 17 00:00:00 2001
From: kiasoc5 <kiasoc5@disroot.org>
Date: Fri, 18 Aug 2023 21:13:09 -0400
Subject: [PATCH 2/2] gnu: Add wl-mirror.

* gnu/packages/wm.scm (wl-mirror): New variable.
---
gnu/packages/wm.scm | 51 +++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 51 insertions(+)

Toggle diff (64 lines)
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index aaff618248..cd36e44417 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -2076,6 +2076,57 @@ (define-public wdisplays
wlr-output-management-unstable-v1 protocol.")
(license license:gpl3+)))
+(define-public wl-mirror
+ (package
+ (name "wl-mirror")
+ (version "0.13.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Ferdi265/wl-mirror.git")
+ (commit (string-append "v" version))
+ (recursive? #t)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0gig06g0gcdg9741ij27dwidk9q6kp5x8idn1yh6vmcrh5xm2rvn"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list #:configure-flags
+ #~(list "-DINSTALL_DOCUMENTATION=ON"
+ "-DFORCE_SYSTEM_WL_PROTOCOLS=ON"
+ "-DFORCE_SYSTEM_WLR_PROTOCOLS=ON"
+ (string-append "-DWL_PROTOCOL_DIR="
+ (search-input-directory
+ %build-inputs "share/wayland-protocols"))
+ (string-append "-DWLR_PROTOCOL_DIR="
+ (search-input-directory
+ %build-inputs"share/wlr-protocols")))
+ #:tests? #f)) ; no tests
+ (inputs (list libglvnd wayland wayland-protocols wlr-protocols))
+ (native-inputs (list pkg-config scdoc))
+ (home-page "https://github.com/Ferdi265/wl-mirror")
+ (synopsis "A simple Wayland output mirror client")
+ (description "@command{wl-mirror} mirrors outputs onto client surfaces
+on wlroots compositors. Features include:
+@itemize
+
+@item Mirror an output onto a resizable window
+
+@item Mirror an output onto another output by fullscreening the window
+
+@item Reacts to changes in output scale
+
+@item Preserves aspect ratio
+
+@item Corrects for flipped or rotated outputs
+
+@item Supports custom flips or rotations
+
+@item Supports mirroring custom regions of outputs
+
+@end itemize ")
+ (license license:gpl3)))
+
(define-public stumpwm
(package
(name "stumpwm")
--
2.39.2
J
J
Julian Flake wrote on 5 Mar 15:56 +0100
how to get this into Guix's master?
(address . 65711@debbugs.gnu.org)
874jdkvi3u.fsf@uni-koblenz.de
Dear Guix,

I also needed wl-mirror and unfortunately didn't check
issues.guix.gnu.org before. However, I ended with quite the same
patch (one difference is, that I used e newer version of
wl-mirror), independently.

What can we do to get one of the patches merged into guix's
master?

Best Regards,
Julian Flake

--
Dipl.-Inf. Julian Flake

Universität Koblenz
Fachbereich Informatik
Institut für Softwaretechnik
Postfach 20 16 02 | D-56016 Koblenz

Tel.: +49 261 287 2787
E-Mail: flake@uni-koblenz.de
J
J
Julian Flake wrote on 5 Mar 15:55 +0100
[PATCH v1] wlr-protocols / wl-mirror added
(address . 65711@debbugs.gnu.org)(name . Julian Flake)(address . flake@uni-koblenz.de)
c180da6634ba411d4768bcdf95da882c7b8bc8bf.1709650524.git.flake@uni-koblenz.de
---
gnu/packages/freedesktop.scm | 31 +++++++++++++++++
gnu/packages/wm.scm | 67 ++++++++++++++++++++++++++----------
2 files changed, 80 insertions(+), 18 deletions(-)

Toggle diff (138 lines)
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 7b5d2dbbf2..627a837801 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -1270,6 +1270,37 @@ (define-public wayland-protocols
. "https://wayland.freedesktop.org/releases.html")))
(license license:expat)))
+(define-public wlr-protocols
+ (let ((revision "0")
+ (commit "4264185db3b7e961e7f157e1cc4fd0ab75137568"))
+ (package
+ (name "wlr-protocols")
+ (version (git-version "0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.freedesktop.org/wlroots/wlr-protocols.git")
+ (commit commit)))
+ (sha256
+ (base32
+ "045jj3mbhi7p2qn59krz0vap0wd3i6zgwkvpl97idy702bnk9mv6"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (delete 'configure)
+ (add-before 'build 'set-prefix-in-makefile
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (substitute* "Makefile"
+ (("PREFIX=.*") (string-append "PREFIX="out "\n")))))))))
+ (inputs
+ (list wayland))
+ (home-page "https://gitlab.freedesktop.org/wlroots/wlr-protocols")
+ (synopsis "Wayland protocols designed for use in wlroots (and other compositors).")
+ (description
+ "Wayland protocols designed for use in wlroots (and other compositors).")
+ (license expat))))
+
(define-public wayland-utils
(package
(name "wayland-utils")
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 8ed3ed1107..f661140d28 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1759,6 +1759,37 @@ (define-public wlroots-0.16
(propagated-inputs (modify-inputs (package-propagated-inputs wlroots)
(delete libdisplay-info)))))
+(define-public wl-mirror
+ (package
+ (name "wl-mirror")
+ (version "0.16.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Ferdi265/wl-mirror")
+ (commit "v0.16.1")))
+ (sha256
+ (base32
+ "0464m60xsbpfwvsszrdkjsxfvrbkr71hp7phsz05cqyvjwf6cism"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list
+ #:tests? #f
+ #:configure-flags
+ #~(list "-DFORCE_SYSTEM_WL_PROTOCOLS=ON"
+ (string-append "-DWL_PROTOCOL_DIR="
+ #$(this-package-input "wayland-protocols") "/share/wayland-protocols")
+ "-DFORCE_SYSTEM_WLR_PROTOCOLS=ON"
+ (string-append "-DWLR_PROTOCOL_DIR="
+ #$(this-package-input "wlr-protocols") "/share/wlr-protocols"))))
+ (inputs
+ (list pkg-config egl-wayland mesa wayland wayland-protocols wlr-protocols))
+ (home-page "https://github.com/Ferdi265/wl-mirror")
+ (synopsis "A simple Wayland output mirror client")
+ (description
+ "wl-mirror attempts to provide a solution to sway's lack of output mirroring by mirroring an output onto a client surface.")
+ (license gpl3)))
+
(define-public sway
(package
(name "sway")
@@ -1777,21 +1808,21 @@ (define-public sway
`(;; elogind is propagated by wlroots -> libseat
;; and would otherwise shadow basu.
#:configure-flags '("-Dsd-bus-provider=basu")
- #:phases
- (modify-phases %standard-phases
- (add-before 'configure 'hardcode-paths
- (lambda* (#:key inputs #:allow-other-keys)
- ;; Hardcode path to swaybg.
- (substitute* "sway/config.c"
- (("strdup..swaybg..")
- (string-append "strdup(\"" (assoc-ref inputs "swaybg")
- "/bin/swaybg\")")))
- ;; Hardcode path to scdoc.
- (substitute* "meson.build"
- (("scdoc.get_pkgconfig_variable..scdoc..")
- (string-append "'" (assoc-ref inputs "scdoc")
- "/bin/scdoc'")))
- #t)))))
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'hardcode-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; Hardcode path to swaybg.
+ (substitute* "sway/config.c"
+ (("strdup..swaybg..")
+ (string-append "strdup(\"" (assoc-ref inputs "swaybg")
+ "/bin/swaybg\")")))
+ ;; Hardcode path to scdoc.
+ (substitute* "meson.build"
+ (("scdoc.get_pkgconfig_variable..scdoc..")
+ (string-append "'" (assoc-ref inputs "scdoc")
+ "/bin/scdoc'")))
+ #t)))))
(inputs (list basu
cairo
gdk-pixbuf
@@ -1807,9 +1838,9 @@ (define-public sway
(native-inputs
(cons* linux-pam mesa pkg-config scdoc wayland-protocols
(if (%current-target-system)
- (list pkg-config-for-build
- wayland)
- '())))
+ (list pkg-config-for-build
+ wayland)
+ '())))
(home-page "https://github.com/swaywm/sway")
(synopsis "Wayland compositor compatible with i3")
(description "Sway is a i3-compatible Wayland compositor.")

base-commit: b6dec0108f99d75066bad15aaa124b84bb0261f3
--
2.41.0
J
J
Julian Flake wrote on 6 Mar 09:46 +0100
cleaned up patch
(address . 65711@debbugs.gnu.org)
87il1zu4pz.fsf@uni-koblenz.de
Sending patch again, since the previous [PATCH v1] contained
additional/unnecessary indentation related diff
--
Dipl.-Inf. Julian Flake

Universität Koblenz
Fachbereich Informatik
Institut für Softwaretechnik
Postfach 20 16 02 | D-56016 Koblenz

Tel.: +49 261 287 2787
E-Mail: flake@uni-koblenz.de
J
J
Julian Flake wrote on 6 Mar 09:47 +0100
[PATCH v2] wlr-protocols / wl-mirror added
(address . 65711@debbugs.gnu.org)(name . Julian Flake)(address . flake@uni-koblenz.de)
e3e4a1ebdfe3a648459d0c17afd235b1e346f874.1709714854.git.flake@uni-koblenz.de
---
gnu/packages/freedesktop.scm | 31 +++++++++++++++++++++++++++++++
gnu/packages/wm.scm | 31 +++++++++++++++++++++++++++++++
2 files changed, 62 insertions(+)

Toggle diff (88 lines)
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 7b5d2dbbf2..627a837801 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -1270,6 +1270,37 @@ (define-public wayland-protocols
. "https://wayland.freedesktop.org/releases.html")))
(license license:expat)))
+(define-public wlr-protocols
+ (let ((revision "0")
+ (commit "4264185db3b7e961e7f157e1cc4fd0ab75137568"))
+ (package
+ (name "wlr-protocols")
+ (version (git-version "0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.freedesktop.org/wlroots/wlr-protocols.git")
+ (commit commit)))
+ (sha256
+ (base32
+ "045jj3mbhi7p2qn59krz0vap0wd3i6zgwkvpl97idy702bnk9mv6"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (delete 'configure)
+ (add-before 'build 'set-prefix-in-makefile
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (substitute* "Makefile"
+ (("PREFIX=.*") (string-append "PREFIX="out "\n")))))))))
+ (inputs
+ (list wayland))
+ (home-page "https://gitlab.freedesktop.org/wlroots/wlr-protocols")
+ (synopsis "Wayland protocols designed for use in wlroots (and other compositors).")
+ (description
+ "Wayland protocols designed for use in wlroots (and other compositors).")
+ (license expat))))
+
(define-public wayland-utils
(package
(name "wayland-utils")
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 8ed3ed1107..fe07747a81 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1759,6 +1759,37 @@ (define-public wlroots-0.16
(propagated-inputs (modify-inputs (package-propagated-inputs wlroots)
(delete libdisplay-info)))))
+(define-public wl-mirror
+ (package
+ (name "wl-mirror")
+ (version "0.16.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Ferdi265/wl-mirror")
+ (commit "v0.16.1")))
+ (sha256
+ (base32
+ "0464m60xsbpfwvsszrdkjsxfvrbkr71hp7phsz05cqyvjwf6cism"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list
+ #:tests? #f
+ #:configure-flags
+ #~(list "-DFORCE_SYSTEM_WL_PROTOCOLS=ON"
+ (string-append "-DWL_PROTOCOL_DIR="
+ #$(this-package-input "wayland-protocols") "/share/wayland-protocols")
+ "-DFORCE_SYSTEM_WLR_PROTOCOLS=ON"
+ (string-append "-DWLR_PROTOCOL_DIR="
+ #$(this-package-input "wlr-protocols") "/share/wlr-protocols"))))
+ (inputs
+ (list pkg-config egl-wayland mesa wayland wayland-protocols wlr-protocols))
+ (home-page "https://github.com/Ferdi265/wl-mirror")
+ (synopsis "A simple Wayland output mirror client")
+ (description
+ "wl-mirror attempts to provide a solution to sway's lack of output mirroring by mirroring an output onto a client surface.")
+ (license gpl3)))
+
(define-public sway
(package
(name "sway")

base-commit: b6dec0108f99d75066bad15aaa124b84bb0261f3
--
2.41.0
J
J
Julian Flake wrote on 6 Mar 12:22 +0100
[PATCH v3 1/2] package wlr-protocols added to gnu/packages/freedesktop.scm
(address . 65711@debbugs.gnu.org)(name . Julian Flake)(address . flake@uni-koblenz.de)
7d46b3909d81b1aebceb7afa66ebe68e18a96139.1709724127.git.flake@uni-koblenz.de
Split the two packages into two separate patches

---
gnu/packages/freedesktop.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 7b5d2dbbf2..dbb55506b6 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -1270,6 +1270,34 @@ (define-public wayland-protocols
. "https://wayland.freedesktop.org/releases.html")))
(license license:expat)))
+(define-public wlr-protocols
+ (let ((revision "0")
+ (commit "4264185db3b7e961e7f157e1cc4fd0ab75137568"))
+ (package
+ (name "wlr-protocols")
+ (version (git-version "0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.freedesktop.org/wlroots/wlr-protocols.git")
+ (commit commit)))
+ (sha256
+ (base32
+ "045jj3mbhi7p2qn59krz0vap0wd3i6zgwkvpl97idy702bnk9mv6"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:make-flags (list
+ (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ #:phases (modify-phases %standard-phases
+ (delete 'configure))))
+ (inputs
+ (list wayland))
+ (home-page "https://gitlab.freedesktop.org/wlroots/wlr-protocols")
+ (synopsis "Wayland protocols designed for use in wlroots (and other compositors).")
+ (description
+ "Wayland protocols designed for use in wlroots (and other compositors).")
+ (license license:expat))))
+
(define-public wayland-utils
(package
(name "wayland-utils")

base-commit: b6dec0108f99d75066bad15aaa124b84bb0261f3
--
2.41.0
J
J
Julian Flake wrote on 6 Mar 12:22 +0100
[PATCH v3 2/2] package wl-mirror added to gnu/packages/wm.scm
(address . 65711@debbugs.gnu.org)(name . Julian Flake)(address . flake@uni-koblenz.de)
dc345b1fc1432a53e0bf51eed2e34db3d0d6bfde.1709724127.git.flake@uni-koblenz.de
---
gnu/packages/wm.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 8ed3ed1107..d4e5af44d5 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1759,6 +1759,37 @@ (define-public wlroots-0.16
(propagated-inputs (modify-inputs (package-propagated-inputs wlroots)
(delete libdisplay-info)))))
+(define-public wl-mirror
+ (package
+ (name "wl-mirror")
+ (version "0.16.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Ferdi265/wl-mirror")
+ (commit "v0.16.1")))
+ (sha256
+ (base32
+ "0464m60xsbpfwvsszrdkjsxfvrbkr71hp7phsz05cqyvjwf6cism"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list
+ #:tests? #f
+ #:configure-flags
+ #~(list "-DFORCE_SYSTEM_WL_PROTOCOLS=ON"
+ (string-append "-DWL_PROTOCOL_DIR="
+ #$(this-package-input "wayland-protocols") "/share/wayland-protocols")
+ "-DFORCE_SYSTEM_WLR_PROTOCOLS=ON"
+ (string-append "-DWLR_PROTOCOL_DIR="
+ #$(this-package-input "wlr-protocols") "/share/wlr-protocols"))))
+ (inputs
+ (list pkg-config egl-wayland mesa wayland wayland-protocols wlr-protocols))
+ (home-page "https://github.com/Ferdi265/wl-mirror")
+ (synopsis "A simple Wayland output mirror client")
+ (description
+ "wl-mirror attempts to provide a solution to sway's lack of output mirroring by mirroring an output onto a client surface.")
+ (license license:gpl3)))
+
(define-public sway
(package
(name "sway")
--
2.41.0
J
J
Julian Flake wrote on 14 Mar 12:26 +0100
[PATCH v4 1/2] package wlr-protocols added to gnu/packages/freedesktop.scm
(address . 65711@debbugs.gnu.org)(name . Julian Flake)(address . flake@uni-koblenz.de)
97928c7b9779645fbedede7a8f4897e3b76e3551.1710415605.git.flake@uni-koblenz.de
Revision 4: use latest commit of wlr-protocols

Change-Id: Ia8daffd7219b7bd573ae54e7cfc5ec6b6a5f4052
---
gnu/packages/freedesktop.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 7b5d2dbbf2..88d0d1d080 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -1270,6 +1270,34 @@ (define-public wayland-protocols
. "https://wayland.freedesktop.org/releases.html")))
(license license:expat)))
+(define-public wlr-protocols
+ (let ((revision "3")
+ (commit "2b8d43325b7012cc3f9b55c08d26e50e42beac7d"))
+ (package
+ (name "wlr-protocols")
+ (version (git-version "0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.freedesktop.org/wlroots/wlr-protocols.git")
+ (commit commit)))
+ (sha256
+ (base32
+ "02ydbbbz9y0hxnpkypw9vwz7q8dzswrl1500liqq1ddgxg89zzd0"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:make-flags (list
+ (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ #:phases (modify-phases %standard-phases
+ (delete 'configure))))
+ (inputs
+ (list wayland))
+ (home-page "https://gitlab.freedesktop.org/wlroots/wlr-protocols")
+ (synopsis "Wayland protocols designed for use in wlroots (and other compositors).")
+ (description
+ "Wayland protocols designed for use in wlroots (and other compositors).")
+ (license license:expat))))
+
(define-public wayland-utils
(package
(name "wayland-utils")

base-commit: b6dec0108f99d75066bad15aaa124b84bb0261f3
--
2.41.0
J
J
Julian Flake wrote on 14 Mar 12:26 +0100
[PATCH v4 2/2] package wl-mirror added to gnu/packages/wm.scm
(address . 65711@debbugs.gnu.org)(name . Julian Flake)(address . flake@uni-koblenz.de)
9e91e20aa1d7e199d7a890869457f4e7a8042d05.1710415605.git.flake@uni-koblenz.de
use latest version of wl-mirror

Change-Id: Ib87959a40800a2a8219877611b8cfd301960c608
---
gnu/packages/wm.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 8ed3ed1107..24c6fdf9e5 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1759,6 +1759,37 @@ (define-public wlroots-0.16
(propagated-inputs (modify-inputs (package-propagated-inputs wlroots)
(delete libdisplay-info)))))
+(define-public wl-mirror
+ (package
+ (name "wl-mirror")
+ (version "0.16.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Ferdi265/wl-mirror")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32
+ "1jdycr9vf5skbf55kbm2hc3zl3qg58x3bb6xqkf9qx14m4ramcdj"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list
+ #:tests? #f
+ #:configure-flags
+ #~(list "-DFORCE_SYSTEM_WL_PROTOCOLS=ON"
+ (string-append "-DWL_PROTOCOL_DIR="
+ #$(this-package-input "wayland-protocols") "/share/wayland-protocols")
+ "-DFORCE_SYSTEM_WLR_PROTOCOLS=ON"
+ (string-append "-DWLR_PROTOCOL_DIR="
+ #$(this-package-input "wlr-protocols") "/share/wlr-protocols"))))
+ (inputs
+ (list pkg-config egl-wayland mesa wayland wayland-protocols wlr-protocols))
+ (home-page "https://github.com/Ferdi265/wl-mirror")
+ (synopsis "A simple Wayland output mirror client")
+ (description
+ "wl-mirror attempts to provide a solution to sway's lack of output mirroring by mirroring an output onto a client surface.")
+ (license license:gpl3)))
+
(define-public sway
(package
(name "sway")
--
2.41.0
H
H
Hilton Chain wrote on 20 Apr 03:28 +0200
Re: [bug#65711] [PATCH v4 1/2] package wlr-protocols added to gnu/packages/freedesktop.scm
(name . Julian Flake)(address . flake@uni-koblenz.de)(address . 65711-done@debbugs.gnu.org)
87plukx1on.wl-hako@ultrarare.space
Hi Julian,

On Thu, 14 Mar 2024 19:26:46 +0800,
Julian Flake wrote:
Toggle quote (3 lines)
>
> Revision 4: use latest commit of wlr-protocols

I have adjusted the series and applied them as 6c4f3043933d and d66bfbeeb2a9.

Thanks!
Closed
J
J
Julian Flake wrote on 20 Apr 09:26 +0200
(name . Hilton Chain)(address . hako@ultrarare.space)(address . 65711-done@debbugs.gnu.org)
87frvgjxzz.fsf@uni-koblenz.de
Hi Hilton,

Toggle quote (5 lines)
>> Revision 4: use latest commit of wlr-protocols
>
> I have adjusted the series and applied them as 6c4f3043933d and
> d66bfbeeb2a9.

Thank you!

Best Regards,
Julian
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 65711@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 65711
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch