[PATCH] gnu: Add r-interactivedisplay.

  • Done
  • quality assurance status badge
Details
2 participants
  • Navid Afkhami
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Navid Afkhami
Severity
normal
N
N
Navid Afkhami wrote on 2 Sep 2023 23:56
(address . guix-patches@gnu.org)(name . Navid Afkhami)(address . navid.afkhami@mdc-berlin.de)
8b873349673578098691476c6e023579ea78af96.1693691804.git.navid.afkhami@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-interactivedisplay): New variable.
---
gnu/packages/bioconductor.scm | 38 +++++++++++++++++++++++++++++++++++
1 file changed, 38 insertions(+)

Toggle diff (56 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 0070d7777c..f2cb268069 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -7734,6 +7734,44 @@ (define-public r-impute
microarray data, using nearest neighbor averaging.")
(license license:gpl2+)))
+(define-public r-interactivedisplay
+ (package
+ (name "r-interactivedisplay")
+ (version "1.38.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "interactiveDisplay" version))
+ (sha256
+ (base32
+ "1y9fdnpz1bagrwhyj8jikp2q5fd9y74j48l5z7f0s88v88sa7szl"))))
+ (properties `((upstream-name . "interactiveDisplay")))
+ (build-system r-build-system)
+ (propagated-inputs (list curl
+ zlib
+ r-annotationdbi
+ r-biocgenerics
+ r-biocmanager
+ r-category
+ r-dt
+ r-ggplot2
+ r-gridsvg
+ r-interactivedisplaybase
+ r-plyr
+ r-rcolorbrewer
+ r-reshape2
+ r-shiny
+ r-zlibbioc
+ r-xml))
+ (native-inputs (list esbuild r-knitr))
+ (home-page "https://bioconductor.org/packages/interactiveDisplay")
+ (synopsis
+ "Package for enabling powerful shiny web displays of Bioconductor objects")
+ (description
+ "This package offers interactive Shiny displays for Bioconductor objects.
+In addition, this package empower users to develop engaging visualizations
+and interfaces for working with Bioconductor data.")
+ (license license:artistic2.0)))
+
(define-public r-interactivedisplaybase
(package
(name "r-interactivedisplaybase")

base-commit: c72bc0bb71a7315241c174636f96faee46a6dfa8
prerequisite-patch-id: 70b98dde8ca4056fb8bd1b731716853ac2c9f0a1
prerequisite-patch-id: da79dfabf48a66d58c294d8a8a5e036808df44d3
prerequisite-patch-id: b1b6000ebee26b162e35b26bffc5b8a6fdf820d8
--
2.34.1
N
N
Navid Afkhami wrote on 12 Sep 2023 17:14
(address . 65707@debbugs.gnu.org)(name . Navid Afkhami)(address . navid.afkhami@mdc-berlin.de)
db638a0b678ef09e3f5463c27a9b88d5f558ab96.1694531662.git.navid.afkhami@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-interactivedisplay): New variable.
---
gnu/packages/bioconductor.scm | 44 +++++++++++++++++++++++++++++++++++
1 file changed, 44 insertions(+)

Toggle diff (59 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index c913232680..9c03366f8b 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -7734,6 +7734,50 @@ (define-public r-impute
microarray data, using nearest neighbor averaging.")
(license license:gpl2+)))
+(define-public r-interactivedisplay
+ (package
+ (name "r-interactivedisplay")
+ (version "1.38.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "interactiveDisplay" version))
+ (sha256
+ (base32
+ "1y9fdnpz1bagrwhyj8jikp2q5fd9y74j48l5z7f0s88v88sa7szl"))))
+ (properties `((upstream-name . "interactiveDisplay")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-annotationdbi
+ r-biocgenerics
+ r-biocmanager
+ r-category
+ r-dt
+ r-ggplot2
+ r-gridsvg
+ r-interactivedisplaybase
+ r-plyr
+ r-rcolorbrewer
+ r-reshape2
+ r-shiny
+ r-zlibbioc
+ r-xml))
+ (native-inputs `(("esbuild" ,esbuild)
+ ("r-knitr" ,r-knitr)
+("js-jquery-1.9.1"
+,(origin
+ (method url-fetch)
+ (uri "https://code.jquery.com/jquery-1.9.1.js")
+ (sha256
+ (base32
+ "0h4dk67yc9d0kadqxb6b33585f3x3559p6qmp70l00qwq030vn3v"))))))
+ (home-page "https://bioconductor.org/packages/interactiveDisplay")
+ (synopsis
+ "Package for enabling powerful shiny web displays of Bioconductor objects")
+ (description
+ "This package offers interactive Shiny displays for Bioconductor objects.
+In addition, this package empower users to develop engaging visualizations
+and interfaces for working with Bioconductor data.")
+ (license license:artistic2.0)))
+
(define-public r-interactivedisplaybase
(package
(name "r-interactivedisplaybase")

base-commit: 45af7b89239d4bbdc145a5c9cc03356f31d5a20e
--
2.34.1
R
R
Ricardo Wurmus wrote on 15 Sep 2023 23:23
(address . 65707-done@debbugs.gnu.org)
87y1h7xh7m.fsf@elephly.net
Thanks for the patch!

This needed a little more work to replace the bundled JavaScript. You
can see the result in commit cda20190bccf9bd55c264b1084eab8b6499c15cc.

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 65707@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 65707
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch