[PATCH] gnu: portfolio: Update to 1.0.0.

  • Done
  • quality assurance status badge
Details
2 participants
  • Liliana Marie Prikler
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Liliana Marie Prikler
Severity
normal
L
L
Liliana Marie Prikler wrote on 2 Sep 2023 15:11
(address . guix-patches@gnu.org)
896c5a8b68e932ac58297a837cafef051d04240d.1693660352.git.liliana.prikler@gmail.com
* gnu/packages/gnome-xyz.scm (portfolio): Update to 1.0.0.
[#:phases]: Add ‘skip-gtk-update-icon-cache’.
[inputs]: Replace gtk+ with gtk.
Replace libhandy with libadwaita.
[native-inputs]: Remove gtk+:bin.
Add pkg-config.
---
gnu/packages/gnome-xyz.scm | 12 ++++++++----
1 file changed, 8 insertions(+), 4 deletions(-)

Toggle diff (53 lines)
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 6ba0ee0092..8b5dc3030e 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -484,7 +484,7 @@ (define-public gnome-plots
(define-public portfolio
(package
(name "portfolio")
- (version "0.9.14")
+ (version "1.0.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -493,7 +493,7 @@ (define-public portfolio
(file-name (git-file-name name version))
(sha256
(base32
- "0h09v8lhz3kv6qmwjhx3gr7rp6ccfhrzm54gjnaixl4dcg9zddls"))))
+ "1ai9mx801m5lngkljg42vrpvhbvc3071sp4jypsvbzw55hxnn5ba"))))
(arguments
(list #:glib-or-gtk? #t
#:imported-modules `(,@%meson-build-system-modules
@@ -508,6 +508,10 @@ (define-public portfolio
(with-directory-excursion (string-append #$output
"/bin")
(symlink "dev.tchx84.Portfolio" "portfolio"))))
+ (add-after 'unpack 'skip-gtk-update-icon-cache
+ (lambda _
+ (substitute* "build-aux/meson/postinstall.py"
+ (("gtk-update-icon-cache") "true"))))
(add-after 'glib-or-gtk-wrap 'python-and-gi-wrap
(lambda* (#:key inputs outputs #:allow-other-keys)
(wrap-program (search-input-file outputs
@@ -519,12 +523,12 @@ (define-public portfolio
`("GI_TYPELIB_PATH" =
(,(getenv "GI_TYPELIB_PATH")))))))))
(build-system meson-build-system)
- (inputs (list bash-minimal python-pygobject gtk+ libhandy))
+ (inputs (list bash-minimal python-pygobject gtk libadwaita))
(native-inputs
(list desktop-file-utils
gettext-minimal
`(,glib "bin")
- `(,gtk+ "bin")
+ pkg-config
python))
(home-page "https://github.com/tchx84/Portfolio")
(synopsis "Minimalist file manager for Linux mobile devices")

base-commit: 9179775b0535ddf038d45f1355f759c4d6dc40dc
prerequisite-patch-id: a6de0ccc2665854539d331239e51c5fa4c3373aa
--
2.41.0
M
M
Maxim Cournoyer wrote on 5 Sep 2023 05:40
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)
871qfdnv8l.fsf@gmail.com
Hello,

Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

Toggle quote (7 lines)
> * gnu/packages/gnome-xyz.scm (portfolio): Update to 1.0.0.
> [#:phases]: Add ‘skip-gtk-update-icon-cache’.
> [inputs]: Replace gtk+ with gtk.
> Replace libhandy with libadwaita.
> [native-inputs]: Remove gtk+:bin.
> Add pkg-config.

LGTM, thanks!

--
Maxim
L
L
Liliana Marie Prikler wrote on 9 Sep 2023 11:03
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)
c9ac076b2f506cca7b2c3bea25b692bc606a242d.camel@gmail.com
Am Montag, dem 04.09.2023 um 23:40 -0400 schrieb Maxim Cournoyer:
Toggle quote (12 lines)
> Hello,
>
> Liliana Marie Prikler <liliana.prikler@gmail.com> writes:
>
> > * gnu/packages/gnome-xyz.scm (portfolio): Update to 1.0.0.
> > [#:phases]: Add ‘skip-gtk-update-icon-cache’.
> > [inputs]: Replace gtk+ with gtk.
> > Replace libhandy with libadwaita.
> > [native-inputs]: Remove gtk+:bin.
> > Add pkg-config.
>
> LGTM, thanks!
Thanks for checking, pushed.

Cheers
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 65701@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 65701
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch