[PATCH] gnu: capypdf: Update to 0.5.0.

  • Done
  • quality assurance status badge
Details
2 participants
  • Liliana Marie Prikler
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Liliana Marie Prikler
Severity
normal
L
L
Liliana Marie Prikler wrote on 2 Sep 2023 08:52
(address . guix-patches@gnu.org)
648551d4a8f57360a49eaf6b90bd02efff186bcc.1693637587.git.liliana.prikler@gmail.com
* gnu/packages/pdf.scm (capypdf): Update to 0.5.0.
[arguments]<#:configure-flags>: Add “-Dcpp_std=c++23”
<#:phases>: Drop ‘add-missing-header’.
---
gnu/packages/pdf.scm | 10 +++-------
1 file changed, 3 insertions(+), 7 deletions(-)

Toggle diff (38 lines)
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index e270bdf27f..b71add6f25 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -117,7 +117,7 @@ (define-module (gnu packages pdf)
(define-public capypdf
(package
(name "capypdf")
- (version "0.4.0")
+ (version "0.5.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -125,18 +125,14 @@ (define-public capypdf
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "1kn46n3j5fygivmd6ldnv8vdwfv48ffaizq61yy4z9w2jm6fgxim"))))
+ (base32 "1mb3i0jq04gg5cm1l07mn9kal5s748miql97j6fpaf1x1j2lcrsx"))))
(build-system meson-build-system)
(arguments
(list #:meson meson/newer
+ #:configure-flags #~(list "-Dcpp_std=c++23")
#:test-options '(list "plainc")
#:phases
#~(modify-phases %standard-phases
- (add-after 'unpack 'add-missing-header
- (lambda _
- (substitute* "src/pdfgen.cpp"
- (("#include <cassert>" all)
- (string-append all "\n#include <unistd.h>")))))
(add-after 'unpack 'fix-glib-application-flags
(lambda _
;; XXX: remove when bumping glib

base-commit: 9179775b0535ddf038d45f1355f759c4d6dc40dc
--
2.41.0
M
M
Maxim Cournoyer wrote on 5 Sep 2023 13:50
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)(address . 65694@debbugs.gnu.org)
87h6o8n8ix.fsf@gmail.com
Hi,

Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

Toggle quote (31 lines)
> * gnu/packages/pdf.scm (capypdf): Update to 0.5.0.
> [arguments]<#:configure-flags>: Add “-Dcpp_std=c++23”
> <#:phases>: Drop ‘add-missing-header’.
> ---
> gnu/packages/pdf.scm | 10 +++-------
> 1 file changed, 3 insertions(+), 7 deletions(-)
>
> diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
> index e270bdf27f..b71add6f25 100644
> --- a/gnu/packages/pdf.scm
> +++ b/gnu/packages/pdf.scm
> @@ -117,7 +117,7 @@ (define-module (gnu packages pdf)
> (define-public capypdf
> (package
> (name "capypdf")
> - (version "0.4.0")
> + (version "0.5.0")
> (source (origin
> (method git-fetch)
> (uri (git-reference
> @@ -125,18 +125,14 @@ (define-public capypdf
> (commit version)))
> (file-name (git-file-name name version))
> (sha256
> - (base32 "1kn46n3j5fygivmd6ldnv8vdwfv48ffaizq61yy4z9w2jm6fgxim"))))
> + (base32 "1mb3i0jq04gg5cm1l07mn9kal5s748miql97j6fpaf1x1j2lcrsx"))))
> (build-system meson-build-system)
> (arguments
> (list #:meson meson/newer
> + #:configure-flags #~(list "-Dcpp_std=c++23")

The build fails otherwise?

LGTM otherwise!

--
Thanks,
Maxim
L
L
Liliana Marie Prikler wrote on 5 Sep 2023 19:02
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)(address . 65694@debbugs.gnu.org)
8c20340ed159c0e80271cdb7860ceb0be518de82.camel@gmail.com
Am Dienstag, dem 05.09.2023 um 07:50 -0400 schrieb Maxim Cournoyer:
Toggle quote (38 lines)
> Hi,
>
> Liliana Marie Prikler <liliana.prikler@gmail.com> writes:
>
> > * gnu/packages/pdf.scm (capypdf): Update to 0.5.0.
> > [arguments]<#:configure-flags>: Add “-Dcpp_std=c++23”
> > <#:phases>: Drop ‘add-missing-header’.
> > ---
> >  gnu/packages/pdf.scm | 10 +++-------
> >  1 file changed, 3 insertions(+), 7 deletions(-)
> >
> > diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
> > index e270bdf27f..b71add6f25 100644
> > --- a/gnu/packages/pdf.scm
> > +++ b/gnu/packages/pdf.scm
> > @@ -117,7 +117,7 @@ (define-module (gnu packages pdf)
> >  (define-public capypdf
> >    (package
> >      (name "capypdf")
> > -    (version "0.4.0")
> > +    (version "0.5.0")
> >      (source (origin
> >                (method git-fetch)
> >                (uri (git-reference
> > @@ -125,18 +125,14 @@ (define-public capypdf
> >                      (commit version)))
> >                (file-name (git-file-name name version))
> >                (sha256
> > -               (base32
> > "1kn46n3j5fygivmd6ldnv8vdwfv48ffaizq61yy4z9w2jm6fgxim"))))
> > +               (base32
> > "1mb3i0jq04gg5cm1l07mn9kal5s748miql97j6fpaf1x1j2lcrsx"))))
> >      (build-system meson-build-system)
> >      (arguments
> >       (list #:meson meson/newer
> > +           #:configure-flags #~(list "-Dcpp_std=c++23")
>
> The build fails otherwise?
Yes, the file contains a very non-standard value for cpp_std, and it's
meant only for the big non free C++ compiler.

Cheers
M
M
Maxim Cournoyer wrote on 6 Sep 2023 03:07
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)(address . 65694@debbugs.gnu.org)
87h6o8ds8z.fsf@gmail.com
Hi,

Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

[...]

Toggle quote (9 lines)
>> >      (build-system meson-build-system)
>> >      (arguments
>> >       (list #:meson meson/newer
>> > +           #:configure-flags #~(list "-Dcpp_std=c++23")
>>
>> The build fails otherwise?
> Yes, the file contains a very non-standard value for cpp_std, and it's
> meant only for the big non free C++ compiler.

Got it.

--
Thanks,
Maxim
L
L
Liliana Marie Prikler wrote on 9 Sep 2023 10:25
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)(address . 65694-done@debbugs.gnu.org)
54e6695ce7ff5e3b4ef34d5e34a49b1c5b7af328.camel@gmail.com
Am Dienstag, dem 05.09.2023 um 21:07 -0400 schrieb Maxim Cournoyer:
Toggle quote (16 lines)
> Hi,
>
> Liliana Marie Prikler <liliana.prikler@gmail.com> writes:
>
> [...]
>
> > > >      (build-system meson-build-system)
> > > >      (arguments
> > > >       (list #:meson meson/newer
> > > > +           #:configure-flags #~(list "-Dcpp_std=c++23")
> > >
> > > The build fails otherwise?
> > Yes, the file contains a very non-standard value for cpp_std, and
> > it's meant only for the big non free C++ compiler.
>
> Got it.
Pushed now.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 65694@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 65694
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch