[PATCH 1/2] gnu: Add r-strawr.

  • Done
  • quality assurance status badge
Details
2 participants
  • Navid Afkhami
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Navid Afkhami
Severity
normal

Debbugs page

Navid Afkhami wrote 2 years ago
(address . guix-patches@gnu.org)(name . Navid Afkhami)(address . navid.afkhami@mdc-berlin.de)
646a45304d13b4544a475fc2ce490faee83496d8.1693601111.git.navid.afkhami@mdc-berlin.de
* gnu/packages/cran.scm (r-strawr): New variable.
---
gnu/packages/cran.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 4ec6b802ff..adf2d4c32a 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -8287,6 +8287,28 @@ (define-public r-statsexpressions
for ggstatsplot.")
(license license:gpl3)))
+(define-public r-strawr
+ (package
+ (name "r-strawr")
+ (version "0.0.91")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "strawr" version))
+ (sha256
+ (base32
+ "1nbcn20g3f3f5x9sscj3020n5h4iaphr70s90n2fz31vc4snzq2m"))))
+ (properties `((upstream-name . "strawr")))
+ (build-system r-build-system)
+ (inputs (list curl openssh openssl zlib))
+ (propagated-inputs (list r-rcpp))
+ (home-page "https://github.com/aidenlab/straw/tree/master/R")
+ (synopsis "Fast Implementation of Reading/Dump for .hic Files")
+ (description
+ "API for efficient .hic file data extraction with programmatic matrix access.
+It doesn't store the pointer data for all the matrices, only theone
+queried, and currently we are only supporting matrices.")
+ (license license:expat)))
+
(define-public r-stringdist
(package
(name "r-stringdist")

base-commit: 7309da3ba64a191f074807275d8c5661a25c035c
prerequisite-patch-id: 70b98dde8ca4056fb8bd1b731716853ac2c9f0a1
--
2.34.1
Ricardo Wurmus wrote 2 years ago
(address . 65689-done@debbugs.gnu.org)
87ledodhx6.fsf@elephly.net
Applied with minor changes. Thank you!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 65689@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 65689
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help