[PATCH 1/2] gnu: simh: Update to 3.12-4.

  • Done
  • quality assurance status badge
Details
2 participants
  • iyzsong
  • Maxim Cournoyer
Owner
unassigned
Submitted by
iyzsong
Severity
normal
I
I
iyzsong wrote on 1 Sep 2023 16:51
(address . guix-patches@gnu.org)(name . ???)(address . iyzsong@member.fsf.org)
37f99d5eea2fc5a389cb3e498e4af8c75b37890b.1693579858.git.iyzsong@member.fsf.org
From: ??? <iyzsong@member.fsf.org>

* gnu/packages/simh.scm (simh): Update to 3.12-4.
[source]: Switch to url-fetch.
[native-inputs]: Add unzip.
[arguments]: Adjust make-flags.
---
gnu/packages/simh.scm | 40 ++++++++++++++++++++++++----------------
1 file changed, 24 insertions(+), 16 deletions(-)

Toggle diff (72 lines)
diff --git a/gnu/packages/simh.scm b/gnu/packages/simh.scm
index 81d26bbde0..2cf92516ba 100644
--- a/gnu/packages/simh.scm
+++ b/gnu/packages/simh.scm
@@ -23,39 +23,47 @@ (define-module (gnu packages simh)
#:use-module (guix download)
#:use-module (guix git-download)
#:use-module (guix build-system gnu)
- #:use-module (gnu packages admin))
+ #:use-module (guix utils)
+ #:use-module (gnu packages admin)
+ #:use-module (gnu packages compression))
(define-public simh
(package
(name "simh")
- (version "3.9-0")
+ (version "3.12-4")
(source
(origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/simh/simh")
- (commit (string-append "v" version))))
+ (method url-fetch)
+ (uri (list (string-append
+ "http://simh.trailing-edge.com/sources/simhv"
+ (string-delete #\. version) ".zip")
+ (string-append
+ "http://simh.trailing-edge.com/sources/archive/simhv"
+ (string-delete #\. version) ".zip")))
(sha256
- (base32 "1jiq6shj6a9xvzacvmyhxxd6xdyica8q4006qqjh5mh96rxrp15c"))
- (file-name (git-file-name name version))))
+ (base32 "1i78c1x8xjiwy9dd2ss0mk3f1v9pmcjb4zc37ikqnjarsfqj2nm0"))))
(build-system gnu-build-system)
+ (native-inputs
+ (list unzip))
(inputs
(list libpcap))
(arguments
- '(#:tests? #f
+ `(#:tests? #f
#:make-flags (list
- "LDFLAGS=-lm"
- (string-append "INCPATH="
- (assoc-ref %build-inputs "libpcap")
- "/include")
- (string-append "LIBPATH="
- (assoc-ref %build-inputs "libpcap")
- "/lib"))
+ (string-append "GCC=" ,(cc-for-target) " -fcommon"))
+ #:modules ((ice-9 string-fun)
+ ,@%gnu-build-system-modules)
#:phases
(modify-phases %standard-phases
(delete 'configure)
(add-before 'build 'prepare-build
(lambda _
+ (substitute* "makefile"
+ (("LIBPATH:=/usr/lib")
+ (string-append "LIBPATH:="
+ (string-replace-substring
+ (getenv "LIBRARY_PATH") ":" " ")))
+ (("export LIBRARY_PATH = .*") ""))
(mkdir "BIN")))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)

base-commit: 4e531e55dcdc99c83bcfe3eec67c3fd95c7b6ca7
--
2.41.0
I
I
iyzsong wrote on 1 Sep 2023 16:53
[PATCH 2/2] gnu: simh: Use G-Expressions.
(address . 65681@debbugs.gnu.org)(name . ???)(address . iyzsong@member.fsf.org)
5dcaf8f1d76f5ebac8dfd128c4ad5b465898caa4.1693579858.git.iyzsong@member.fsf.org
From: ??? <iyzsong@member.fsf.org>

* gnu/packages/simh.scm (simh)[arguments]: Convert to list of G-Expressions.
---
gnu/packages/simh.scm | 70 +++++++++++++++++++++----------------------
1 file changed, 35 insertions(+), 35 deletions(-)

Toggle diff (90 lines)
diff --git a/gnu/packages/simh.scm b/gnu/packages/simh.scm
index 2cf92516ba..9f5c04d8fb 100644
--- a/gnu/packages/simh.scm
+++ b/gnu/packages/simh.scm
@@ -19,6 +19,7 @@
(define-module (gnu packages simh)
#:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix gexp)
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix git-download)
@@ -48,41 +49,40 @@ (define-public simh
(inputs
(list libpcap))
(arguments
- `(#:tests? #f
- #:make-flags (list
- (string-append "GCC=" ,(cc-for-target) " -fcommon"))
- #:modules ((ice-9 string-fun)
- ,@%gnu-build-system-modules)
- #:phases
- (modify-phases %standard-phases
- (delete 'configure)
- (add-before 'build 'prepare-build
- (lambda _
- (substitute* "makefile"
- (("LIBPATH:=/usr/lib")
- (string-append "LIBPATH:="
- (string-replace-substring
- (getenv "LIBRARY_PATH") ":" " ")))
- (("export LIBRARY_PATH = .*") ""))
- (mkdir "BIN")))
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (bin (string-append out "/bin/"))
- (lib (string-append out "/lib/simh/")))
- (mkdir-p bin)
- (mkdir-p lib)
- (for-each
- (lambda (file)
- (copy-file file (string-append bin
- "simh-"
- (basename file))))
- (find-files "BIN"))
- (for-each
- (lambda (file)
- (copy-file file (string-append lib
- (basename file))))
- (find-files "VAX" "bin$"))))))))
+ (list #:tests? #f
+ #:make-flags
+ #~(list (string-append "GCC=" #$(cc-for-target) " -fcommon"))
+ #:modules `((ice-9 string-fun)
+ ,@%gnu-build-system-modules)
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure)
+ (add-before 'build 'prepare-build
+ (lambda _
+ (substitute* "makefile"
+ (("LIBPATH:=/usr/lib")
+ (string-append "LIBPATH:="
+ (string-replace-substring
+ (getenv "LIBRARY_PATH") ":" " ")))
+ (("export LIBRARY_PATH = .*") ""))
+ (mkdir "BIN")))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin/"))
+ (lib (string-append out "/lib/simh/")))
+ (mkdir-p bin)
+ (mkdir-p lib)
+ (for-each (lambda (file)
+ (copy-file file
+ (string-append bin "simh-"
+ (basename file))))
+ (find-files "BIN"))
+ (for-each (lambda (file)
+ (copy-file file
+ (string-append lib
+ (basename file))))
+ (find-files "VAX" "bin$"))))))))
(home-page "http://simh.trailing-edge.com")
(synopsis "Collection of simulators from The Computer History Simulation
Project")
--
2.41.0
M
M
Maxim Cournoyer wrote on 6 Sep 2023 02:51
Re: bug#65681: [PATCH 1/2] gnu: simh: Update to 3.12-4.
(address . iyzsong@envs.net)
87bkegf7ix.fsf_-_@gmail.com
Hi,

Series installed :-).

--
Thanks,
Maxim
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 65681@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 65681
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch