(address . guix-patches@gnu.org)
From c546257438e4e824ddf54351b77a754d2f466567 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?R=C3=A9mi=20Teissier?= <rteissier.code@chillpc.fr>
Date: Thu, 31 Aug 2023 15:17:28 +0200
Subject: [PATCH] gnu: Add antifennel.
---
gnu/packages/lua.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)
Toggle diff (44 lines)
diff --git a/gnu/packages/lua.scm b/gnu/packages/lua.scm
index 405f8511cb..9f80b2017c 100644
--- a/gnu/packages/lua.scm
+++ b/gnu/packages/lua.scm
@@ -1226,6 +1226,37 @@ (define-public fennel
system.")
(license license:expat)))
+(define-public antifennel
+ (package
+ (version "0.2.0")
+ (name "antifennel")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~technomancy/antifennel")
+ (commit version)))
+ (sha256
+ (base32
+ "1hd9h17q31b3gg88c657zq4han4air2ag55rrakbmcpy6n8acsqc"))
+ (file-name (git-file-name name version))))
+ (build-system gnu-build-system)
+ (inputs (list lua luajit))
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (delete 'configure)
+ (delete 'check)
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((bin (string-append (assoc-ref outputs "out")
+ "/bin")))
+ (install-file "antifennel" bin)))))))
+ (home-page "https://git.sr.ht/~technomancy/antifennel")
+ (synopsis "Turn Lua code into Fennel code")
+ (description
+ "Turn Lua code into Fennel code. This compiler does the opposite
+ of what the Fennel compiler does.")
+ (license (list license:expat))))
+
(define-public fnlfmt
(package
(name "fnlfmt")
--
2.40.1