[PATCH] gnu: Add emacs-flymake-guile.

  • Done
  • quality assurance status badge
Details
2 participants
  • Andrew Tropin
  • Distopico
Owner
unassigned
Submitted by
Distopico
Severity
normal
D
D
Distopico wrote on 31 Aug 2023 03:24
(address . guix-patches@gnu.org)(name . Distopico)(address . distopico@riseup.net)
20230831012433.2668-1-distopico@riseup.net
* gnu/packages/emacs-xyz.scm (emacs-flymake-guile): New variable.
---

* gnu/packages/emacs-xyz.scm (emacs-flymake-guile): New variable.
gnu/packages/emacs-xyz.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (45 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 3eaf215134..fb1940262b 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -132,6 +132,7 @@
;;; Copyright © 2023 Fabio Natali <me@fabionatali.com>
;;; Copyright © 2023 Arnaud Lechevallier <arnaud.lechevallier@free.fr>
;;; Copyright © 2023 Ahmad Draidi <a.r.draidi@redscript.org>
+;;; Copyright © 2023 Camilo Q.S. (Distopico) <distopico@riseup.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2497,6 +2498,30 @@ (define-public emacs-flymake-collection
modes.")
(license license:expat)))
+(define-public emacs-flymake-guile
+ (package
+ (name "emacs-flymake-guile")
+ (version "0.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url
+ "https://framagit.org/flymake-backends/flymake-guile.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "044k5rjc6bxpb1bsnlclc5n86vvj8gqkf974np9kcb3fgdrwvbqf"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-flymake-quickdef))
+ (home-page "https://framagit.org/flymake-backends/flymake-guile")
+ (synopsis "GNU Guile support for Flymake")
+ (description
+ "This package provides a Flymake backend for GNU Guile using @code{guild
+compile}.")
+ (license license:gpl3+)))
+
(define-public emacs-flymake-popon
(package
(name "emacs-flymake-popon")
--
2.41.0
D
D
Distopico wrote on 6 Sep 2023 02:46
[PATCH v2] gnu: Add emacs-flymake-guile.
(address . 65643@debbugs.gnu.org)(name . Distopico)(address . distopico@riseup.net)
20230906004729.2588-1-distopico@riseup.net
From v1 -> v2 remove flymake-quickdef dependency and update version.

* gnu/packages/emacs-xyz.scm (emacs-flymake-guile): New variable.
---

* gnu/packages/emacs-xyz.scm (emacs-flymake-guile): New variable.

gnu/packages/emacs-xyz.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 3eaf215134..463cae82fe 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -132,6 +132,7 @@
;;; Copyright © 2023 Fabio Natali <me@fabionatali.com>
;;; Copyright © 2023 Arnaud Lechevallier <arnaud.lechevallier@free.fr>
;;; Copyright © 2023 Ahmad Draidi <a.r.draidi@redscript.org>
+;;; Copyright © 2023 Camilo Q.S. (Distopico) <distopico@riseup.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2497,6 +2498,29 @@ (define-public emacs-flymake-collection
modes.")
(license license:expat)))
+(define-public emacs-flymake-guile
+ (package
+ (name "emacs-flymake-guile")
+ (version "0.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url
+ "https://framagit.org/flymake-backends/flymake-guile.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0cb2wcn34bzj93y7s1g2b2sxv79vqihb3a5n0rhxbrddfila95hh"))))
+ (build-system emacs-build-system)
+ (home-page "https://framagit.org/flymake-backends/flymake-guile")
+ (synopsis "GNU Guile support for Flymake")
+ (description
+ "This package provides a Flymake backend for GNU Guile using @code{guild
+compile}.")
+ (license license:gpl3+)))
+
(define-public emacs-flymake-popon
(package
(name "emacs-flymake-popon")
--
2.41.0
A
A
Andrew Tropin wrote on 7 Sep 2023 14:31
87y1hip3ka.fsf@trop.in
On 2023-09-05 19:46, Distopico wrote:

Hi Camilo!

Toggle quote (5 lines)
> From v1 -> v2 remove flymake-quickdef dependency and update version.
>
> * gnu/packages/emacs-xyz.scm (emacs-flymake-guile): New variable.
> ---

Under --- is a better place for reroll notes, text here doesn't go to
commit message body.

Toggle quote (49 lines)
>
> * gnu/packages/emacs-xyz.scm (emacs-flymake-guile): New variable.
>
> gnu/packages/emacs-xyz.scm | 24 ++++++++++++++++++++++++
> 1 file changed, 24 insertions(+)
>
> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
> index 3eaf215134..463cae82fe 100644
> --- a/gnu/packages/emacs-xyz.scm
> +++ b/gnu/packages/emacs-xyz.scm
> @@ -132,6 +132,7 @@
> ;;; Copyright © 2023 Fabio Natali <me@fabionatali.com>
> ;;; Copyright © 2023 Arnaud Lechevallier <arnaud.lechevallier@free.fr>
> ;;; Copyright © 2023 Ahmad Draidi <a.r.draidi@redscript.org>
> +;;; Copyright © 2023 Camilo Q.S. (Distopico) <distopico@riseup.net>
> ;;;
> ;;; This file is part of GNU Guix.
> ;;;
> @@ -2497,6 +2498,29 @@ (define-public emacs-flymake-collection
> modes.")
> (license license:expat)))
>
> +(define-public emacs-flymake-guile
> + (package
> + (name "emacs-flymake-guile")
> + (version "0.5")
> + (source
> + (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url
> + "https://framagit.org/flymake-backends/flymake-guile.git")
> + (commit version)))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> + "0cb2wcn34bzj93y7s1g2b2sxv79vqihb3a5n0rhxbrddfila95hh"))))
> + (build-system emacs-build-system)
> + (home-page "https://framagit.org/flymake-backends/flymake-guile")
> + (synopsis "GNU Guile support for Flymake")
> + (description
> + "This package provides a Flymake backend for GNU Guile using @code{guild
> +compile}.")
> + (license license:gpl3+)))
> +
> (define-public emacs-flymake-popon
> (package
> (name "emacs-flymake-popon")

Thank you for the package, applied, merged, updated commit message,
pushed.

--
Best regards,
Andrew Tropin
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEKEGaxlA4dEDH6S/6IgjSCVjB3rAFAmT5wrUACgkQIgjSCVjB
3rD97A//a6N01NC+MvtmIQ4XX7YO78DOLr4kievNTOa8r6vqpG5sWRSUCnYrdGnB
FrYya+ue6ra97RkaCFL1IgRUTDKXOu9NfN2l+/Ngxqfdbo3m11+mHU8AcOrT3w+x
ZrKg4Gu+0NzjMCmC0sX0G7RXJLxPQQ5/cM6Iqbh9Km/k8c7EMaL+6sUY0C3yT7rL
WJiTDUUikxDjKSy/XxISDCZj4TxwfUEbLWB1QeYpgbc1vebscCAIn491Ub9wwHHx
1g/4osiXfgRETyolE7ROi6z9hiqIBCii03pFDZq3O3zaTblWbIiDiwHXtOMqaaQh
Z1l+Fk19Pe7rWC0AINDATxhZYSYSe1UEceDrSpLM/rZ1zOf3BTR5YNUjbnktXKhy
wqTSZNAjQ93t9Rs2CqE6Nvm1Y9Wx2QQOypEecZcr5ZE0YB3vZpgpzdrLTXcO7rQo
QDW3kcHtMaEwm7VjHnNfcb7wwAyp0Sw/cppjpgxnae/nCMalURWZucR0lszEIiXK
Rd5oScRhibxIU6WO9jwCZBvybkiA9j3LwkHEIKhSnLoFDjK84P0/dOcmL9WvK9Zd
WuE6NezfxZsmB02J6VxkgoLNp2Ff1zGs8JCfE6+pnHZ2OnTK9+eS2ryCWrwPdb3e
weIkBfrQDuyi0MR3weNMg3EVaqv91pWyFUEuABKstV3ijyGkkFQ=
=4BUH
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 65643@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 65643
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch