python-selenium raises a WebDriverException because driver is not found in PATH

  • Open
  • quality assurance status badge
Details
One participant
  • jgart
Owner
unassigned
Submitted by
jgart
Severity
normal
J
(address . bug-guix@gnu.org)(address . lars@6xq.net)
613a2c473a3924dba39b181aeadf1ac9@dismail.de
Hi Guixers,

I'm adding this as a future TODO for myself or anyone else that would like to work on it.

python-selenium fails with the following when webdriver.Chrome is called:

driver = webdriver.Chrome('./chromedriver')
File "/gnu/store/hz5k0k0lggsn6j2ij49xriawbwrq988n-profile/lib/python3.10/site-packages/selenium/webdriver/chrome/webdriver.py", line 73, in __init__
self.service.start()
File "/gnu/store/hz5k0k0lggsn6j2ij49xriawbwrq988n-profile/lib/python3.10/site-packages/selenium/webdriver/common/service.py", line 81, in start
raise WebDriverException(
selenium.common.exceptions.WebDriverException: Message: 'chromedriver' executable needs to be in PATH. Please see https://sites.google.com/a/chromium.org/chromedriver/home

See what the nixpkgs package did here:


Related references:


best,

jgart
?