python-selenium raises a WebDriverException because driver is not found in PATH

  • Open
  • quality assurance status badge
Details
One participant
  • jgart
Owner
unassigned
Submitted by
jgart
Severity
normal

Debbugs page

jgart wrote 2 years ago
(address . bug-guix@gnu.org)(address . lars@6xq.net)
613a2c473a3924dba39b181aeadf1ac9@dismail.de
Hi Guixers,

I'm adding this as a future TODO for myself or anyone else that would like to work on it.

python-selenium fails with the following when webdriver.Chrome is called:

driver = webdriver.Chrome('./chromedriver')
File "/gnu/store/hz5k0k0lggsn6j2ij49xriawbwrq988n-profile/lib/python3.10/site-packages/selenium/webdriver/chrome/webdriver.py", line 73, in __init__
self.service.start()
File "/gnu/store/hz5k0k0lggsn6j2ij49xriawbwrq988n-profile/lib/python3.10/site-packages/selenium/webdriver/common/service.py", line 81, in start
raise WebDriverException(
selenium.common.exceptions.WebDriverException: Message: 'chromedriver' executable needs to be in PATH. Please see https://sites.google.com/a/chromium.org/chromedriver/home

See what the nixpkgs package did here:


Related references:


best,

jgart
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 65633@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 65633
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help