[PATCH emacs-team] gnu: emacs-rainbow-delimiters: Fix tests.

  • Done
  • quality assurance status badge
Details
2 participants
  • Andrew Tropin
  • Hilton Chain
Owner
unassigned
Submitted by
Hilton Chain
Severity
normal
H
H
Hilton Chain wrote on 29 Aug 2023 05:23
(address . guix-patches@gnu.org)(name . Hilton Chain)(address . hako@ultrarare.space)
c57490c0484058b749c32e01041a09b110778274.1693278104.git.hako@ultrarare.space
* gnu/packages/emacs-xyz.scm (emacs-rainbow-delimiters): Adjust tests for
Emacs 29.
---
gnu/packages/emacs-xyz.scm | 6 ++++++
1 file changed, 6 insertions(+)

Toggle diff (21 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 3514ae5fbe..1318ac57ae 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -14171,6 +14171,12 @@ (define-public emacs-rainbow-delimiters
(url "https://github.com/Fanael/rainbow-delimiters")
(commit version)))
(file-name (git-file-name name version))
+ ;; Fix tests for Emacs 29
+ ;; https://github.com/Fanael/rainbow-delimiters/pull/78
+ (modules '((guix build utils)))
+ (snippet '(substitute* "rainbow-delimiters-test.el"
+ (("category c-type " all)
+ (string-append all "c-<>-c-types-set "))))
(sha256
(base32
"179mzsd8nvlr0ym9zf9fgdngsgxj3kdgbjblynliirsyk05ssrwc"))))

base-commit: 9d074e16c7a9879d67c348c7b2d70b725adfbdfa
--
2.41.0
A
A
Andrew Tropin wrote on 3 Sep 2023 06:20
87y1hn51mr.fsf@trop.in
On 2023-08-29 11:23, Hilton Chain wrote:

Toggle quote (26 lines)
> * gnu/packages/emacs-xyz.scm (emacs-rainbow-delimiters): Adjust tests for
> Emacs 29.
> ---
> gnu/packages/emacs-xyz.scm | 6 ++++++
> 1 file changed, 6 insertions(+)
>
> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
> index 3514ae5fbe..1318ac57ae 100644
> --- a/gnu/packages/emacs-xyz.scm
> +++ b/gnu/packages/emacs-xyz.scm
> @@ -14171,6 +14171,12 @@ (define-public emacs-rainbow-delimiters
> (url "https://github.com/Fanael/rainbow-delimiters")
> (commit version)))
> (file-name (git-file-name name version))
> + ;; Fix tests for Emacs 29
> + ;; https://github.com/Fanael/rainbow-delimiters/pull/78
> + (modules '((guix build utils)))
> + (snippet '(substitute* "rainbow-delimiters-test.el"
> + (("category c-type " all)
> + (string-append all "c-<>-c-types-set "))))
> (sha256
> (base32
> "179mzsd8nvlr0ym9zf9fgdngsgxj3kdgbjblynliirsyk05ssrwc"))))
>
> base-commit: 9d074e16c7a9879d67c348c7b2d70b725adfbdfa

I see the the pull request in the comment merged, is this patch still
relevant?

--
Best regards,
Andrew Tropin
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEKEGaxlA4dEDH6S/6IgjSCVjB3rAFAmT0CXwACgkQIgjSCVjB
3rDQWw/+I/qO98dO+eQbZ1FME/9F5KAeWBsbyervm5NtIwmbcSjceMTTUfIm0ir0
QdwpX2A57PNOVb0vmNpEMc8gDsaKLqr+7Af6jjKU9fn63YTVDqx3Ry+KcubzfzyQ
rllwYfQe4qUn5LIm81p5WfP8R8fllvIqHEp0w7Ri1IXuT1MXAdj0mR+4OZ6G/RY4
0iFNeDasvEFbDGJOiAb0yacVl2/zuIateGu5TM3Hv/roP4Ta35hdiDhNf9nRaWQ9
m6NzMWAluajWNC74Krtnem7uTgpqrxbr2UJSBAj69K1Zvn1I89RMDe2658P4kYKx
jPQEjQGp6DHIthQTaytctshafUtiOR3aZdJdu8sFpd0uDGBK+38mJPkIojFg1Fwn
qQCzPWf36FTin3npXft7JJa9dHJGuGqI++l1HYXCZhBfc4ePquxWyU+PUl+3cOZP
O7X56QYS9dom+EV6I8u6DfW1+0MSgCG/lBuuo+t3vERr4wDJ68JQglJOS8E//5d4
4+IwyMivrVxOzcU72oroQHDj9ioo7Sj+yljbIYAmIUHsXiF90+sSXgSi7qp9xa5i
45DkHroScq5rBPG8UZSgkwUl2c9So+86YeXthpJJsBz3YPzZIVbBZcAcRh4tzx9l
jDKQk/q3NOHvp2USdBG9x6yBt206wzKpD8cIVZ7zJfEE7czBjsU=
=UHaD
-----END PGP SIGNATURE-----

H
H
Hilton Chain wrote on 3 Sep 2023 09:35
(name . Andrew Tropin)(address . andrew@trop.in)
87il8r4slm.wl-hako@ultrarare.space
On Sun, 03 Sep 2023 12:20:12 +0800,
Andrew Tropin wrote:
Toggle quote (4 lines)
>
> I see the the pull request in the comment merged, is this patch still
> relevant?

Still relevant. I opened the pull request right before sending this
patch, it's now merged but not in a release.
A
A
Andrew Tropin wrote on 4 Sep 2023 07:06
(name . Hilton Chain)(address . hako@ultrarare.space)
87msy2mssk.fsf@trop.in
On 2023-09-03 15:35, Hilton Chain wrote:

Toggle quote (9 lines)
> On Sun, 03 Sep 2023 12:20:12 +0800,
> Andrew Tropin wrote:
>>
>> I see the the pull request in the comment merged, is this patch still
>> relevant?
>
> Still relevant. I opened the pull request right before sending this
> patch, it's now merged but not in a release.

I see. Thank you for your work! Applied, checked the build, merged.

--
Best regards,
Andrew Tropin
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEKEGaxlA4dEDH6S/6IgjSCVjB3rAFAmT1ZbsACgkQIgjSCVjB
3rAhOA//aUTJnef7ktgiH8ziLnyI06k6qvQtSxunL0/XYfTsFA+YQSEZ6rL/bFf5
BZbD8ucSkzxuCp8ooAbAOz6oVD/Q2aXYRM98Fkxurwxl01//cYKdiOHMw5gjht8a
ECEJj7qjIeICPVbcjXMtJdKr20khycOEEzwA8t2kreSbpX5AbiyRRolilIcrRSJ4
qofsoNPuWH0xpDz8BVKorFwJJRQ+q8sEGHsod4ZoFOPDYxxf1m3pGNAaj3xlqR1l
8WiphQxiE6s28LVBFc1ykLLDCZsEaPKq9auV+y3XN5Uge0vLErcok3as/2NkKMFA
3AbnmHO/l6EdBukwV4DPI+RKGNneAWi5gMi9xbQF9VE/SDdw4R42WjdwGPQ3/mbK
2Wa9APpmYH8EgS5xFgENxku6U65skppj4Ek9/FKC2KXbk/CvJHv2LZ49ZENbVVTL
GqFC4uVjHaifv8LPGd2BtfrscNNDqLc5+G+5bc0lPrAkm9wUODxdU3UTanwh4F3/
rqQu4pVPpjkY6nsGmEqaNVdtCk4rIHRzXQPhqz8jDBaUMkHY2gxGm51zWEh2OpNZ
pjtZ+xCK94B7CdJbbVsDH4zu7uK9yxnqeBiDYAkx4Jr6wXZP3u1vRyAGiB/3VHuf
BtFrDJF0B6rHD4NFCH0fj9XvYK7ivV5G+YYZSj3gbNSHi34mWkw=
=iAsA
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 65589@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 65589
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch