[PATCH emacs-guix] elisp/guix-misc: Update Emacs Info-directory-list if needed

  • Done
  • quality assurance status badge
Details
2 participants
  • Janneke Nieuwenhuizen
  • Ludovic Courtès
Owner
unassigned
Submitted by
Janneke Nieuwenhuizen
Severity
normal
J
J
Janneke Nieuwenhuizen wrote on 28 Aug 2023 19:40
(address . guix-patches@gnu.org)
20230828174008.21189-1-janneke@gnu.org
* elisp/guix-misc.el (guix-set-emacs-environment): Set 'Info-directory-list'
when setting "INFOPATH" variable.
---
elisp/guix-misc.el | 6 ++++--
1 file changed, 4 insertions(+), 2 deletions(-)

Toggle diff (26 lines)
diff --git a/elisp/guix-misc.el b/elisp/guix-misc.el
index 93340a2..f4a7aaa 100644
--- a/elisp/guix-misc.el
+++ b/elisp/guix-misc.el
@@ -1,7 +1,7 @@
;;; guix-misc.el --- Miscellaneous definitions -*- lexical-binding: t -*-
;; Copyright © 2014–2018 Alex Kost <alezost@gmail.com>
-;; Copyright © 2018, 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
+;; Copyright © 2018, 2020, 2023 Janneke Nieuwenhuizen <janneke@gnu.org>
;; This file is part of Emacs-Guix.
@@ -244,7 +244,9 @@ If PROFILE is nil, use `guix-current-profile'."
path)))
(setenv variable value)
(when (equal variable "PATH")
- (setq exec-path (split-string value ":")))))))
+ (setq exec-path (split-string value ":")))
+ (when (equal variable "INFOPATH")
+ (setq Info-directory-list (split-string value ":")))))))
;;; Executing guix commands
--
2.41.0
L
L
Ludovic Courtès wrote on 9 Sep 2023 15:43
(name . Janneke Nieuwenhuizen)(address . janneke@gnu.org)(address . 65586@debbugs.gnu.org)
87a5tvxy0u.fsf@gnu.org
Hi,

Janneke Nieuwenhuizen <janneke@gnu.org> skribis:

Toggle quote (3 lines)
> * elisp/guix-misc.el (guix-set-emacs-environment): Set 'Info-directory-list'
> when setting "INFOPATH" variable.

LGTM, please push! :-)

Ludo’.
J
J
Janneke Nieuwenhuizen wrote on 9 Sep 2023 15:56
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 65586-done@debbugs.gnu.org)
87jzszpi0u.fsf@gnu.org
Ludovic Courtès writes:

Toggle quote (7 lines)
> Janneke Nieuwenhuizen <janneke@gnu.org> skribis:
>
>> * elisp/guix-misc.el (guix-set-emacs-environment): Set 'Info-directory-list'
>> when setting "INFOPATH" variable.
>
> LGTM, please push! :-)

Thanks! Pushed to master as 3fba3f46483aa8ad4482ca2ae02d83a6f0fefd46

Greetings,
Janneke

--
Janneke Nieuwenhuizen <janneke@gnu.org> | GNU LilyPond https://LilyPond.org
Freelance IT https://www.JoyOfSource.com| Avatar® https://AvatarAcademy.com
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 65586@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 65586
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch