[PATCH] services: vpn: Fix broken format string for wireguard dns.

  • Done
  • quality assurance status badge
Details
2 participants
  • Liliana Marie Prikler
  • Reily Siegel
Owner
unassigned
Submitted by
Reily Siegel
Severity
normal
R
R
Reily Siegel wrote on 28 Aug 2023 17:11
(address . guix-patches@gnu.org)
5c2f7432277e673fc725649bc90348410423f931.1693236027.git.mail@reilysiegel.com
* gnu/services/vpn.scm (wireguard-configuration-file): Fix broken format
string.
---
gnu/services/vpn.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/services/vpn.scm b/gnu/services/vpn.scm
index 9c8243d131..7fb4775757 100644
--- a/gnu/services/vpn.scm
+++ b/gnu/services/vpn.scm
@@ -820,7 +820,7 @@ (define (wireguard-configuration-file config)
(format #f "~@[ListenPort = ~a~]" #$port)
#$@(if (null? dns)
'()
- (list (format #f "~{DNS = ~{~a~^, ~}" dns)))))
+ (list (format #f "DNS = ~{~a~^, ~}" dns)))))
(mkdir #$output)
(chdir #$output)

base-commit: 4a49a89b09d07d96f4d6ef3c0ca93801370f7b20
L
L
Liliana Marie Prikler wrote on 9 Sep 2023 12:32
a6615cde86250f2b62619d7fa0207871a3d04ed8.camel@gmail.com
Am Montag, dem 28.08.2023 um 11:11 -0400 schrieb Reily Siegel:
Toggle quote (4 lines)
>
> * gnu/services/vpn.scm (wireguard-configuration-file): Fix broken
> format string.
> ---
LGTM, pushed.

Thanks
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 65582@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 65582
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch