[PATCH]: Update sbcl-iolib to 0.8.4-0.010b7a6

  • Done
  • quality assurance status badge
Details
2 participants
  • André A. Gomes
  • Guillaume Le Vaillant
Owner
unassigned
Submitted by
André A. Gomes
Severity
normal
A
A
André A. Gomes wrote on 28 Aug 2023 09:27
(address . guix-patches@gnu.org)(address . pierre@atlas.engineer)
87sf83k4or.fsf@gmail.com
Hi Guix,

Please find the patch attached. Thanks.


--
André A. Gomes
"You cannot even find the ruins..."
From 3a0b9ddc52b8c918b5a7fefa2d6a7c28b86e7b8e Mon Sep 17 00:00:00 2001
From: "Andre A. Gomes" <andremegafone@gmail.com>
Date: Mon, 28 Aug 2023 10:18:04 +0300
Subject: [PATCH] gnu: sbcl-iolib: Update to 0.8.4-0.010b7a6.

* gnu/packages/lisp-xyz.scm (sbcl-iolib): Update to 0.8.4.0.010b7a6.
---
gnu/packages/lisp-xyz.scm | 83 +++++++++++++++++++--------------------
1 file changed, 41 insertions(+), 42 deletions(-)

Toggle diff (99 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 01acd0299f..3526c4f253 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -7974,51 +7974,50 @@ (define-public ecl-swap-bytes
(sbcl-package->ecl-package sbcl-swap-bytes))
(define-public sbcl-iolib
- (package
- (name "sbcl-iolib")
- (version "0.8.4")
- (home-page "https://github.com/sionescu/iolib")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url home-page)
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1f43jqqqwp9n7xksqxw91myapsdbc2dxck6nd6flakbnp9haylyq"))))
- (build-system asdf-build-system/sbcl)
- (inputs
- `(("alexandria" ,sbcl-alexandria)
- ("bordeaux-threads" ,sbcl-bordeaux-threads)
- ("cffi" ,sbcl-cffi)
- ("idna" ,sbcl-idna)
- ("libfixposix" ,libfixposix)
- ("split-sequence" ,sbcl-split-sequence)
- ("swap-bytes" ,sbcl-swap-bytes)))
- (arguments
- '(#:asd-systems '("iolib"
- "iolib/os")
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'fix-paths
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "src/syscalls/ffi-functions-unix.lisp"
- (("\\(:default \"libfixposix\"\\)")
- (string-append
- "(:default \""
- (assoc-ref inputs "libfixposix") "/lib/libfixposix\")")))
- ;; Socket tests need Internet access, disable them.
- (substitute* "iolib.asd"
- (("\\(:file \"sockets\" :depends-on \\(\"pkgdcl\" \"defsuites\"\\)\\)")
- "")))))))
- (synopsis "Common Lisp I/O library")
- (description "IOlib is to be a better and more modern I/O library than
+ (let ((commit "010b7a6bdd2e918ebf2ec85edd3853179f01cb30")
+ (revision "0"))
+ (package
+ (name "sbcl-iolib")
+ (version (git-version "0.8.4" revision commit))
+ (home-page "https://github.com/sionescu/iolib")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1qqy2yhprkmdn2vmi69akf818q3n99gv8cacv6456af0wjm5p1ga"))))
+ (build-system asdf-build-system/sbcl)
+ (native-inputs
+ (list sbcl-fiveam pkg-config))
+ (inputs
+ (list sbcl-alexandria sbcl-bordeaux-threads sbcl-cffi sbcl-idna
+ libfixposix sbcl-split-sequence sbcl-swap-bytes))
+ (arguments
+ '(#:asd-systems '("iolib"
+ "iolib/os")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "src/syscalls/ffi-functions-unix.lisp"
+ (("\\(:default \"libfixposix\"\\)")
+ (string-append
+ "(:default \""
+ (assoc-ref inputs "libfixposix") "/lib/libfixposix\")")))
+ ;; Socket tests need Internet access, disable them.
+ (substitute* "iolib.asd"
+ (("\\(:file \"sockets\" :depends-on \\(\"pkgdcl\" \"defsuites\"\\)\\)")
+ "")))))))
+ (synopsis "Common Lisp I/O library")
+ (description "IOlib is to be a better and more modern I/O library than
the standard Common Lisp library. It contains a socket library, a DNS
resolver, an I/O multiplexer(which supports @code{select(2)}, @code{epoll(4)}
and @code{kqueue(2)}), a pathname library and file-system utilities.")
- (license license:expat)))
+ (license license:expat))))
(define-public cl-iolib
(let ((parent (sbcl-package->cl-source-package sbcl-iolib)))
--
2.41.0
G
G
Guillaume Le Vaillant wrote on 4 Sep 2023 09:45
(name . André A. Gomes)(address . andremegafone@gmail.com)(address . 65576-done@debbugs.gnu.org)
87cyyyjs9c.fsf@kitej
Patch applied as 2c6133295d7aaca3d130d73232075ea550862598.
Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCZPWLLw8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j/o+QD6Awj/zhUzBilQ2aR34RJA+wVaQzTuahmecQrr
5HOepDIBAIidXye9bKnCLoXvuZuNONgXOUH+ivd6ppuOyd45nUt/
=jKFs
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 65576@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 65576
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch