[PATCH] gnu: Add python-casa-formats-io.

  • Done
  • quality assurance status badge
Details
2 participants
  • Maxim Cournoyer
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal

Debbugs page

Sharlatan Hellseher wrote 2 years ago
(address . guix-patches@gnu.org)
189f2e7bd9694ea14bbb4f6e3eaaa440462503c1.1693168122.git.sharlatanus@gmail.com
* gnu/packages/astronomy.scm (python-casa-formats-io): New variable.

Co-Authored-By: Iliya Tikhonenko <tikhonenko@mpe.mpg.de>
---
gnu/packages/astronomy.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (46 lines)
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index e8499bb4b4..bcc3d8494a 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -1611,6 +1611,37 @@ (define-public python-bayesicfitting
Herschel.")
(license license:gpl3+)))
+(define-public python-casa-formats-io
+ (package
+ (name "python-casa-formats-io")
+ (version "0.2.1")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "casa-formats-io" version))
+ (sha256
+ (base32
+ "07cchih2ws6jf6q1a4xhkv0jk96s3w08kzxx9l1911wzqk0pw9pj"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'check 'build-extensions
+ (lambda _
+ (invoke "python" "setup.py" "build_ext" "--inplace"))))))
+ (native-inputs
+ (list python-pytest python-pytest-cov python-pytest-openfiles))
+ (propagated-inputs
+ (list python-astropy python-click python-dask python-numpy))
+ (home-page "https://casa-formats-io.readthedocs.io/")
+ (synopsis "Dask-based reader for CASA data")
+ (description
+ "The casa-formats-io package is a small package which implements functionality
+to read data stored in @acronym{CASA, Common Astronomy Software Applications}
+formats (such as .image datasets). This implementation is independent of and
+does not use casacore.")
+ (license license:lgpl2.0)))
+
(define-public python-ccdproc
(package
(name "python-ccdproc")

base-commit: 37cca1d87e18c257a9697110557a2bfaf9bc684b
--
2.40.1
Sharlatan Hellseher wrote 1 years ago
(address . 65571@debbugs.gnu.org)
CAO+9K5paiUbngJXt6KBwGOVXwy9RH4GdU0YDX7MHOM-=3NJ2xQ@mail.gmail.com
Hi,
A gentle ping on this one. QA as green as spring leaves :-)
--
… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.
Maxim Cournoyer wrote 1 years ago
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
87sf6t3vye.fsf@gmail.com
Hello,

Sharlatan Hellseher <sharlatanus@gmail.com> writes:

Toggle quote (46 lines)
> * gnu/packages/astronomy.scm (python-casa-formats-io): New variable.
>
> Co-Authored-By: Iliya Tikhonenko <tikhonenko@mpe.mpg.de>
> ---
> gnu/packages/astronomy.scm | 31 +++++++++++++++++++++++++++++++
> 1 file changed, 31 insertions(+)
>
> diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
> index e8499bb4b4..bcc3d8494a 100644
> --- a/gnu/packages/astronomy.scm
> +++ b/gnu/packages/astronomy.scm
> @@ -1611,6 +1611,37 @@ (define-public python-bayesicfitting
> Herschel.")
> (license license:gpl3+)))
>
> +(define-public python-casa-formats-io
> + (package
> + (name "python-casa-formats-io")
> + (version "0.2.1")
> + (source (origin
> + (method url-fetch)
> + (uri (pypi-uri "casa-formats-io" version))
> + (sha256
> + (base32
> + "07cchih2ws6jf6q1a4xhkv0jk96s3w08kzxx9l1911wzqk0pw9pj"))))
> + (build-system pyproject-build-system)
> + (arguments
> + (list
> + #:phases
> + #~(modify-phases %standard-phases
> + (add-before 'check 'build-extensions
> + (lambda _
> + (invoke "python" "setup.py" "build_ext" "--inplace"))))))
> + (native-inputs
> + (list python-pytest python-pytest-cov python-pytest-openfiles))
> + (propagated-inputs
> + (list python-astropy python-click python-dask python-numpy))
> + (home-page "https://casa-formats-io.readthedocs.io/")
> + (synopsis "Dask-based reader for CASA data")
> + (description
> + "The casa-formats-io package is a small package which implements functionality
> +to read data stored in @acronym{CASA, Common Astronomy Software Applications}
> +formats (such as .image datasets). This implementation is independent of and
> +does not use casacore.")
> + (license license:lgpl2.0)))

Applied, after adding some Texinfo sugar:

Toggle snippet (18 lines)
modified gnu/packages/astronomy.scm
@@ -1649,10 +1649,10 @@ (define-public python-casa-formats-io
(home-page "https://casa-formats-io.readthedocs.io/")
(synopsis "Dask-based reader for CASA data")
(description
- "The casa-formats-io package is a small package which implements functionality
-to read data stored in @acronym{CASA, Common Astronomy Software Applications}
-formats (such as .image datasets). This implementation is independent of and
-does not use casacore.")
+ "The @code{casa-formats-io} package is a small package which implements
+functionality to read data stored in @acronym{CASA, Common Astronomy Software
+Applications} formats (such as @file{.image} datasets). This implementation
+is independent of and does not use @code{casacore}.")
(license license:lgpl2.0)))
(define-public python-ccdproc

--
Thanks,
Maxim
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 65571@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 65571
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help