(address . guix-patches@gnu.org)(name . 宋文武)(address . iyzsong@member.fsf.org)
From: 宋文武 <iyzsong@member.fsf.org>
* gnu/packages/cpp.scm (chaiscript)[arguments]: Add fix-tests phase.
---
gnu/packages/cpp.scm | 9 +++++++++
1 file changed, 9 insertions(+)
Toggle diff (24 lines)
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 3b949198c7..4681963794 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -511,6 +511,15 @@ (define-public chaiscript
(sha256
(base32 "0i1c88rn1wwz8nf3dpapcdkk4w623m3nksfy5yjai10k9irkzy3c"))))
(build-system cmake-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-tests
+ (lambda _
+ ;; Its bundled catch2 fails to build with glibc-2.35.
+ (copy-file #$(file-append catch2 "/include/catch2/catch.hpp")
+ "unittests/catch.hpp"))))))
(home-page "https://chaiscript.com/")
(synopsis "Embedded scripting language designed for C++")
(description
base-commit: 8b4a248fc4765212a4103c4520ae1f901937df41
--
2.41.0