[PATCH 0/5] *** Patch for r-ggstatsplot plus its dependencies ***

  • Done
  • quality assurance status badge
Details
2 participants
  • Navid Afkhami
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Navid Afkhami
Severity
normal
N
N
Navid Afkhami wrote on 25 Aug 2023 15:10
(address . guix-patches@gnu.org)(name . Navid Afkhami)(address . navid.afkhami@mdc-berlin.de)
cover.1692968852.git.navid.afkhami@mdc-berlin.de
*** This patch includes r-ggstatsplot + its dependencies. Thank you for your review!***

Navid Afkhami (5):
gnu: Add r-wrs2.
gnu: Add r-statsexpressions.
gnu: Add r-mc2d.
gnu: Add r-ggstatsplot.
gnu: Add r-correlation.

gnu/packages/cran.scm | 154 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 154 insertions(+)


base-commit: 1c916c167b7eb1f2f8af2cf621aa1512b00b1033
prerequisite-patch-id: ab9aad8c0ca60c38323f24b41dd3d5b1c3286e10
prerequisite-patch-id: c57cd1d51559f364cccdc54030deb28d7692bf48
prerequisite-patch-id: fbceb485e63c38a57a5c46288287479afe028191
prerequisite-patch-id: c1337efaa4849347307f9818e4e81227b096fcc6
--
2.34.1
N
N
Navid Afkhami wrote on 25 Aug 2023 15:12
[PATCH 1/5] gnu: Add r-wrs2.
(address . 65535@debbugs.gnu.org)(name . Navid Afkhami)(address . navid.afkhami@mdc-berlin.de)
347cb06663e21608f65bbb5ab7afcbbc1296bbbc.1692968852.git.navid.afkhami@mdc-berlin.de
* gnu/packages/cran.scm (r-wrs2): New variable.
---
gnu/packages/cran.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 9226805717..667decab70 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -13269,6 +13269,30 @@ (define-public r-writexls
contains or can be specified by the user.")
(license license:gpl2+)))
+(define-public r-wrs2
+ (package
+ (name "r-wrs2")
+ (version "1.1-4")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "WRS2" version))
+ (sha256
+ (base32
+ "1838wy59cqd65s0bw6c24xcvx7zflypqcbgs35l9s2fj87vw2hdc"))))
+ (properties `((upstream-name . "WRS2")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-mass r-mc2d r-plyr r-reshape))
+ (native-inputs (list r-knitr))
+ (home-page "https://r-forge.r-project.org/projects/psychor/")
+ (synopsis "Collection of robust statistical methods")
+ (description
+ "R-wrs2 offers a range of strong stats methods from Wilcox WRS functions.
+It implements robust t-tests, both independent and dependent, robust ANOVA,
+including designs with between-within subjects, quantile ANOVA, robust
+correlation, robust mediation, and nonparametric ANCOVA models using
+robust location measures.")
+ (license license:gpl3)))
+
(define-public r-biasedurn
(package
(name "r-biasedurn")
--
2.34.1
N
N
Navid Afkhami wrote on 25 Aug 2023 15:12
[PATCH 2/5] gnu: Add r-statsexpressions.
(address . 65535@debbugs.gnu.org)(name . Navid Afkhami)(address . navid.afkhami@mdc-berlin.de)
61d36d8d9050a9f103785933f74e0eb74d2b999c.1692968852.git.navid.afkhami@mdc-berlin.de
* gnu/packages/cran.scm (r-statsexpressions): New variable.
---
gnu/packages/cran.scm | 44 +++++++++++++++++++++++++++++++++++++++++++
1 file changed, 44 insertions(+)

Toggle diff (57 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 667decab70..dd90da6826 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -8113,6 +8113,50 @@ (define-public r-statip
@end itemize")
(license license:gpl3)))
+(define-public r-statsexpressions
+ (package
+ (name "r-statsexpressions")
+ (version "1.5.1")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "statsExpressions" version))
+ (sha256
+ (base32
+ "1lq4h3a8yr7wnmjkg2rgr8524vdpfacr73pv4wxj44dbg9yh8l3x"))))
+ (properties `((upstream-name . "statsExpressions")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-afex
+ r-bayesfactor
+ r-correlation
+ r-datawizard
+ r-dplyr
+ r-effectsize
+ r-glue
+ r-insight
+ r-magrittr
+ r-parameters
+ r-performance
+ r-pmcmrplus
+ r-purrr
+ r-rlang
+ r-tibble
+ r-tidyr
+ r-withr
+ r-wrs2
+ r-zeallot))
+ (native-inputs (list r-knitr))
+ (home-page "https://indrajeetpatil.github.io/statsExpressions/")
+ (synopsis "Dataframes and expressions with statistical details")
+ (description
+ "Tools for creating detailed dataframes for common statistical approaches and tests.
+These include parametric, nonparametric, robust, and Bayesian t-test,
+one-way ANOVA, correlation analyses, contingency table analyses, and
+meta-analyses. The functions are pipe-friendly and provide a consistent
+syntax to work with tidy data. These dataframes additionally contain
+expressions with statistical details, and can be used in graphing packages.
+This package also forms the statistical processing backend for ggstatsplot.")
+ (license license:gpl3)))
+
(define-public r-stringdist
(package
(name "r-stringdist")
--
2.34.1
N
N
Navid Afkhami wrote on 25 Aug 2023 15:12
[PATCH 4/5] gnu: Add r-ggstatsplot.
(address . 65535@debbugs.gnu.org)(name . Navid Afkhami)(address . navid.afkhami@mdc-berlin.de)
76eab1b66c7e36ced93f1fb109f7998903cd2f17.1692968852.git.navid.afkhami@mdc-berlin.de
* gnu/packages/cran.scm (r-ggstatsplot): New variable.
---
gnu/packages/cran.scm | 43 +++++++++++++++++++++++++++++++++++++++++++
1 file changed, 43 insertions(+)

Toggle diff (56 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index d9618a9d14..d928ac1030 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -744,6 +744,49 @@ (define-public r-ggfittext
"Ggfittext is a ggplot2 extension for fitting text into boxes.")
(license license:gpl2)))
+(define-public r-ggstatsplot
+ (package
+ (name "r-ggstatsplot")
+ (version "0.12.0")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "ggstatsplot" version))
+ (sha256
+ (base32
+ "17jxvzr4dlvsakrsvblxngg60jxh0c1a0i8phqqg63nbf79ng2lk"))))
+ (properties `((upstream-name . "ggstatsplot")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-correlation
+ r-datawizard
+ r-dplyr
+ r-ggcorrplot
+ r-ggplot2
+ r-ggrepel
+ r-ggside
+ r-ggsignif
+ r-glue
+ r-insight
+ r-paletteer
+ r-parameters
+ r-patchwork
+ r-performance
+ r-purrr
+ r-rlang
+ r-statsexpressions
+ r-tidyr))
+ (native-inputs (list r-knitr))
+ (home-page "https://indrajeetpatil.github.io/ggstatsplot/")
+ (synopsis "Based plots with statistical details")
+ (description
+ "This package generates graphics with embedded details from statistical tests.
+Statistical tests included in the plots themselves. It provides an easier
+syntax to generate information-rich plots for statistical analysis of
+continuous or categorical data. Currently, it supports the most common
+types of statistical approaches and tests: parametric, nonparametric,
+robust, and Bayesian versions of t-test/ANOVA, correlation analyses,
+contingency table analysis, meta-analysis, and regression analyses.")
+ (license license:gpl3)))
+
(define-public r-glmpca
(package
(name "r-glmpca")
--
2.34.1
N
N
Navid Afkhami wrote on 25 Aug 2023 15:12
[PATCH 3/5] gnu: Add r-mc2d.
(address . 65535@debbugs.gnu.org)(name . Navid Afkhami)(address . navid.afkhami@mdc-berlin.de)
c1042e53e089afef6a76818b183eaef8f87c0821.1692968852.git.navid.afkhami@mdc-berlin.de
* gnu/packages/cran.scm (r-mc2d): New variable.
---
gnu/packages/cran.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)

Toggle diff (33 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index dd90da6826..d9618a9d14 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -2997,6 +2997,26 @@ (define-public r-mclogit
the group sizes are small.")
(license license:gpl2)))
+(define-public r-mc2d
+ (package
+ (name "r-mc2d")
+ (version "0.2.0")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "mc2d" version))
+ (sha256
+ (base32
+ "07h2gvmdfqjydikxksbqhikihg46fv6xyn8vk5kyni6x75gp9abk"))))
+ (properties `((upstream-name . "mc2d")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-ggplot2 r-ggpubr r-mvtnorm))
+ (home-page "https://cran.r-project.org/package=mc2d")
+ (synopsis "Tools for two-dimensional monte-carlo simulations")
+ (description
+ "This is a framework for construction and analysis of 2D Monte-Carlo simulations.
+In addition, this package includes various distributions.")
+ (license license:gpl2+)))
+
(define-public r-shadowtext
(package
(name "r-shadowtext")
--
2.34.1
N
N
Navid Afkhami wrote on 25 Aug 2023 15:12
[PATCH 5/5] gnu: Add r-correlation.
(address . 65535@debbugs.gnu.org)(name . Navid Afkhami)(address . navid.afkhami@mdc-berlin.de)
418c5d0cea2ae78ed8682008b86a3d36505dfacf.1692968852.git.navid.afkhami@mdc-berlin.de
* gnu/packages/cran.scm (r-correlation): New variable.
---
gnu/packages/cran.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index d928ac1030..82d674dfb8 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -363,6 +363,29 @@ (define-public r-collections
queues, stacks, deques, dicts and ordered dicts.")
(license license:expat)))
+(define-public r-correlation
+ (package
+ (name "r-correlation")
+ (version "0.8.4")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "correlation" version))
+ (sha256
+ (base32
+ "07fz7wmvrcd6b023jhj3bsrvg4w6i7f1v99jslm0gj84vzmnqzbs"))))
+ (properties `((upstream-name . "correlation")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-bayestestr r-datawizard r-insight r-parameters))
+ (native-inputs (list r-knitr))
+ (home-page "https://easystats.github.io/correlation/")
+ (synopsis "Methods for Correlation Analysis")
+ (description
+ "This ia a lightweight package for computing different kinds of correlations.
+These correlations include partial correlations, Bayesian correlations, multilevel
+correlations, polychoric correlations, biweight correlations, distance correlations
+and more.")
+ (license license:gpl3)))
+
(define-public r-cplm
(package
(name "r-cplm")
--
2.34.1
R
R
Ricardo Wurmus wrote on 28 Aug 2023 10:40
[PATCH 0/5] *** Patch for r-ggstatsplot plus its dependencies ***
(address . 65535-done@debbugs.gnu.org)
87zg2beexu.fsf@elephly.net
Thanks for the patches! I applied them all. It seems that you
committed them in the wrong order, so I couldn’t just apply the patch
series as is.

I reordered the commits so that they build on top of each other.

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 65535@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 65535
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch