[PATCH] gnu: anki: Fix preferences error.

  • Done
  • quality assurance status badge
Details
One participant
  • iyzsong
Owner
unassigned
Submitted by
iyzsong
Severity
normal
I
I
iyzsong wrote on 25 Aug 2023 14:49
(address . guix-patches@gnu.org)
0fffd709734d941c668f52f1f5ceb3aa368bdb34.1692967772.git.iyzsong@member.fsf.org
From: ??? <iyzsong@member.fsf.org>


* gnu/packages/education.scm (anki)[source]: Add snippet.
---
gnu/packages/education.scm | 7 +++++++
1 file changed, 7 insertions(+)

Toggle diff (22 lines)
diff --git a/gnu/packages/education.scm b/gnu/packages/education.scm
index bb307cf7ab..21c8a60c0b 100644
--- a/gnu/packages/education.scm
+++ b/gnu/packages/education.scm
@@ -737,6 +737,13 @@ (define-public anki
version "-source.tgz"))
(sha256
(base32 "1gfr51rnllkyzli73p4r51h5ypzfa3m7lic3m3rzpywmqwrxs07k"))
+ (modules '((guix build utils)))
+ ;; #65506 Fix preferences error.
+ (snippet '(substitute* "aqt/preferences.py"
+ (("qc\\['collapseTime']/60\\.0" x)
+ (format #f "int(~a)" x))
+ (("qc\\['timeLim']/60\\.0" x)
+ (format #f "int(~a)" x))))
(patches (search-patches "anki-mpv-args.patch"))))
(build-system gnu-build-system)
(arguments

base-commit: 1c916c167b7eb1f2f8af2cf621aa1512b00b1033
--
2.41.0
?
(address . 65533-done@debbugs.gnu.org)
877cpfphc6.fsf@envs.net
Toggle quote (28 lines)
>
> * gnu/packages/education.scm (anki)[source]: Add snippet.
> ---
> gnu/packages/education.scm | 7 +++++++
> 1 file changed, 7 insertions(+)
>
> diff --git a/gnu/packages/education.scm b/gnu/packages/education.scm
> index bb307cf7ab..21c8a60c0b 100644
> --- a/gnu/packages/education.scm
> +++ b/gnu/packages/education.scm
> @@ -737,6 +737,13 @@ (define-public anki
> version "-source.tgz"))
> (sha256
> (base32 "1gfr51rnllkyzli73p4r51h5ypzfa3m7lic3m3rzpywmqwrxs07k"))
> + (modules '((guix build utils)))
> + ;; #65506 Fix preferences error.
> + (snippet '(substitute* "aqt/preferences.py"
> + (("qc\\['collapseTime']/60\\.0" x)
> + (format #f "int(~a)" x))
> + (("qc\\['timeLim']/60\\.0" x)
> + (format #f "int(~a)" x))))
> (patches (search-patches "anki-mpv-args.patch"))))
> (build-system gnu-build-system)
> (arguments
>
> base-commit: 1c916c167b7eb1f2f8af2cf621aa1512b00b1033


Pushed now, closing.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 65533@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 65533
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch