[PATCH] gnu: r-classdiscovery: Update to 3.4.0.

  • Done
  • quality assurance status badge
Details
2 participants
  • Navid Afkhami
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Navid Afkhami
Severity
normal
N
N
Navid Afkhami wrote on 25 Aug 2023 13:15
(address . guix-patches@gnu.org)(name . Navid Afkhami)(address . navid.afkhami@mdc-berlin.de)
86f4a95a7ee7469b7e79f26a481700f6ba2d1395.1692962151.git.navid.afkhami@mdc-berlin.de
* gnu/packages/cran.scm (r-classdiscovery): Update to 3.4.0.
---
gnu/packages/cran.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

Toggle diff (28 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 43a9e11fea..9226805717 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -66,6 +66,7 @@ (define-module (gnu packages cran)
#:use-module (gnu packages algebra)
#:use-module (gnu packages autotools)
#:use-module (gnu packages base)
+ #:use-module (gnu packages bioconductor)
#:use-module (gnu packages bioinformatics)
#:use-module (gnu packages c)
#:use-module (gnu packages compression)
@@ -1630,7 +1631,7 @@ (define-public r-classdiscovery
(synopsis
"Classes and methods for \"Class Discovery\" with microarrays or proteomics")
(description
- "This package defines classes for \"class discovery\" in OOMPA project.
+ "This package defines classes for \"class discovery\" in OOMPA project.
Class discovery primarily consists of unsupervised clustering methods
with attempts to assess their statistical significance.")
(license license:asl2.0)))

base-commit: 1c916c167b7eb1f2f8af2cf621aa1512b00b1033
prerequisite-patch-id: ab9aad8c0ca60c38323f24b41dd3d5b1c3286e10
prerequisite-patch-id: c57cd1d51559f364cccdc54030deb28d7692bf48
prerequisite-patch-id: fbceb485e63c38a57a5c46288287479afe028191
--
2.34.1
N
N
Navid Afkhami wrote on 28 Aug 2023 14:34
[PATCH] gnu: Add r-classdiscovery.
(address . 65530@debbugs.gnu.org)(name . Navid Afkhami)(address . navid.afkhami@mdc-berlin.de)
97955c28991010a44b9c3579b1798fd38c20c6f5.1693226058.git.navid.afkhami@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-classdiscovery): New variable.
---
gnu/packages/bioconductor.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 0e01f3115d..81fe723779 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -13924,6 +13924,31 @@ (define-public r-enrichplot
All the visualization methods are developed based on ggplot2 graphics.")
(license license:artistic2.0)))
+;; This is a CRAN package, but it depends on Bioconductor packages and module.
+;; That is why we added it here!
+(define-public r-classdiscovery
+ (package
+ (name "r-classdiscovery")
+ (version "3.4.0")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "ClassDiscovery" version))
+ (sha256
+ (base32
+ "06l7jvpcdynij05hb0ka33zpg7xdyqyzfzx24s0bnlspp83yc62s"))))
+ (properties `((upstream-name . "ClassDiscovery")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-biobase r-cluster r-mclust r-oompabase
+ r-oompadata))
+ (home-page "http://oompa.r-forge.r-project.org/")
+ (synopsis
+ "Classes and Methods for \"Class Discovery\" with Microarrays or Proteomics")
+ (description
+ "This package defines classes for \"class discovery\" in OOMPA project.
+Class discovery primarily consists of unsupervised clustering methods
+with attempts to assess their statistical significance.")
+ (license license:asl2.0)))
+
(define-public r-clusterprofiler
(package
(name "r-clusterprofiler")

base-commit: 4a49a89b09d07d96f4d6ef3c0ca93801370f7b20
--
2.34.1
R
R
Ricardo Wurmus wrote on 28 Aug 2023 17:10
[PATCH] gnu: r-classdiscovery: Update to 3.4.0.
(address . 65530-done@debbugs.gnu.org)
87r0nndwx4.fsf@elephly.net
Thanks for the corrected patch. I’ve applied it.

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 65530@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 65530
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch